aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDan Ziemba2016-01-19 21:54:12 -0500
committerDan Ziemba2016-01-19 21:54:12 -0500
commitd5930975ac5ce7cc5183a5878dc3a38341cd09af (patch)
tree78a27166ffb6531f1b1b87f0fb0b3aeded4b5401
parent8181ac0f9fa2dbfd22c4d852d8980fd3507ca7fa (diff)
downloadaur-d5930975ac5ce7cc5183a5878dc3a38341cd09af.tar.gz
Patch for CVE-2016-0728
-rw-r--r--.SRCINFO4
-rw-r--r--KEYS-Fix-keyring-ref-leak-in-join_session_keyring.patch75
-rw-r--r--PKGBUILD6
3 files changed, 84 insertions, 1 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c122aa50597b..34a6f0fa32b7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
# Generated by mksrcinfo v8
-# Wed Jan 20 02:11:11 UTC 2016
+# Wed Jan 20 02:53:40 UTC 2016
pkgbase = linux-vfio
pkgver = 4.4
pkgrel = 4
@@ -21,6 +21,7 @@ pkgbase = linux-vfio
source = change-default-console-loglevel.patch
source = 0001-sdhci-revert.patch
source = tpmdd-devel-v3-base-platform-fix-binding-for-drivers-without-probe-callback.patch
+ source = KEYS-Fix-keyring-ref-leak-in-join_session_keyring.patch
source = override_for_missing_acs_capabilities.patch
source = i915_317.patch
sha256sums = 401d7c8fef594999a460d10c72c5a94e9c2e1022f16795ec51746b0d165418b2
@@ -31,6 +32,7 @@ pkgbase = linux-vfio
sha256sums = 1256b241cd477b265a3c2d64bdc19ffe3c9bbcee82ea3994c590c2c76e767d99
sha256sums = 5313df7cb5b4d005422bd4cd0dae956b2dadba8f3db904275aaf99ac53894375
sha256sums = ab57037ecee0a425c612babdff47c831378bca0bff063a1308599989a350226d
+ sha256sums = b6ce060a6997861e14d1061d72b96c35476e8967dd26c8020fcff4a5f0fe453d
sha256sums = 975f79348119bfba8dd972a9fbfe6b38484c45bfd228f2f6d48a0c02426ba149
sha256sums = b5a8eebbe75e1801b35d2f5197eba6f57123c224e09e97a7eb526f1fa58ac918
diff --git a/KEYS-Fix-keyring-ref-leak-in-join_session_keyring.patch b/KEYS-Fix-keyring-ref-leak-in-join_session_keyring.patch
new file mode 100644
index 000000000000..9c6a9697387d
--- /dev/null
+++ b/KEYS-Fix-keyring-ref-leak-in-join_session_keyring.patch
@@ -0,0 +1,75 @@
+From 7ca88764d45c209791e8813131c1457c2e9e51e7 Mon Sep 17 00:00:00 2001
+From: Yevgeny Pats <yevgeny@perception-point.io>
+Date: Mon, 11 Jan 2016 12:05:28 +0000
+Subject: KEYS: Fix keyring ref leak in join_session_keyring()
+
+If a thread is asked to join as a session keyring the keyring that's already
+set as its session, we leak a keyring reference.
+
+This can be tested with the following program:
+
+ #include <stddef.h>
+ #include <stdio.h>
+ #include <sys/types.h>
+ #include <keyutils.h>
+
+ int main(int argc, const char *argv[])
+ {
+ int i = 0;
+ key_serial_t serial;
+
+ serial = keyctl(KEYCTL_JOIN_SESSION_KEYRING,
+ "leaked-keyring");
+ if (serial < 0) {
+ perror("keyctl");
+ return -1;
+ }
+
+ if (keyctl(KEYCTL_SETPERM, serial,
+ KEY_POS_ALL | KEY_USR_ALL) < 0) {
+ perror("keyctl");
+ return -1;
+ }
+
+ for (i = 0; i < 100; i++) {
+ serial = keyctl(KEYCTL_JOIN_SESSION_KEYRING,
+ "leaked-keyring");
+ if (serial < 0) {
+ perror("keyctl");
+ return -1;
+ }
+ }
+
+ return 0;
+ }
+
+If, after the program has run, there something like the following line in
+/proc/keys:
+
+3f3d898f I--Q--- 100 perm 3f3f0000 0 0 keyring leaked-keyring: empty
+
+with a usage count of 100 * the number of times the program has been run,
+then the kernel is malfunctioning. If leaked-keyring has zero usages or
+has been garbage collected, then the problem is fixed.
+
+Reported-by: Yevgeny Pats <yevgeny@perception-point.io>
+Signed-off-by: David Howells <dhowells@redhat.com>
+---
+ security/keys/process_keys.c | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/security/keys/process_keys.c b/security/keys/process_keys.c
+index a3f85d2..e6d50172 100644
+--- a/security/keys/process_keys.c
++++ b/security/keys/process_keys.c
+@@ -794,6 +794,7 @@ long join_session_keyring(const char *name)
+ ret = PTR_ERR(keyring);
+ goto error2;
+ } else if (keyring == new->session_keyring) {
++ key_put(keyring);
+ ret = 0;
+ goto error2;
+ }
+--
+2.7.0.rc3
+
diff --git a/PKGBUILD b/PKGBUILD
index 3c54c06bf240..d11743e3bc69 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -20,6 +20,7 @@ source=("https://www.kernel.org/pub/linux/kernel/v4.x/${_srcname}.tar.xz"
'change-default-console-loglevel.patch'
'0001-sdhci-revert.patch'
'tpmdd-devel-v3-base-platform-fix-binding-for-drivers-without-probe-callback.patch'
+ 'KEYS-Fix-keyring-ref-leak-in-join_session_keyring.patch'
'override_for_missing_acs_capabilities.patch'
'i915_317.patch')
sha256sums=('401d7c8fef594999a460d10c72c5a94e9c2e1022f16795ec51746b0d165418b2'
@@ -30,6 +31,7 @@ sha256sums=('401d7c8fef594999a460d10c72c5a94e9c2e1022f16795ec51746b0d165418b2'
'1256b241cd477b265a3c2d64bdc19ffe3c9bbcee82ea3994c590c2c76e767d99'
'5313df7cb5b4d005422bd4cd0dae956b2dadba8f3db904275aaf99ac53894375'
'ab57037ecee0a425c612babdff47c831378bca0bff063a1308599989a350226d'
+ 'b6ce060a6997861e14d1061d72b96c35476e8967dd26c8020fcff4a5f0fe453d'
'975f79348119bfba8dd972a9fbfe6b38484c45bfd228f2f6d48a0c02426ba149'
'b5a8eebbe75e1801b35d2f5197eba6f57123c224e09e97a7eb526f1fa58ac918')
validpgpkeys=(
@@ -68,6 +70,10 @@ prepare() {
cat "${srcdir}/config" > ./.config
fi
+ # patch for CVE-2016-0728
+ # https://anonscm.debian.org/cgit/kernel/linux.git/commit/?h=jessie-security&id=0ac8c3e88cf1ea329ede357f2a01a9b1a8734e24
+ patch -Np1 -i "${srcdir}/KEYS-Fix-keyring-ref-leak-in-join_session_keyring.patch"
+
# patches for vga arbiter fix in intel systems
echo '==> Applying i915 VGA arbitration patch'
patch -Np1 -i "${srcdir}/i915_317.patch"