aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDan Ziemba2016-01-26 16:21:27 -0500
committerDan Ziemba2016-01-26 16:21:27 -0500
commit7ef0c20ffeb4067574ff947a0e7e07bdc05b152e (patch)
treeb256616443a361fdab1492a3e53cb89c74cfc77c
parent395dd26e9be85bab67ecc740881877d2660c8f54 (diff)
downloadaur-7ef0c20ffeb4067574ff947a0e7e07bdc05b152e.tar.gz
4.1.16
-rw-r--r--.SRCINFO20
-rw-r--r--KEYS-Fix-keyring-ref-leak-in-join_session_keyring.patch75
-rw-r--r--PKGBUILD16
3 files changed, 12 insertions, 99 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 37dd474b98be..95636c1a9b32 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Wed Jan 20 03:20:36 UTC 2016
+# Tue Jan 26 21:19:57 UTC 2016
pkgbase = linux-vfio-lts
- pkgver = 4.1.15
- pkgrel = 2
+ pkgver = 4.1.16
+ pkgrel = 1
url = http://www.kernel.org/
arch = i686
arch = x86_64
@@ -15,24 +15,22 @@ pkgbase = linux-vfio-lts
options = !strip
source = https://www.kernel.org/pub/linux/kernel/v4.x/linux-4.1.tar.xz
source = https://www.kernel.org/pub/linux/kernel/v4.x/linux-4.1.tar.sign
- source = https://www.kernel.org/pub/linux/kernel/v4.x/patch-4.1.15.xz
- source = https://www.kernel.org/pub/linux/kernel/v4.x/patch-4.1.15.sign
+ source = https://www.kernel.org/pub/linux/kernel/v4.x/patch-4.1.16.xz
+ source = https://www.kernel.org/pub/linux/kernel/v4.x/patch-4.1.16.sign
source = config
source = config.x86_64
source = linux.preset
source = change-default-console-loglevel.patch
- source = KEYS-Fix-keyring-ref-leak-in-join_session_keyring.patch
source = override_for_missing_acs_capabilities.patch
source = i915_317.patch
sha256sums = caf51f085aac1e1cea4d00dbbf3093ead07b551fc07b31b2a989c05f8ea72d9f
sha256sums = SKIP
- sha256sums = 0ffca8557f1aa191da2f2260ad279c9cc858e6308a8af8a76f7ca3d3c0540344
+ sha256sums = 53eb9ab07a1b23b350f899f86962a92635faf917ca2ca8554343fa3e58e565fd
sha256sums = SKIP
sha256sums = b5d6829dcb75d99fea401d9579e859a6ebb9bc09b2d6992dde171e8f05d5cbcf
sha256sums = ee55d469a4c00b6fb4144549f2a9c5b84d9fe7948c7cbd2637dce72227392b4f
sha256sums = f0d90e756f14533ee67afda280500511a62465b4f76adcc5effa95a40045179c
sha256sums = 1256b241cd477b265a3c2d64bdc19ffe3c9bbcee82ea3994c590c2c76e767d99
- sha256sums = b6ce060a6997861e14d1061d72b96c35476e8967dd26c8020fcff4a5f0fe453d
sha256sums = 975f79348119bfba8dd972a9fbfe6b38484c45bfd228f2f6d48a0c02426ba149
sha256sums = 65faab45248008810b0a5f27162101a34dfe298c14d3506e52236c680353d7f8
@@ -44,20 +42,20 @@ pkgname = linux-vfio-lts
depends = kmod
depends = mkinitcpio>=0.7
optdepends = crda: to set the correct wireless channels of your country
- provides = kernel26-vfio-lts=4.1.15
+ provides = kernel26-vfio-lts=4.1.16
conflicts = kernel26-vfio-lts
replaces = kernel26-vfio-lts
backup = etc/mkinitcpio.d/linux-vfio-lts.preset
pkgname = linux-vfio-lts-headers
pkgdesc = Header files and scripts for building modules for Linux-vfio-lts kernel
- provides = kernel26-vfio-lts-headers=4.1.15
+ provides = kernel26-vfio-lts-headers=4.1.16
conflicts = kernel26-vfio-lts-headers
replaces = kernel26-vfio-lts-headers
pkgname = linux-vfio-lts-docs
pkgdesc = Kernel hackers manual - HTML documentation that comes with the Linux-vfio-lts kernel
- provides = kernel26-vfio-lts-docs=4.1.15
+ provides = kernel26-vfio-lts-docs=4.1.16
conflicts = kernel26-vfio-lts-docs
replaces = kernel26-vfio-lts-docs
diff --git a/KEYS-Fix-keyring-ref-leak-in-join_session_keyring.patch b/KEYS-Fix-keyring-ref-leak-in-join_session_keyring.patch
deleted file mode 100644
index 9c6a9697387d..000000000000
--- a/KEYS-Fix-keyring-ref-leak-in-join_session_keyring.patch
+++ /dev/null
@@ -1,75 +0,0 @@
-From 7ca88764d45c209791e8813131c1457c2e9e51e7 Mon Sep 17 00:00:00 2001
-From: Yevgeny Pats <yevgeny@perception-point.io>
-Date: Mon, 11 Jan 2016 12:05:28 +0000
-Subject: KEYS: Fix keyring ref leak in join_session_keyring()
-
-If a thread is asked to join as a session keyring the keyring that's already
-set as its session, we leak a keyring reference.
-
-This can be tested with the following program:
-
- #include <stddef.h>
- #include <stdio.h>
- #include <sys/types.h>
- #include <keyutils.h>
-
- int main(int argc, const char *argv[])
- {
- int i = 0;
- key_serial_t serial;
-
- serial = keyctl(KEYCTL_JOIN_SESSION_KEYRING,
- "leaked-keyring");
- if (serial < 0) {
- perror("keyctl");
- return -1;
- }
-
- if (keyctl(KEYCTL_SETPERM, serial,
- KEY_POS_ALL | KEY_USR_ALL) < 0) {
- perror("keyctl");
- return -1;
- }
-
- for (i = 0; i < 100; i++) {
- serial = keyctl(KEYCTL_JOIN_SESSION_KEYRING,
- "leaked-keyring");
- if (serial < 0) {
- perror("keyctl");
- return -1;
- }
- }
-
- return 0;
- }
-
-If, after the program has run, there something like the following line in
-/proc/keys:
-
-3f3d898f I--Q--- 100 perm 3f3f0000 0 0 keyring leaked-keyring: empty
-
-with a usage count of 100 * the number of times the program has been run,
-then the kernel is malfunctioning. If leaked-keyring has zero usages or
-has been garbage collected, then the problem is fixed.
-
-Reported-by: Yevgeny Pats <yevgeny@perception-point.io>
-Signed-off-by: David Howells <dhowells@redhat.com>
----
- security/keys/process_keys.c | 1 +
- 1 file changed, 1 insertion(+)
-
-diff --git a/security/keys/process_keys.c b/security/keys/process_keys.c
-index a3f85d2..e6d50172 100644
---- a/security/keys/process_keys.c
-+++ b/security/keys/process_keys.c
-@@ -794,6 +794,7 @@ long join_session_keyring(const char *name)
- ret = PTR_ERR(keyring);
- goto error2;
- } else if (keyring == new->session_keyring) {
-+ key_put(keyring);
- ret = 0;
- goto error2;
- }
---
-2.7.0.rc3
-
diff --git a/PKGBUILD b/PKGBUILD
index 05ed28af2f64..e3e881a1c828 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,12 +2,8 @@
pkgbase=linux-vfio-lts
_srcname=linux-4.1
-# / \
-# /\ /\
-# / | \
-# SKY NET
-pkgver=4.1.15
-pkgrel=2
+pkgver=4.1.16
+pkgrel=1
arch=('i686' 'x86_64')
url="http://www.kernel.org/"
license=('GPL2')
@@ -22,19 +18,17 @@ source=("https://www.kernel.org/pub/linux/kernel/v4.x/${_srcname}.tar.xz"
# standard config files for mkinitcpio ramdisk
'linux.preset'
'change-default-console-loglevel.patch'
- 'KEYS-Fix-keyring-ref-leak-in-join_session_keyring.patch'
'override_for_missing_acs_capabilities.patch'
'i915_317.patch'
)
sha256sums=('caf51f085aac1e1cea4d00dbbf3093ead07b551fc07b31b2a989c05f8ea72d9f'
'SKIP'
- '0ffca8557f1aa191da2f2260ad279c9cc858e6308a8af8a76f7ca3d3c0540344'
+ '53eb9ab07a1b23b350f899f86962a92635faf917ca2ca8554343fa3e58e565fd'
'SKIP'
'b5d6829dcb75d99fea401d9579e859a6ebb9bc09b2d6992dde171e8f05d5cbcf'
'ee55d469a4c00b6fb4144549f2a9c5b84d9fe7948c7cbd2637dce72227392b4f'
'f0d90e756f14533ee67afda280500511a62465b4f76adcc5effa95a40045179c'
'1256b241cd477b265a3c2d64bdc19ffe3c9bbcee82ea3994c590c2c76e767d99'
- 'b6ce060a6997861e14d1061d72b96c35476e8967dd26c8020fcff4a5f0fe453d'
'975f79348119bfba8dd972a9fbfe6b38484c45bfd228f2f6d48a0c02426ba149'
'65faab45248008810b0a5f27162101a34dfe298c14d3506e52236c680353d7f8')
validpgpkeys=(
@@ -64,10 +58,6 @@ prepare() {
cat "${srcdir}/config" > ./.config
fi
- # patch for CVE-2016-0728
- # https://anonscm.debian.org/cgit/kernel/linux.git/commit/?h=jessie-security&id=0ac8c3e88cf1ea329ede357f2a01a9b1a8734e24
- patch -Np1 -i "${srcdir}/KEYS-Fix-keyring-ref-leak-in-join_session_keyring.patch"
-
# patches for vga arbiter fix in intel systems
patch -Np1 -i "${srcdir}/i915_317.patch"