summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEvgeny Myandin2021-12-22 15:43:50 +0300
committerEvgeny Myandin2021-12-22 15:43:50 +0300
commit2095c7eeabacf45494e0a49434ac0e3ae6c98f73 (patch)
tree653fa09d17a09e490fe1da4239d11c3ebb8901aa
parent77b5d21fbb305289e0de6c4973be4923380b12c5 (diff)
downloadaur-2095c7eeabacf45494e0a49434ac0e3ae6c98f73.tar.gz
new fix acs
-rw-r--r--.SRCINFO2
-rw-r--r--0999-acs.patch15
-rw-r--r--PKGBUILD2
3 files changed, 10 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6dde28bfb0c1..b2db6b07df43 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -82,7 +82,7 @@ pkgbase = linux-vfio-manjaro
sha256sums = 27471eee564ca3149dd271b0817719b5565a9594dc4d884fe3dc51a5f03832bc
sha256sums = 60e295601e4fb33d9bf65f198c54c7eb07c0d1e91e2ad1e0dd6cd6e142cb266d
sha256sums = 035ea4b2a7621054f4560471f45336b981538a40172d8f17285910d4e0e0b3ef
- sha256sums = ee1cc58be8f03d975451be70a1f55ae44c06b057173fcc882b33a6776ffe6996
+ sha256sums = e1a5de2aa63b042c5392b4f78052549df2d3e47b2ae6cee261636ab8a544705e
pkgname = linux-vfio-manjaro
pkgdesc = The Linux-vfio-manjaro kernel and modules
diff --git a/0999-acs.patch b/0999-acs.patch
index ecd43b98c8cf..95ed8a514e64 100644
--- a/0999-acs.patch
+++ b/0999-acs.patch
@@ -1,5 +1,5 @@
---- a/Documentation/admin-guide/kernel-parameters.txt 2021-12-20 11:49:22.121459738 +0300
-+++ b/Documentation/admin-guide/kernel-parameters.txt 2021-12-20 11:51:19.127255042 +0300
+--- a/Documentation/admin-guide/kernel-parameters.txt
++++ b/Documentation/admin-guide/kernel-parameters.txt
@@ -3892,6 +3892,15 @@
nomsi [MSI] If the PCI_MSI kernel config parameter is
enabled, this kernel boot option can be used to
@@ -16,8 +16,8 @@
noioapicquirk [APIC] Disable all boot interrupt quirks.
Safety option to keep boot IRQs enabled. This
should never be necessary.
---- a/drivers/pci/quirks.c 2021-10-31 23:53:10.000000000 +0300
-+++ b/drivers/pci/quirks.c 2021-12-22 15:13:44.277459777 +0300
+--- a/drivers/pci/quirks.c
++++ a/drivers/pci/quirks.c
@@ -193,6 +193,106 @@
}
fs_initcall_sync(pci_apply_final_quirks);
@@ -125,11 +125,12 @@
/*
* Decoding should be disabled for a PCI device during BAR sizing to avoid
* conflict. But doing so may cause problems on host bridge and perhaps other
-@@ -4949,6 +4949,8 @@
+@@ -4949,6 +5049,8 @@
{ PCI_VENDOR_ID_NXP, 0x8d9b, pci_quirk_nxp_rp_acs },
/* Zhaoxin Root/Downstream Ports */
{ PCI_VENDOR_ID_ZHAOXIN, PCI_ANY_ID, pci_quirk_zhaoxin_pcie_ports_acs },
-+ /* allow acs for any */
-+ { PCI_ANY_ID, PCI_ANY_ID, pcie_acs_overrides },
++ /* allow acs for any */
++ { PCI_ANY_ID, PCI_ANY_ID, pcie_acs_overrides },
{ 0 }
};
+
diff --git a/PKGBUILD b/PKGBUILD
index a8be79fdca33..b62923b0cca2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -99,7 +99,7 @@ sha256sums=('57b2cf6991910e3b67a1b3490022e8a0674b6965c74c12da1e99d138d1991ee8'
'27471eee564ca3149dd271b0817719b5565a9594dc4d884fe3dc51a5f03832bc'
'60e295601e4fb33d9bf65f198c54c7eb07c0d1e91e2ad1e0dd6cd6e142cb266d'
'035ea4b2a7621054f4560471f45336b981538a40172d8f17285910d4e0e0b3ef'
- 'ee1cc58be8f03d975451be70a1f55ae44c06b057173fcc882b33a6776ffe6996')
+ 'e1a5de2aa63b042c5392b4f78052549df2d3e47b2ae6cee261636ab8a544705e')
prepare() {
cd "linux-${_basekernel}"