summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEvgeny Myandin2021-12-23 15:38:42 +0300
committerEvgeny Myandin2021-12-23 15:38:42 +0300
commit85b7f28116f7dd636869604308c88ac9480a7673 (patch)
treefc49106d8952b5f78d3c45a7a0ce69c98cec18af
parent2095c7eeabacf45494e0a49434ac0e3ae6c98f73 (diff)
downloadaur-85b7f28116f7dd636869604308c88ac9480a7673.tar.gz
patch remastered
-rw-r--r--.SRCINFO4
-rw-r--r--0999-acs.gitpatch (renamed from 0999-acs.patch)44
-rw-r--r--PKGBUILD7
3 files changed, 31 insertions, 24 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b2db6b07df43..207c1958c247 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -49,7 +49,7 @@ pkgbase = linux-vfio-manjaro
source = 0411-bootsplash.patch
source = 0412-bootsplash.patch
source = 0413-bootsplash.gitpatch
- source = 0999-acs.patch
+ source = 0999-acs.gitpatch
sha256sums = 57b2cf6991910e3b67a1b3490022e8a0674b6965c74c12da1e99d138d1991ee8
sha256sums = bdb35ece2dd0f6d8225947b63539e70c8fc16bd28f03395d590515d8187f03c4
sha256sums = ccbfb721030426bbd148602f99c88aaf226b7a6641a9c8c56973dd25a3f1df94
@@ -82,7 +82,7 @@ pkgbase = linux-vfio-manjaro
sha256sums = 27471eee564ca3149dd271b0817719b5565a9594dc4d884fe3dc51a5f03832bc
sha256sums = 60e295601e4fb33d9bf65f198c54c7eb07c0d1e91e2ad1e0dd6cd6e142cb266d
sha256sums = 035ea4b2a7621054f4560471f45336b981538a40172d8f17285910d4e0e0b3ef
- sha256sums = e1a5de2aa63b042c5392b4f78052549df2d3e47b2ae6cee261636ab8a544705e
+ sha256sums = 6d6b327ec7c7798f628f98ab964f4457d3cf043bad2632eb8f27548478a83cc1
pkgname = linux-vfio-manjaro
pkgdesc = The Linux-vfio-manjaro kernel and modules
diff --git a/0999-acs.patch b/0999-acs.gitpatch
index 95ed8a514e64..401b27c13f1c 100644
--- a/0999-acs.patch
+++ b/0999-acs.gitpatch
@@ -1,24 +1,28 @@
+diff --git a/Documentation/admin-guide/kernel-parameters.txt b/Documentation/admin-guide/kernel-parameters.txt
+index 1396fd2..3c0ede4 100644
--- a/Documentation/admin-guide/kernel-parameters.txt
+++ b/Documentation/admin-guide/kernel-parameters.txt
@@ -3892,6 +3892,15 @@
- nomsi [MSI] If the PCI_MSI kernel config parameter is
- enabled, this kernel boot option can be used to
- disable the use of MSI interrupts system-wide.
-+ pcie_acs_override=
-+ [PCIE] Override missing PCIe ACS support for:
-+ downstream
-+ All downstream ports - full ACS capabilities
-+ multfunction
-+ All multifunction devices - multifunction ACS subset
-+ id:nnnn:nnnn
-+ Specfic device - full ACS capabilities
-+ Specified as vid:did (vendor/device ID) in hex
- noioapicquirk [APIC] Disable all boot interrupt quirks.
- Safety option to keep boot IRQs enabled. This
- should never be necessary.
+ nomsi [MSI] If the PCI_MSI kernel config parameter is
+ enabled, this kernel boot option can be used to
+ disable the use of MSI interrupts system-wide.
++ pcie_acs_override=
++ [PCIE] Override missing PCIe ACS support for:
++ downstream
++ All downstream ports - full ACS capabilities
++ multfunction
++ All multifunction devices - multifunction ACS subset
++ id:nnnn:nnnn
++ Specfic device - full ACS capabilities
++ Specified as vid:did (vendor/device ID) in hex
+ noioapicquirk [APIC] Disable all boot interrupt quirks.
+ Safety option to keep boot IRQs enabled. This
+ should never be necessary.
+diff --git a/drivers/pci/quirks.c b/drivers/pci/quirks.c
+index 4537d1e..c4f01fe 100644
--- a/drivers/pci/quirks.c
-+++ a/drivers/pci/quirks.c
-@@ -193,6 +193,106 @@
++++ b/drivers/pci/quirks.c
+@@ -193,6 +193,106 @@ static int __init pci_apply_final_quirks(void)
}
fs_initcall_sync(pci_apply_final_quirks);
@@ -125,12 +129,12 @@
/*
* Decoding should be disabled for a PCI device during BAR sizing to avoid
* conflict. But doing so may cause problems on host bridge and perhaps other
-@@ -4949,6 +5049,8 @@
+@@ -4949,6 +5049,8 @@ static const struct pci_dev_acs_enabled {
{ PCI_VENDOR_ID_NXP, 0x8d9b, pci_quirk_nxp_rp_acs },
/* Zhaoxin Root/Downstream Ports */
{ PCI_VENDOR_ID_ZHAOXIN, PCI_ANY_ID, pci_quirk_zhaoxin_pcie_ports_acs },
-+ /* allow acs for any */
-+ { PCI_ANY_ID, PCI_ANY_ID, pcie_acs_overrides },
++ /* allow acs for any */
++ { PCI_ANY_ID, PCI_ANY_ID, pcie_acs_overrides },
{ 0 }
};
diff --git a/PKGBUILD b/PKGBUILD
index b62923b0cca2..bfa2fa9ac032 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -66,7 +66,7 @@ source=("https://www.kernel.org/pub/linux/kernel/v5.x/linux-${_basekernel}.tar.x
'0411-bootsplash.patch'
'0412-bootsplash.patch'
'0413-bootsplash.gitpatch'
- '0999-acs.patch')
+ '0999-acs.gitpatch')
sha256sums=('57b2cf6991910e3b67a1b3490022e8a0674b6965c74c12da1e99d138d1991ee8'
'bdb35ece2dd0f6d8225947b63539e70c8fc16bd28f03395d590515d8187f03c4'
'ccbfb721030426bbd148602f99c88aaf226b7a6641a9c8c56973dd25a3f1df94'
@@ -99,7 +99,7 @@ sha256sums=('57b2cf6991910e3b67a1b3490022e8a0674b6965c74c12da1e99d138d1991ee8'
'27471eee564ca3149dd271b0817719b5565a9594dc4d884fe3dc51a5f03832bc'
'60e295601e4fb33d9bf65f198c54c7eb07c0d1e91e2ad1e0dd6cd6e142cb266d'
'035ea4b2a7621054f4560471f45336b981538a40172d8f17285910d4e0e0b3ef'
- 'e1a5de2aa63b042c5392b4f78052549df2d3e47b2ae6cee261636ab8a544705e')
+ '6d6b327ec7c7798f628f98ab964f4457d3cf043bad2632eb8f27548478a83cc1')
prepare() {
cd "linux-${_basekernel}"
@@ -120,6 +120,9 @@ prepare() {
msg2 "0513-bootsplash"
git apply -p1 < "../0413-bootsplash.gitpatch"
+ msg2 "0999-acs"
+ git apply -p1 < "../0999-acs.gitpatch"
+
msg2 "add config"
cat "../config" > ./.config