summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEvgeny Myandin2021-12-26 12:26:12 +0300
committerEvgeny Myandin2021-12-26 12:26:12 +0300
commitad2b76b528a2895e4c4366375576f06550083bc7 (patch)
tree02e460582803af26129ee368d4c12a30f742ca3c
parent74b207e4bf5ebb6a636919a5c6c687779e588b2a (diff)
downloadaur-ad2b76b528a2895e4c4366375576f06550083bc7.tar.gz
Change PKGBUILD and Description
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD9
2 files changed, 8 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4cb4ed924c68..8cc3a31a6153 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -91,9 +91,10 @@ pkgname = linux-vfio-manjaro
depends = kmod
depends = mkinitcpio>=27
optdepends = crda: to set the correct wireless channels of your country
- provides = linux=5.15.11
provides = VIRTUALBOX-GUEST-MODULES
provides = WIREGUARD-MODULE
+ replaces = virtualbox-guest-modules
+ replaces = wireguard
pkgname = linux-vfio-manjaro-headers
pkgdesc = Headers and scripts for building modules for the Linux Manjaro standart kernel with ACS patch
@@ -101,4 +102,3 @@ pkgname = linux-vfio-manjaro-headers
depends = python
depends = libelf
depends = pahole
- provides = linux-headers=5.15.11
diff --git a/PKGBUILD b/PKGBUILD
index 58858e2f5845..6e73a836ff42 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -156,7 +156,9 @@ package_linux-vfio-manjaro() {
pkgdesc="The Linux Manjaro standart kernel and modules with ACS patch"
depends=('coreutils' 'linux-firmware' 'kmod' 'mkinitcpio>=27')
optdepends=('crda: to set the correct wireless channels of your country')
- provides=("linux=${pkgver}" VIRTUALBOX-GUEST-MODULES WIREGUARD-MODULE)
+ provides=(VIRTUALBOX-GUEST-MODULES WIREGUARD-MODULE)
+ replaces=(virtualbox-guest-modules wireguard)
+# provides=("linux=${pkgver}${pkgrel}${_kernelname}" VIRTUALBOX-GUEST-MODULES WIREGUARD-MODULE)
cd "linux-${_basekernel}"
@@ -194,7 +196,8 @@ package_linux-vfio-manjaro() {
package_linux-vfio-manjaro-headers() {
pkgdesc="Headers and scripts for building modules for the Linux Manjaro standart kernel with ACS patch"
depends=('gawk' 'python' 'libelf' 'pahole')
- provides=("linux-headers=$pkgver")
+# provides=("")
+# provides=("linux-headers=${pkgver}${pkgrel}${_kernelname}")
cd "linux-${_basekernel}"
local _builddir="${pkgdir}/usr/lib/modules/${_kernver}/build"
@@ -260,7 +263,7 @@ package_linux-vfio-manjaro-headers() {
esac
done < <(find "${_builddir}" -type f -perm -u+x ! -name vmlinux -print0 2>/dev/null)
strip $STRIP_STATIC "${_builddir}/vmlinux"
-
+
# remove unwanted files
find ${_builddir} -name '*.orig' -delete
}