summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2021-09-12 09:38:35 -0600
committerMark Wagie2021-09-12 09:38:35 -0600
commit104690cc144cc885b4d94de6a6e269ed446e8a1b (patch)
treebf14fb00ff013abffa1f075cf05b7e7e0a1d064f
parentdb1a44fdecc29084a55aed7685fe1d1fa4587790 (diff)
downloadaur-104690cc144cc885b4d94de6a6e269ed446e8a1b.tar.gz
4.1.0
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD9
2 files changed, 10 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 683acb174900..3c7f2e54dca5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = linux-wifi-hotspot
- pkgdesc = Create virtual wifi hotspot using same wifi card which is connected to an AP + many features (a GUI tool)
- pkgver = 4.0.3
+ pkgdesc = Feature-rich wifi hotspot creator
+ pkgver = 4.1.0
pkgrel = 1
url = https://github.com/lakinduakash/linux-wifi-hotspot
install = linux-wifi-hotspot.install
@@ -21,7 +21,7 @@ pkgbase = linux-wifi-hotspot
conflicts = wihotspot
conflicts = create_ap
backup = etc/create_ap.conf
- source = linux-wifi-hotspot-4.0.3.tar.gz::https://github.com/lakinduakash/linux-wifi-hotspot/archive/v4.0.3.tar.gz
- sha256sums = 39298a46daa41ac91034564f2e0a64d4afb90d9de442f1239d8fdfc96bd14900
+ source = linux-wifi-hotspot-4.1.0.tar.gz::https://github.com/lakinduakash/linux-wifi-hotspot/archive/v4.1.0.tar.gz
+ sha256sums = 7deb1aab2545cd1c2a311e678d3c07778688e29fbf53b4f434563a64532e4c25
pkgname = linux-wifi-hotspot
diff --git a/PKGBUILD b/PKGBUILD
index de43a4ebfbc7..88b7cc42d0de 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,9 @@
# Maintainer: Mark Wagie <mark dot wagie at tutanota dot com>
# Contributor: Dimitris Kiziridis <ragouel at outlook dot com>
pkgname=linux-wifi-hotspot
-pkgver=4.0.3
+pkgver=4.1.0
pkgrel=1
-pkgdesc="Create virtual wifi hotspot using same wifi card which is connected to an AP + many features (a GUI tool)"
+pkgdesc="Feature-rich wifi hotspot creator"
arch=('x86_64' 'aarch64')
url="https://github.com/lakinduakash/linux-wifi-hotspot"
license=('BSD')
@@ -16,7 +16,7 @@ conflicts=('wihotspot' 'create_ap')
backup=('etc/create_ap.conf')
install="$pkgname.install"
source=("$pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz")
-sha256sums=('39298a46daa41ac91034564f2e0a64d4afb90d9de442f1239d8fdfc96bd14900')
+sha256sums=('7deb1aab2545cd1c2a311e678d3c07778688e29fbf53b4f434563a64532e4c25')
build() {
cd "$pkgname-$pkgver"
@@ -27,5 +27,8 @@ package() {
cd "$pkgname-$pkgver"
make DESTDIR="$pkgdir" install
+ # Fix permissions
+ chmod 750 "$pkgdir/usr/share/polkit-1/rules.d"
+
install -Dm644 LICENSE -t "$pkgdir/usr/share/licenses/$pkgname"
}