summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2020-08-28 21:25:26 -0600
committerMark Wagie2020-08-28 21:25:26 -0600
commit1b1648ee7e5a49e1e062d0a403d3b322ce306882 (patch)
tree18d4014f5eded0e4c9453a253b73e6321286d906
parentc5cf53964b1f0aa639a9d7f440f7413bfd35483c (diff)
downloadaur-1b1648ee7e5a49e1e062d0a403d3b322ce306882.tar.gz
updated to 2.1.0
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD18
2 files changed, 10 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fed97f9af371..032b113432ef 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = linux-wifi-hotspot
pkgdesc = Create virtual wifi hotspot using same wifi card which is connected to an AP + many features (a GUI tool)
- pkgver = 2.0.0+4+g61ac43a
- pkgrel = 2
+ pkgver = 2.1.0
+ pkgrel = 1
url = https://github.com/lakinduakash/linux-wifi-hotspot
install = linux-wifi-hotspot.install
arch = x86_64
@@ -19,8 +19,8 @@ pkgbase = linux-wifi-hotspot
provides = wihotspot
conflicts = wihotspot
conflicts = create_ap
- source = git+https://github.com/lakinduakash/linux-wifi-hotspot#commit=61ac43ab50b8a751d94d4ac78c2d9448fdb97a66
- sha256sums = SKIP
+ source = linux-wifi-hotspot-2.1.0.tar.gz::https://github.com/lakinduakash/linux-wifi-hotspot/archive/2.1.0.tar.gz
+ sha256sums = 36b9b9d02231f884ab6bec9fa46d8522185717067e68b32a5789d96063cc83d1
pkgname = linux-wifi-hotspot
diff --git a/PKGBUILD b/PKGBUILD
index bda3c4c435a5..6ac69f429574 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Dimitris Kiziridis <ragouel at outlook dot com>
# Co-Maintainer: Mark Wagie <mark dot wagie at tutanota dot com>
pkgname=linux-wifi-hotspot
-pkgver=2.0.0+4+g61ac43a
-pkgrel=2
+pkgver=2.1.0
+pkgrel=1
pkgdesc="Create virtual wifi hotspot using same wifi card which is connected to an AP + many features (a GUI tool)"
arch=('x86_64')
url="https://github.com/lakinduakash/linux-wifi-hotspot"
@@ -19,22 +19,16 @@ optdepends=('haveged: For random MAC generation'
provides=('wihotspot')
conflicts=('wihotspot' 'create_ap')
install="$pkgname.install"
-_commit=61ac43ab50b8a751d94d4ac78c2d9448fdb97a66
-source=("git+https://github.com/lakinduakash/linux-wifi-hotspot#commit=$_commit")
-sha256sums=('SKIP')
-
-pkgver() {
- cd "${srcdir}/${pkgname}"
- git describe --tags | sed 's/^v//;s/-/+/g'
-}
+source=("$pkgname-$pkgver.tar.gz::$url/archive/$pkgver.tar.gz")
+sha256sums=('36b9b9d02231f884ab6bec9fa46d8522185717067e68b32a5789d96063cc83d1')
build() {
- cd "${srcdir}/${pkgname}"
+ cd "${pkgname}-${pkgver}"
make
}
package() {
- cd "${srcdir}/${pkgname}"
+ cd "${pkgname}-${pkgver}"
make DESTDIR="${pkgdir}" install
install -Dm644 LICENSE -t \