summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2020-10-04 11:02:19 -0600
committerMark Wagie2020-10-04 11:02:19 -0600
commit2f2a4aec65765da62995f247c7bed4136cff151f (patch)
tree6a79271e8aea2ab88192539a785ca58595f9507d
parentcde20358432d60f13143ed0a3535abb354ebca80 (diff)
downloadaur-2f2a4aec65765da62995f247c7bed4136cff151f.tar.gz
3.0.0
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD15
2 files changed, 12 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c91c8ac96a64..24ffbea8de28 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,13 @@
pkgbase = linux-wifi-hotspot
pkgdesc = Create virtual wifi hotspot using same wifi card which is connected to an AP + many features (a GUI tool)
- pkgver = 2.1.1
+ pkgver = 3.0.0
pkgrel = 1
url = https://github.com/lakinduakash/linux-wifi-hotspot
install = linux-wifi-hotspot.install
arch = x86_64
license = BSD
- makedepends = cmake
makedepends = git
+ makedepends = glade
depends = hostapd
depends = iw
depends = gtk3
@@ -16,11 +16,13 @@ pkgbase = linux-wifi-hotspot
depends = iproute2
optdepends = haveged: For random MAC generation
optdepends = wireless_tools: if iw cannot recognize your adapter
+ optdepends = bash-completion: for bash completions
provides = wihotspot
conflicts = wihotspot
conflicts = create_ap
- source = linux-wifi-hotspot-2.1.1.tar.gz::https://github.com/lakinduakash/linux-wifi-hotspot/archive/v2.1.1.tar.gz
- sha256sums = 6d4f122630f9ebf44dbdd24d6080ddbd0b79ed5850865b78a2c556fd9371a177
+ backup = etc/create_ap.conf
+ source = linux-wifi-hotspot-3.0.0.tar.gz::https://github.com/lakinduakash/linux-wifi-hotspot/archive/v3.0.0.tar.gz
+ sha256sums = 33a24587a27b500e280da8a3d0a32008ed4b54705e021b7284d6649dfbbbf638
pkgname = linux-wifi-hotspot
diff --git a/PKGBUILD b/PKGBUILD
index 69299b9fd7db..eaded89bd5f3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Dimitris Kiziridis <ragouel at outlook dot com>
# Co-Maintainer: Mark Wagie <mark dot wagie at tutanota dot com>
pkgname=linux-wifi-hotspot
-pkgver=2.1.1
+pkgver=3.0.0
pkgrel=1
pkgdesc="Create virtual wifi hotspot using same wifi card which is connected to an AP + many features (a GUI tool)"
arch=('x86_64')
@@ -13,14 +13,16 @@ depends=('hostapd'
'procps-ng'
'dnsmasq'
'iproute2')
-makedepends=('cmake' 'git')
+makedepends=('git' 'glade')
optdepends=('haveged: For random MAC generation'
- 'wireless_tools: if iw cannot recognize your adapter')
+ 'wireless_tools: if iw cannot recognize your adapter'
+ 'bash-completion: for bash completions')
provides=('wihotspot')
conflicts=('wihotspot' 'create_ap')
+backup=('etc/create_ap.conf')
install="$pkgname.install"
source=("$pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz")
-sha256sums=('6d4f122630f9ebf44dbdd24d6080ddbd0b79ed5850865b78a2c556fd9371a177')
+sha256sums=('33a24587a27b500e280da8a3d0a32008ed4b54705e021b7284d6649dfbbbf638')
build() {
cd "${pkgname}-${pkgver}"
@@ -35,10 +37,5 @@ package() {
"${pkgdir}/usr/share/licenses/${pkgname}"
install -Dm644 src/desktop/hotspot.png \
"$pkgdir/usr/share/pixmaps/wihotspot.png"
- install -Dm644 src/desktop/wifihotspot.desktop \
- "$pkgdir/usr/share/applications/wihotspot.desktop"
-
- install -d "$pkgdir/usr/share/doc/$pkgname"
- cp -r docs/* "$pkgdir/usr/share/doc/$pkgname"
}
# vim:set ts=2 sw=2 et: