summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2020-06-30 10:16:16 -0600
committerMark Wagie2020-06-30 10:16:16 -0600
commit35ed1b22b2db135ea64766f15e73d15435671bf5 (patch)
tree7ad03c6200e711fcd9b09a6dfefee859570d2738
parenta6dd7cafd42a170906fc2614c26f7d197a311b9a (diff)
downloadaur-35ed1b22b2db135ea64766f15e73d15435671bf5.tar.gz
add iwconfig to optdepends, add docs
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD18
2 files changed, 15 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7b3f767e0ca2..5c9ffd180a9e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = linux-wifi-hotspot
pkgdesc = Create virtual wifi hotspot using same wifi card which is connected to an AP + many features (a GUI tool)
pkgver = 2.0.0
- pkgrel = 3
+ pkgrel = 4
url = https://github.com/lakinduakash/linux-wifi-hotspot
install = linux-wifi-hotspot.install
arch = x86_64
@@ -14,6 +14,7 @@ pkgbase = linux-wifi-hotspot
depends = dnsmasq
depends = iproute2
optdepends = haveged: For random MAC generation
+ optdepends = iwconfig: if iw cannot recognize your adapter
provides = create_ap
provides = wihotspot
conflicts = create_ap
diff --git a/PKGBUILD b/PKGBUILD
index 211e39004c35..ce63c3aea093 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Dimitris Kiziridis <ragouel at outlook dot com>
-
+# Co-Maintainer: Mark Wagie <mark dot wagie at tutanota dot com>
pkgname=linux-wifi-hotspot
pkgver=2.0.0
-pkgrel=3
+pkgrel=4
pkgdesc='Create virtual wifi hotspot using same wifi card which is connected to an AP + many features (a GUI tool)'
arch=('x86_64')
url='https://github.com/lakinduakash/linux-wifi-hotspot'
@@ -16,14 +16,18 @@ depends=('hostapd'
conflicts=('create_ap' 'wihotspot')
provides=('create_ap' 'wihotspot')
install="$pkgname.install"
-optdepends=('haveged: For random MAC generation')
+optdepends=('haveged: For random MAC generation'
+ 'iwconfig: if iw cannot recognize your adapter')
makedepends=('cmake')
-source=("${pkgname}-${pkgver}.tar.gz::https://github.com/lakinduakash/linux-wifi-hotspot/archive/v${pkgver}.tar.gz")
+source=("${pkgname}-${pkgver}.tar.gz::$url/archive/v${pkgver}.tar.gz")
sha256sums=('c364b3ac184f7939a8ed2d545e958791cfabc94ea9d5dcc077ca8625ef9b96c0')
prepare() {
cd "${pkgname}-${pkgver}"
+
+ # Cannot use visudo in fakeroot environment, move to install file
sed -i '15d' src/scripts/Makefile
+
sed -i "s|running_info|h_running_info|g" src/ui/h_prop.c
sed -i "s|running_info|h_running_info|g" src/ui/h_prop.h
sed -i "566s|get_running_info|get_h_running_info|" src/ui/ui.c
@@ -37,11 +41,15 @@ build() {
package() {
cd "${pkgname}-${pkgver}"
make DESTDIR="${pkgdir}" install
+
install -Dm644 LICENSE -t \
"${pkgdir}/usr/share/licenses/${pkgname}"
install -Dm644 src/desktop/hotspot.png \
"$pkgdir/usr/share/pixmaps/wihotspot.png"
install -Dm644 src/desktop/wifihotspot.desktop \
"$pkgdir/usr/share/applications/wihotspot.desktop"
+
+ install -d "$pkgdir/usr/share/doc/$pkgname"
+ cp -r docs/* "$pkgdir/usr/share/doc/$pkgname"
}
-# vim:set ts=2 sw=2 et: \ No newline at end of file
+# vim:set ts=2 sw=2 et: