summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2021-01-17 09:51:45 -0700
committerMark Wagie2021-01-17 09:51:45 -0700
commit392cbf81f9b50c8630dfee665bbc40937c08a56d (patch)
treeec952cc12c17014594371c36a62a62a4706f1cfd
parent1f5eaa4a0622524d52f6f925ac35410ef0f02a1c (diff)
downloadaur-392cbf81f9b50c8630dfee665bbc40937c08a56d.tar.gz
fix installing of service file
-rw-r--r--.SRCINFO4
-rw-r--r--.gitignore2
-rw-r--r--PKGBUILD15
-rw-r--r--linux-wifi-hotspot.install9
-rw-r--r--makefile.patch12
5 files changed, 36 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 79fcadb4796f..993b2dde9b83 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = linux-wifi-hotspot
pkgdesc = Create virtual wifi hotspot using same wifi card which is connected to an AP + many features (a GUI tool)
pkgver = 3.5.1
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/lakinduakash/linux-wifi-hotspot
install = linux-wifi-hotspot.install
arch = x86_64
@@ -20,7 +20,9 @@ pkgbase = linux-wifi-hotspot
conflicts = create_ap
backup = etc/create_ap.conf
source = linux-wifi-hotspot-3.5.1.tar.gz::https://github.com/lakinduakash/linux-wifi-hotspot/archive/v3.5.1.tar.gz
+ source = makefile.patch
sha256sums = 9a895fba33adad657142d0114c46f45a294179c5a4bb2597c2bb21165ca1e7d0
+ sha256sums = 63f9f3e73e42c4e3fcbdaf8aa71b00f2b016a3ed6ceab62809d89a83797813e9
pkgname = linux-wifi-hotspot
diff --git a/.gitignore b/.gitignore
index 4dab8d6386e3..218f7e8d23ef 100644
--- a/.gitignore
+++ b/.gitignore
@@ -5,3 +5,5 @@
!.gitignore
!PKGBUILD
!.SRCINFO
+!linux-wifi-hotspot.install
+!makefile.patch
diff --git a/PKGBUILD b/PKGBUILD
index fc493617ce29..c57130479cce 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Co-Maintainer: Mark Wagie <mark dot wagie at tutanota dot com>
pkgname=linux-wifi-hotspot
pkgver=3.5.1
-pkgrel=1
+pkgrel=2
pkgdesc="Create virtual wifi hotspot using same wifi card which is connected to an AP + many features (a GUI tool)"
arch=('x86_64')
url="https://github.com/lakinduakash/linux-wifi-hotspot"
@@ -20,8 +20,15 @@ provides=('wihotspot')
conflicts=('wihotspot' 'create_ap')
backup=('etc/create_ap.conf')
install="$pkgname.install"
-source=("$pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz")
-sha256sums=('9a895fba33adad657142d0114c46f45a294179c5a4bb2597c2bb21165ca1e7d0')
+source=("$pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz"
+ 'makefile.patch')
+sha256sums=('9a895fba33adad657142d0114c46f45a294179c5a4bb2597c2bb21165ca1e7d0'
+ '63f9f3e73e42c4e3fcbdaf8aa71b00f2b016a3ed6ceab62809d89a83797813e9')
+
+prepare() {
+ cd "${pkgname}-${pkgver}"
+ patch --forward --strip=1 --input="${srcdir}/makefile.patch"
+}
build() {
cd "${pkgname}-${pkgver}"
@@ -35,6 +42,6 @@ package() {
install -Dm644 LICENSE -t \
"${pkgdir}/usr/share/licenses/${pkgname}"
install -Dm644 src/desktop/hotspot.png \
- "$pkgdir/usr/share/pixmaps/wihotspot.png"
+ "${pkgdir}"/usr/share/pixmaps/wihotspot.png
}
# vim:set ts=2 sw=2 et:
diff --git a/linux-wifi-hotspot.install b/linux-wifi-hotspot.install
index 7dfdee544aae..d569c5bb6a2e 100644
--- a/linux-wifi-hotspot.install
+++ b/linux-wifi-hotspot.install
@@ -1,11 +1,18 @@
post_install() {
# Execute create_ap without asking for a password
echo "ALL ALL=NOPASSWD: /usr/bin/create_ap" | (sudo su -c 'EDITOR="tee -a" visudo -f /etc/sudoers.d/create_ap')
+
+ echo ""
+ echo "Start the hotspot service on startup (using your saved configuration) with:"
+ echo "systemctl enable create_ap"
+ echo ""
}
post_remove() {
sudo rm /etc/sudoers.d/create_ap
+ echo ""
echo "Optionally remove config file:"
echo "sudo rm /etc/wh.config"
-} \ No newline at end of file
+ echo ""
+}
diff --git a/makefile.patch b/makefile.patch
new file mode 100644
index 000000000000..d05e3c28b03c
--- /dev/null
+++ b/makefile.patch
@@ -0,0 +1,12 @@
+diff --unified --recursive --text linux-wifi-hotspot-3.5.1.orig/src/scripts/Makefile linux-wifi-hotspot-3.5.1.new/src/scripts/Makefile
+--- linux-wifi-hotspot-3.5.1.orig/src/scripts/Makefile 2020-11-13 17:02:11.000000000 -0700
++++ linux-wifi-hotspot-3.5.1.new/src/scripts/Makefile 2021-01-17 09:44:36.708721295 -0700
+@@ -9,7 +9,7 @@
+ install:
+ install -CDm755 create_ap $(DESTDIR)$(BINDIR)/create_ap
+ install -CDm644 create_ap.conf $(DESTDIR)/etc/create_ap.conf
+- [ ! -d $(DESTDIR)/lib/systemd/system ] || install -CDm644 create_ap.service $(DESTDIR)/lib/systemd/system/create_ap.service
++ install -CDm644 create_ap.service $(DESTDIR)$(PREFIX)/lib/systemd/system/create_ap.service
+ install -CDm644 bash_completion $(DESTDIR)$(PREFIX)/share/bash-completion/completions/create_ap
+ install -CDm644 README.md $(DESTDIR)$(PREFIX)/share/doc/create_ap/README.md
+ install -CDm755 wihotspot $(DESTDIR)$(BINDIR)/wihotspot