summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDimitris Kiziridis2020-05-26 14:52:17 +0300
committerDimitris Kiziridis2020-05-26 14:52:17 +0300
commit42857b3c8feb5ba444292967e5fb0be02d4a30a4 (patch)
tree6012c7e9328a511ca27079ba7accebf4512d5b36
parent16ff2b379b48642f8ebe11441abefb959ce3465c (diff)
downloadaur-42857b3c8feb5ba444292967e5fb0be02d4a30a4.tar.gz
Update to 2.0.0
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD23
-rw-r--r--hotspot.pngbin0 -> 1880 bytes
3 files changed, 18 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index facecde07cbd..fdc1dad8b683 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = linux-wifi-hotspot
pkgdesc = Create virtual wifi hotspot using same wifi card which is connected to an AP + many features (a GUI tool)
- pkgver = 1.9
- pkgrel = 3
+ pkgver = 2.0.0
+ pkgrel = 1
url = https://github.com/lakinduakash/linux-wifi-hotspot
arch = x86_64
license = BSD
@@ -12,16 +12,14 @@ pkgbase = linux-wifi-hotspot
depends = gtk3
depends = gksu
depends = procps-ng
- depends = util-linux
depends = dnsmasq
- depends = iptables
optdepends = haveged: For random MAC generation
provides = create_ap
provides = wihotspot
conflicts = create_ap
- source = linux-wifi-hotspot-1.9.tar.gz::https://github.com/lakinduakash/linux-wifi-hotspot/archive/wihotspot-1.9.tar.gz
+ source = linux-wifi-hotspot-2.0.0.tar.gz::https://github.com/lakinduakash/linux-wifi-hotspot/archive/v2.0.0.tar.gz
source = https://github.com/lakinduakash/linux-wifi-hotspot/raw/master/src/desktop/hotspot.png
- sha256sums = 964166d2411395ae0b8d5042ea367ceecc5a43c31251682c465044cc4a01fdd8
+ sha256sums = c364b3ac184f7939a8ed2d545e958791cfabc94ea9d5dcc077ca8625ef9b96c0
sha256sums = 00b1f5a4c225ea83d8cd1036d57de17a41c4428b667818180eea45610147b5b9
pkgname = linux-wifi-hotspot
diff --git a/PKGBUILD b/PKGBUILD
index fc2aa9ea39e3..f6a519defe2d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Dimitris Kiziridis <ragouel at outlook dot com>
pkgname=linux-wifi-hotspot
-pkgver=1.9
-pkgrel=3
+pkgver=2.0.0
+pkgrel=1
pkgdesc='Create virtual wifi hotspot using same wifi card which is connected to an AP + many features (a GUI tool)'
arch=('x86_64')
url='https://github.com/lakinduakash/linux-wifi-hotspot'
@@ -12,25 +12,30 @@ depends=('hostapd'
'gtk3'
'gksu'
'procps-ng'
- 'util-linux'
- 'dnsmasq'
- 'iptables')
+ 'dnsmasq')
conflicts=('create_ap')
provides=('create_ap' 'wihotspot')
optdepends=('haveged: For random MAC generation')
makedepends=('cmake' 'gendesk')
-source=("${pkgname}-${pkgver}.tar.gz::https://github.com/lakinduakash/linux-wifi-hotspot/archive/wihotspot-${pkgver}.tar.gz"
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/lakinduakash/linux-wifi-hotspot/archive/v${pkgver}.tar.gz"
'https://github.com/lakinduakash/linux-wifi-hotspot/raw/master/src/desktop/hotspot.png')
-sha256sums=('964166d2411395ae0b8d5042ea367ceecc5a43c31251682c465044cc4a01fdd8'
+sha256sums=('c364b3ac184f7939a8ed2d545e958791cfabc94ea9d5dcc077ca8625ef9b96c0'
'00b1f5a4c225ea83d8cd1036d57de17a41c4428b667818180eea45610147b5b9')
+prepare() {
+ cd "${pkgname}-${pkgver}"
+ sed -i "s|running_info|h_running_info|g" src/ui/h_prop.c
+ sed -i "s|running_info|h_running_info|g" src/ui/h_prop.h
+ sed -i "566s|get_running_info|get_h_running_info|" src/ui/ui.c
+}
+
build() {
- cd "${pkgname}-wihotspot-${pkgver}"
+ cd "${pkgname}-${pkgver}"
make
}
package() {
- cd "${pkgname}-wihotspot-${pkgver}"
+ cd "${pkgname}-${pkgver}"
make DESTDIR="${pkgdir}" install
install -Dm644 LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"
install -Dm644 ${srcdir}/hotspot.png "${pkgdir}/usr/share/pixmaps/wihotspot.png"
diff --git a/hotspot.png b/hotspot.png
new file mode 100644
index 000000000000..dc4fa202e2ec
--- /dev/null
+++ b/hotspot.png
Binary files differ