summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2021-10-18 13:47:05 -0600
committerMark Wagie2021-10-18 13:47:05 -0600
commit96aaa4f5c5e0ef25e102217c387464273f2a68df (patch)
tree60fa048c0480bfaf6bd29019e6fcc66ff5e0394a
parentf22b56d65468cdce448db40baaf06862d04497ea (diff)
downloadaur-96aaa4f5c5e0ef25e102217c387464273f2a68df.tar.gz
4.3.2
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD9
2 files changed, 10 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6f559fc774f1..074f71c806d9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,19 @@
pkgbase = linux-wifi-hotspot
pkgdesc = Feature-rich wifi hotspot creator
- pkgver = 4.2.1
+ pkgver = 4.3.2
pkgrel = 1
url = https://github.com/lakinduakash/linux-wifi-hotspot
install = linux-wifi-hotspot.install
arch = x86_64
arch = aarch64
license = BSD
+ depends = dnsmasq
+ depends = gtk3
depends = hostapd
+ depends = iproute2
depends = iw
- depends = gtk3
depends = procps-ng
- depends = dnsmasq
- depends = iproute2
+ depends = qrencode
optdepends = haveged: For random MAC generation
optdepends = wireless_tools: if iw cannot recognize your adapter
optdepends = bash-completion: for bash completions
@@ -21,7 +22,7 @@ pkgbase = linux-wifi-hotspot
conflicts = wihotspot
conflicts = create_ap
backup = etc/create_ap.conf
- source = linux-wifi-hotspot-4.2.1.tar.gz::https://github.com/lakinduakash/linux-wifi-hotspot/archive/v4.2.1.tar.gz
- sha256sums = 21434d165af7e76a9b9ab86523e24a063696b1daa087213c72a4443ae5976804
+ source = linux-wifi-hotspot-4.3.2.tar.gz::https://github.com/lakinduakash/linux-wifi-hotspot/archive/v4.3.2.tar.gz
+ sha256sums = ffc65f24a3a8bc3f023c7407fd6eb44b7028d6a2f5a9471ef62904980b09a976
pkgname = linux-wifi-hotspot
diff --git a/PKGBUILD b/PKGBUILD
index 2ef7537cbb20..0315b575f8d5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,13 @@
# Maintainer: Mark Wagie <mark dot wagie at tutanota dot com>
# Contributor: Dimitris Kiziridis <ragouel at outlook dot com>
pkgname=linux-wifi-hotspot
-pkgver=4.2.1
+pkgver=4.3.2
pkgrel=1
pkgdesc="Feature-rich wifi hotspot creator"
arch=('x86_64' 'aarch64')
url="https://github.com/lakinduakash/linux-wifi-hotspot"
license=('BSD')
-depends=('hostapd' 'iw' 'gtk3' 'procps-ng' 'dnsmasq' 'iproute2')
+depends=('dnsmasq' 'gtk3' 'hostapd' 'iproute2' 'iw' 'procps-ng' 'qrencode')
optdepends=('haveged: For random MAC generation'
'wireless_tools: if iw cannot recognize your adapter'
'bash-completion: for bash completions')
@@ -16,7 +16,7 @@ conflicts=('wihotspot' 'create_ap')
backup=('etc/create_ap.conf')
install="$pkgname.install"
source=("$pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz")
-sha256sums=('21434d165af7e76a9b9ab86523e24a063696b1daa087213c72a4443ae5976804')
+sha256sums=('ffc65f24a3a8bc3f023c7407fd6eb44b7028d6a2f5a9471ef62904980b09a976')
prepare() {
cd "$pkgname-$pkgver"
@@ -32,8 +32,5 @@ package() {
cd "$pkgname-$pkgver"
make DESTDIR="$pkgdir" install
- # Fix permissions
- chmod 750 "$pkgdir/usr/share/polkit-1/rules.d"
-
install -Dm644 LICENSE -t "$pkgdir/usr/share/licenses/$pkgname"
}