summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDimitris Kiziridis2020-05-06 02:26:07 +0300
committerDimitris Kiziridis2020-05-06 02:26:07 +0300
commit9c5b0623002e8392aea1ed949cf5fbf71273c375 (patch)
treebd8d6c1c8c2566417557449fc9611e8e83f6edce
downloadaur-9c5b0623002e8392aea1ed949cf5fbf71273c375.tar.gz
Initial commit
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD29
2 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..56eed9f1573a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = linux-wifi-hotspot
+ pkgdesc = Create virtual wifi hotspot using same wifi card which is connected to an AP + many features (a GUI tool)
+ pkgver = 1.9
+ pkgrel = 1
+ url = https://github.com/lakinduakash/linux-wifi-hotspot
+ arch = any
+ license = BSD-2-Clause
+ makedepends = gendesk
+ depends = hostapd
+ depends = iw
+ depends = gtk3
+ optdepends = haveged: For random MAC generation
+ provides = wihotspot
+ source = linux-wifi-hotspot-1.9.tar.gz::https://github.com/lakinduakash/linux-wifi-hotspot/archive/wihotspot-1.9.tar.gz
+ sha256sums = 964166d2411395ae0b8d5042ea367ceecc5a43c31251682c465044cc4a01fdd8
+
+pkgname = linux-wifi-hotspot
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f36b95928bf5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Dimitris Kiziridis <ragouel at outlook dot com>
+
+pkgname=linux-wifi-hotspot
+pkgver=1.9
+pkgrel=1
+pkgdesc='Create virtual wifi hotspot using same wifi card which is connected to an AP + many features (a GUI tool)'
+arch=('any')
+url='https://github.com/lakinduakash/linux-wifi-hotspot'
+license=('BSD-2-Clause')
+depends=('hostapd'
+ 'iw'
+ 'gtk3')
+optdepends=('haveged: For random MAC generation')
+makedepends=('gendesk')
+provides=('wihotspot')
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/lakinduakash/linux-wifi-hotspot/archive/wihotspot-${pkgver}.tar.gz")
+sha256sums=('964166d2411395ae0b8d5042ea367ceecc5a43c31251682c465044cc4a01fdd8')
+
+build() {
+ cd "${pkgname}-wihotspot-${pkgver}"
+ make
+}
+
+package() {
+ cd "${pkgname}-wihotspot-${pkgver}"
+ make DESTDIR="${pkgdir}" install
+ install -Dm644 LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"
+}
+# vim:set ts=2 sw=2 et: \ No newline at end of file