summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDimitris Kiziridis2020-05-06 06:19:02 +0300
committerDimitris Kiziridis2020-05-06 06:19:02 +0300
commita83535dd276b1a773bbcf82a16ee2afbdf657651 (patch)
treef37904463042e484adaf2d9124df868892286760
parent9c5b0623002e8392aea1ed949cf5fbf71273c375 (diff)
downloadaur-a83535dd276b1a773bbcf82a16ee2afbdf657651.tar.gz
fix broken pkgbuild
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD28
2 files changed, 30 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 56eed9f1573a..8eb557937464 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,25 @@
pkgbase = linux-wifi-hotspot
pkgdesc = Create virtual wifi hotspot using same wifi card which is connected to an AP + many features (a GUI tool)
pkgver = 1.9
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/lakinduakash/linux-wifi-hotspot
- arch = any
+ arch = x86_64
license = BSD-2-Clause
+ makedepends = cmake
makedepends = gendesk
depends = hostapd
depends = iw
depends = gtk3
+ depends = libx11
+ depends = gksu
optdepends = haveged: For random MAC generation
+ provides = create_ap
provides = wihotspot
+ conflicts = create_ap
source = linux-wifi-hotspot-1.9.tar.gz::https://github.com/lakinduakash/linux-wifi-hotspot/archive/wihotspot-1.9.tar.gz
+ source = https://github.com/lakinduakash/linux-wifi-hotspot/raw/master/src/desktop/hotspot.png
sha256sums = 964166d2411395ae0b8d5042ea367ceecc5a43c31251682c465044cc4a01fdd8
+ sha256sums = 00b1f5a4c225ea83d8cd1036d57de17a41c4428b667818180eea45610147b5b9
pkgname = linux-wifi-hotspot
diff --git a/PKGBUILD b/PKGBUILD
index f36b95928bf5..e714f3c016b2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,19 +2,24 @@
pkgname=linux-wifi-hotspot
pkgver=1.9
-pkgrel=1
+pkgrel=2
pkgdesc='Create virtual wifi hotspot using same wifi card which is connected to an AP + many features (a GUI tool)'
-arch=('any')
+arch=('x86_64')
url='https://github.com/lakinduakash/linux-wifi-hotspot'
license=('BSD-2-Clause')
depends=('hostapd'
'iw'
- 'gtk3')
+ 'gtk3'
+ 'libx11'
+ 'gksu')
+conflicts=('create_ap')
+provides=('create_ap' 'wihotspot')
optdepends=('haveged: For random MAC generation')
-makedepends=('gendesk')
-provides=('wihotspot')
-source=("${pkgname}-${pkgver}.tar.gz::https://github.com/lakinduakash/linux-wifi-hotspot/archive/wihotspot-${pkgver}.tar.gz")
-sha256sums=('964166d2411395ae0b8d5042ea367ceecc5a43c31251682c465044cc4a01fdd8')
+makedepends=('cmake' 'gendesk')
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/lakinduakash/linux-wifi-hotspot/archive/wihotspot-${pkgver}.tar.gz"
+ 'https://github.com/lakinduakash/linux-wifi-hotspot/raw/master/src/desktop/hotspot.png')
+sha256sums=('964166d2411395ae0b8d5042ea367ceecc5a43c31251682c465044cc4a01fdd8'
+ '00b1f5a4c225ea83d8cd1036d57de17a41c4428b667818180eea45610147b5b9')
build() {
cd "${pkgname}-wihotspot-${pkgver}"
@@ -25,5 +30,14 @@ package() {
cd "${pkgname}-wihotspot-${pkgver}"
make DESTDIR="${pkgdir}" install
install -Dm644 LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"
+ install -Dm644 ${srcdir}/hotspot.png "${pkgdir}/usr/share/pixmaps/wihotspot.png"
+ gendesk -f -n --pkgname "${pkgname}" \
+ --pkgdesc "$pkgdesc" \
+ --name "WifiHotspot" \
+ --comment "$pkgdesc" \
+ --exec 'gksudo -g wihotspot' \
+ --categories 'System;' \
+ --icon wihotspot
+ install -Dm644 ${pkgname}.desktop -t "${pkgdir}/usr/share/applications/"
}
# vim:set ts=2 sw=2 et: \ No newline at end of file