summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2021-07-25 08:04:26 -0600
committerMark Wagie2021-07-25 08:04:26 -0600
commitdb1a44fdecc29084a55aed7685fe1d1fa4587790 (patch)
treec9c545ab266e4d0fa20203075799cb3f88d5493f
parent408d9ce1879f4b70ffdca05f397abff782c85fc7 (diff)
downloadaur-db1a44fdecc29084a55aed7685fe1d1fa4587790.tar.gz
add aarch64
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD12
-rw-r--r--linux-wifi-hotspot.install24
3 files changed, 19 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 38e1b9287dca..683acb174900 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -5,6 +5,7 @@ pkgbase = linux-wifi-hotspot
url = https://github.com/lakinduakash/linux-wifi-hotspot
install = linux-wifi-hotspot.install
arch = x86_64
+ arch = aarch64
license = BSD
depends = hostapd
depends = iw
@@ -24,4 +25,3 @@ pkgbase = linux-wifi-hotspot
sha256sums = 39298a46daa41ac91034564f2e0a64d4afb90d9de442f1239d8fdfc96bd14900
pkgname = linux-wifi-hotspot
-
diff --git a/PKGBUILD b/PKGBUILD
index fd9b6ccf777f..de43a4ebfbc7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@ pkgname=linux-wifi-hotspot
pkgver=4.0.3
pkgrel=1
pkgdesc="Create virtual wifi hotspot using same wifi card which is connected to an AP + many features (a GUI tool)"
-arch=('x86_64')
+arch=('x86_64' 'aarch64')
url="https://github.com/lakinduakash/linux-wifi-hotspot"
license=('BSD')
depends=('hostapd' 'iw' 'gtk3' 'procps-ng' 'dnsmasq' 'iproute2')
@@ -19,13 +19,13 @@ source=("$pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz")
sha256sums=('39298a46daa41ac91034564f2e0a64d4afb90d9de442f1239d8fdfc96bd14900')
build() {
- cd "$pkgname-$pkgver"
- make
+ cd "$pkgname-$pkgver"
+ make
}
package() {
- cd "$pkgname-$pkgver"
- make DESTDIR="$pkgdir" install
+ cd "$pkgname-$pkgver"
+ make DESTDIR="$pkgdir" install
- install -Dm644 LICENSE -t "$pkgdir/usr/share/licenses/$pkgname"
+ install -Dm644 LICENSE -t "$pkgdir/usr/share/licenses/$pkgname"
}
diff --git a/linux-wifi-hotspot.install b/linux-wifi-hotspot.install
index 2315a69693ac..5502bfb47169 100644
--- a/linux-wifi-hotspot.install
+++ b/linux-wifi-hotspot.install
@@ -1,21 +1,21 @@
post_install() {
- echo ""
- echo "Start the hotspot service on startup (using your saved configuration) with:"
- echo "systemctl enable --now create_ap"
- echo ""
+ echo ""
+ echo "Start the hotspot service on startup (using your saved configuration) with:"
+ echo "systemctl enable --now create_ap"
+ echo ""
}
post_upgrade() {
- # Remove old file from previous versions if existing
- if [ -f /etc/sudoers.d/create_ap ]; then
- rm /etc/sudoers.d/create_ap
- fi
+ # Remove old file from previous versions if existing
+ if [ -f /etc/sudoers.d/create_ap ]; then
+ rm /etc/sudoers.d/create_ap
+ fi
}
post_remove() {
- echo ""
- echo "Optionally remove config file:"
- echo "sudo rm /etc/wh.config"
- echo ""
+ echo ""
+ echo "Optionally remove config file:"
+ echo "sudo rm /etc/wh.config"
+ echo ""
}