summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2021-01-17 16:06:59 -0700
committerMark Wagie2021-01-17 16:06:59 -0700
commitdb9fff4dec97178de57b8a780aaf37308ff67175 (patch)
tree86a21de95ae415e4f5efd4c65bfdbc686ff777bd
parent392cbf81f9b50c8630dfee665bbc40937c08a56d (diff)
downloadaur-db9fff4dec97178de57b8a780aaf37308ff67175.tar.gz
3.6.0
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD16
-rw-r--r--makefile.patch57
3 files changed, 67 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 993b2dde9b83..1deaa20199f0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = linux-wifi-hotspot
pkgdesc = Create virtual wifi hotspot using same wifi card which is connected to an AP + many features (a GUI tool)
- pkgver = 3.5.1
- pkgrel = 2
+ pkgver = 3.6.0
+ pkgrel = 1
url = https://github.com/lakinduakash/linux-wifi-hotspot
install = linux-wifi-hotspot.install
arch = x86_64
@@ -16,13 +16,14 @@ pkgbase = linux-wifi-hotspot
optdepends = wireless_tools: if iw cannot recognize your adapter
optdepends = bash-completion: for bash completions
provides = wihotspot
+ provides = create_ap
conflicts = wihotspot
conflicts = create_ap
backup = etc/create_ap.conf
- source = linux-wifi-hotspot-3.5.1.tar.gz::https://github.com/lakinduakash/linux-wifi-hotspot/archive/v3.5.1.tar.gz
+ source = linux-wifi-hotspot-3.6.0.tar.gz::https://github.com/lakinduakash/linux-wifi-hotspot/archive/v3.6.0.tar.gz
source = makefile.patch
- sha256sums = 9a895fba33adad657142d0114c46f45a294179c5a4bb2597c2bb21165ca1e7d0
- sha256sums = 63f9f3e73e42c4e3fcbdaf8aa71b00f2b016a3ed6ceab62809d89a83797813e9
+ sha256sums = a3020ded511c57d24ad97a257878bf024bb6483860721d97bb8fb62c132d8de0
+ sha256sums = 0b7a043231d07cc5e14efb3b3c2541caac037cece882b3ca9891b0fe169ff942
pkgname = linux-wifi-hotspot
diff --git a/PKGBUILD b/PKGBUILD
index c57130479cce..db9ee37fe223 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Dimitris Kiziridis <ragouel at outlook dot com>
# Co-Maintainer: Mark Wagie <mark dot wagie at tutanota dot com>
pkgname=linux-wifi-hotspot
-pkgver=3.5.1
-pkgrel=2
+pkgver=3.6.0
+pkgrel=1
pkgdesc="Create virtual wifi hotspot using same wifi card which is connected to an AP + many features (a GUI tool)"
arch=('x86_64')
url="https://github.com/lakinduakash/linux-wifi-hotspot"
@@ -16,14 +16,14 @@ depends=('hostapd'
optdepends=('haveged: For random MAC generation'
'wireless_tools: if iw cannot recognize your adapter'
'bash-completion: for bash completions')
-provides=('wihotspot')
+provides=('wihotspot' 'create_ap')
conflicts=('wihotspot' 'create_ap')
backup=('etc/create_ap.conf')
install="$pkgname.install"
source=("$pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz"
'makefile.patch')
-sha256sums=('9a895fba33adad657142d0114c46f45a294179c5a4bb2597c2bb21165ca1e7d0'
- '63f9f3e73e42c4e3fcbdaf8aa71b00f2b016a3ed6ceab62809d89a83797813e9')
+sha256sums=('a3020ded511c57d24ad97a257878bf024bb6483860721d97bb8fb62c132d8de0'
+ '0b7a043231d07cc5e14efb3b3c2541caac037cece882b3ca9891b0fe169ff942')
prepare() {
cd "${pkgname}-${pkgver}"
@@ -39,9 +39,7 @@ package() {
cd "${pkgname}-${pkgver}"
make DESTDIR="${pkgdir}" install
- install -Dm644 LICENSE -t \
- "${pkgdir}/usr/share/licenses/${pkgname}"
- install -Dm644 src/desktop/hotspot.png \
- "${pkgdir}"/usr/share/pixmaps/wihotspot.png
+ install -Dm644 LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"
}
+
# vim:set ts=2 sw=2 et:
diff --git a/makefile.patch b/makefile.patch
index d05e3c28b03c..c7e33ed0e12d 100644
--- a/makefile.patch
+++ b/makefile.patch
@@ -1,6 +1,48 @@
-diff --unified --recursive --text linux-wifi-hotspot-3.5.1.orig/src/scripts/Makefile linux-wifi-hotspot-3.5.1.new/src/scripts/Makefile
---- linux-wifi-hotspot-3.5.1.orig/src/scripts/Makefile 2020-11-13 17:02:11.000000000 -0700
-+++ linux-wifi-hotspot-3.5.1.new/src/scripts/Makefile 2021-01-17 09:44:36.708721295 -0700
+diff --unified --recursive --text linux-wifi-hotspot-3.6.0.orig/src/desktop/wifihotspot.desktop linux-wifi-hotspot-3.6.0.new/src/desktop/wifihotspot.desktop
+--- linux-wifi-hotspot-3.6.0.orig/src/desktop/wifihotspot.desktop 2021-01-17 14:06:48.000000000 -0700
++++ linux-wifi-hotspot-3.6.0.new/src/desktop/wifihotspot.desktop 2021-01-17 15:49:58.492871071 -0700
+@@ -2,7 +2,7 @@
+ Type=Application
+ Name=Wifi Hotspot
+ Comment=feature-rich wifi hotspot creator
+-Icon=/usr/share/wihotspot/hotspot.png
++Icon=wihotspot
+ Exec=sh -c 'env DISPLAY=$DISPLAY XAUTHORITY=$XAUTHORITY /usr/bin/wihotspot'
+ Terminal=false
+ Categories=System
+diff --unified --recursive --text linux-wifi-hotspot-3.6.0.orig/src/Makefile linux-wifi-hotspot-3.6.0.new/src/Makefile
+--- linux-wifi-hotspot-3.6.0.orig/src/Makefile 2021-01-17 14:06:48.000000000 -0700
++++ linux-wifi-hotspot-3.6.0.new/src/Makefile 2021-01-17 15:59:13.791901354 -0700
+@@ -31,7 +31,7 @@
+ resources.c: ui/glade/wifih.gresource.xml ui/glade/wifih.ui
+ $(GLIB_COMPILE_RESOURCES) ui/glade/wifih.gresource.xml --target=ui/$@ --sourcedir=ui/glade --generate-source
+ @$(MAKE) -f $(THIS_FILE) wihotspot-gui
+-
++
+ $(ODIR)/%.o: ui/%.c
+ $(CC) -c -o $@ $< $(CFLAGS)
+
+@@ -42,9 +42,7 @@
+ $(CC) -o $(ODIR)/$@ $^ $(CFLAGS) $(LIBS)
+
+ install: $(ODIR)/wihotspot-gui
+- mkdir -p $(DESTDIR)$(APP_DIR)
+- install -Dm644 desktop/hotspot.png $(DESTDIR)$(APP_DIR)/hotspot.png
+- install -Dm644 desktop/wifihotspot.desktop $(DESTDIR)$(APP_DIR)/$(APP_NAME).desktop
++ install -Dm644 desktop/hotspot.png $(DESTDIR)$(PREFIX)/share/pixmaps/wihotspot.png
+ install -Dm644 desktop/wifihotspot.desktop $(DESTDIR)$(PREFIX)/share/applications/$(APP_NAME).desktop
+ install -Dm755 $(ODIR)/wihotspot-gui $(DESTDIR)$(BINDIR)/$(APP_GUI_BINARY)
+ cd scripts && $(MAKE) install
+@@ -64,4 +62,4 @@
+ clean:
+ rm -f $(ODIR)/*.o
+ rm -f ui/$(BUILT_SRC)
+- rm -f $(ODIR)/wihotspot-gui
+\ No newline at end of file
++ rm -f $(ODIR)/wihotspot-gui
+diff --unified --recursive --text linux-wifi-hotspot-3.6.0.orig/src/scripts/Makefile linux-wifi-hotspot-3.6.0.new/src/scripts/Makefile
+--- linux-wifi-hotspot-3.6.0.orig/src/scripts/Makefile 2021-01-17 14:06:48.000000000 -0700
++++ linux-wifi-hotspot-3.6.0.new/src/scripts/Makefile 2021-01-17 15:53:05.076540423 -0700
@@ -9,7 +9,7 @@
install:
install -CDm755 create_ap $(DESTDIR)$(BINDIR)/create_ap
@@ -10,3 +52,12 @@ diff --unified --recursive --text linux-wifi-hotspot-3.5.1.orig/src/scripts/Make
install -CDm644 bash_completion $(DESTDIR)$(PREFIX)/share/bash-completion/completions/create_ap
install -CDm644 README.md $(DESTDIR)$(PREFIX)/share/doc/create_ap/README.md
install -CDm755 wihotspot $(DESTDIR)$(BINDIR)/wihotspot
+@@ -17,7 +17,7 @@
+ install-cli-only:
+ install -CDm755 create_ap $(DESTDIR)$(BINDIR)/create_ap
+ install -CDm644 create_ap.conf $(DESTDIR)/etc/create_ap.conf
+- [ ! -d $(DESTDIR)/lib/systemd/system ] || install -CDm644 create_ap.service $(DESTDIR)/lib/systemd/system/create_ap.service
++ install -CDm644 create_ap.service $(DESTDIR)$(PREFIX)/lib/systemd/system/create_ap.service
+ install -CDm644 bash_completion $(DESTDIR)$(PREFIX)/share/bash-completion/completions/create_ap
+ install -CDm644 README.md $(DESTDIR)$(PREFIX)/share/doc/create_ap/README.md
+