summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDimitris Kiziridis2020-05-26 20:16:44 +0300
committerDimitris Kiziridis2020-05-26 20:16:44 +0300
commitefe756585e64fce80271e9a775f417b5277be43a (patch)
treececa59e4a62e07ba8dd6ceff188c6fde159da4f5
parent42857b3c8feb5ba444292967e5fb0be02d4a30a4 (diff)
downloadaur-efe756585e64fce80271e9a775f417b5277be43a.tar.gz
update pkgbuild
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD34
-rw-r--r--hotspot.pngbin1880 -> 0 bytes
-rw-r--r--linux-wifi-hotspot.install11
4 files changed, 30 insertions, 24 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fdc1dad8b683..93e4686d8cdf 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,26 +1,25 @@
pkgbase = linux-wifi-hotspot
pkgdesc = Create virtual wifi hotspot using same wifi card which is connected to an AP + many features (a GUI tool)
pkgver = 2.0.0
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/lakinduakash/linux-wifi-hotspot
+ install = linux-wifi-hotspot.install
arch = x86_64
license = BSD
makedepends = cmake
- makedepends = gendesk
depends = hostapd
depends = iw
depends = gtk3
- depends = gksu
depends = procps-ng
depends = dnsmasq
+ depends = iproute2
optdepends = haveged: For random MAC generation
provides = create_ap
provides = wihotspot
conflicts = create_ap
+ conflicts = wihotspot
source = linux-wifi-hotspot-2.0.0.tar.gz::https://github.com/lakinduakash/linux-wifi-hotspot/archive/v2.0.0.tar.gz
- source = https://github.com/lakinduakash/linux-wifi-hotspot/raw/master/src/desktop/hotspot.png
sha256sums = c364b3ac184f7939a8ed2d545e958791cfabc94ea9d5dcc077ca8625ef9b96c0
- sha256sums = 00b1f5a4c225ea83d8cd1036d57de17a41c4428b667818180eea45610147b5b9
pkgname = linux-wifi-hotspot
diff --git a/PKGBUILD b/PKGBUILD
index f6a519defe2d..324be2666e4a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=linux-wifi-hotspot
pkgver=2.0.0
-pkgrel=1
+pkgrel=2
pkgdesc='Create virtual wifi hotspot using same wifi card which is connected to an AP + many features (a GUI tool)'
arch=('x86_64')
url='https://github.com/lakinduakash/linux-wifi-hotspot'
@@ -10,20 +10,20 @@ license=('BSD')
depends=('hostapd'
'iw'
'gtk3'
- 'gksu'
'procps-ng'
- 'dnsmasq')
-conflicts=('create_ap')
+ 'dnsmasq'
+ 'iproute2')
+conflicts=('create_ap' 'wihotspot')
provides=('create_ap' 'wihotspot')
+install="$pkgname.install"
optdepends=('haveged: For random MAC generation')
-makedepends=('cmake' 'gendesk')
-source=("${pkgname}-${pkgver}.tar.gz::https://github.com/lakinduakash/linux-wifi-hotspot/archive/v${pkgver}.tar.gz"
- 'https://github.com/lakinduakash/linux-wifi-hotspot/raw/master/src/desktop/hotspot.png')
-sha256sums=('c364b3ac184f7939a8ed2d545e958791cfabc94ea9d5dcc077ca8625ef9b96c0'
- '00b1f5a4c225ea83d8cd1036d57de17a41c4428b667818180eea45610147b5b9')
+makedepends=('cmake')
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/lakinduakash/linux-wifi-hotspot/archive/v${pkgver}.tar.gz")
+sha256sums=('c364b3ac184f7939a8ed2d545e958791cfabc94ea9d5dcc077ca8625ef9b96c0')
prepare() {
cd "${pkgname}-${pkgver}"
+ sed -i '15d' src/scripts/Makefile
sed -i "s|running_info|h_running_info|g" src/ui/h_prop.c
sed -i "s|running_info|h_running_info|g" src/ui/h_prop.h
sed -i "566s|get_running_info|get_h_running_info|" src/ui/ui.c
@@ -37,15 +37,11 @@ build() {
package() {
cd "${pkgname}-${pkgver}"
make DESTDIR="${pkgdir}" install
- install -Dm644 LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"
- install -Dm644 ${srcdir}/hotspot.png "${pkgdir}/usr/share/pixmaps/wihotspot.png"
- gendesk -f -n --pkgname "${pkgname}" \
- --pkgdesc "$pkgdesc" \
- --name "WifiHotspot" \
- --comment "$pkgdesc" \
- --exec 'gksudo -g wihotspot' \
- --categories 'System;' \
- --icon wihotspot
- install -Dm644 ${pkgname}.desktop -t "${pkgdir}/usr/share/applications/"
+ install -Dm644 LICENSE -t \
+ "${pkgdir}/usr/share/licenses/${pkgname}"
+ install -Dm644 src/desktop/hotspot.png \
+ "$pkgdir/usr/share/pixmaps/wihotspot.png"
+ install -Dm644 src/desktop/wifihotspot.desktop \
+ "$pkgdir/usr/share/applications/wihotspot.desktop"
}
# vim:set ts=2 sw=2 et: \ No newline at end of file
diff --git a/hotspot.png b/hotspot.png
deleted file mode 100644
index dc4fa202e2ec..000000000000
--- a/hotspot.png
+++ /dev/null
Binary files differ
diff --git a/linux-wifi-hotspot.install b/linux-wifi-hotspot.install
new file mode 100644
index 000000000000..7a045ce43076
--- /dev/null
+++ b/linux-wifi-hotspot.install
@@ -0,0 +1,11 @@
+post_install() {
+ # Execute create_ap without asking for a password
+ echo 'ALL ALL=NOPASSWD: /usr/bin/create_ap' | sudo EDITOR='tee -a' visudo -f /etc/sudoers.d/create_ap
+}
+
+post_remove() {
+ sudo rm /etc/sudoers.d/create_ap
+
+ echo "Optionally remove config file:"
+ echo "sudo rm /etc/wh.config"
+} \ No newline at end of file