summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGrey Christoforo2019-11-03 13:26:23 +0000
committerGrey Christoforo2019-11-03 13:26:23 +0000
commite6eee5a762a7e3b3dab975270e07d52e7cce8555 (patch)
tree451e9491a2e257c8fa4061e6c9eeecf940459dbf
downloadaur-e6eee5a762a7e3b3dab975270e07d52e7cce8555.tar.gz
initial commit
-rw-r--r--.SRCINFO22
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD44
3 files changed, 69 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..defa3d781234
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = linux-wsl
+ pkgver = 4.19.81
+ pkgrel = 1
+ url = https://github.com/microsoft/WSL2-Linux-Kernel
+ arch = x86_64
+ license = GPL2
+ makedepends = xmlto
+ makedepends = kmod
+ makedepends = inetutils
+ makedepends = bc
+ makedepends = libelf
+ makedepends = git
+ makedepends = python-sphinx
+ makedepends = python-sphinx_rtd_theme
+ makedepends = graphviz
+ makedepends = imagemagick
+ options = !strip
+ source = https://github.com/microsoft/WSL2-Linux-Kernel/archive/4.19.81-microsoft-standard.tar.gz
+ md5sums = e2784adf1f52ff428a6b965cf49e214d
+
+pkgname = linux-wsl
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..72a3ed3fe6e0
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,3 @@
+*.tar*
+pkg/
+src/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5636ca1fdda2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+#
+# Maintainer: Grey Christoforo <firstname@lastname.net>
+#
+pkgname=linux-wsl
+_tag=4.19.81-microsoft-standard
+pkgver=${_tag%%-*}
+pkgrel=1
+arch=(x86_64)
+url="https://github.com/microsoft/WSL2-Linux-Kernel"
+license=(GPL2)
+makedepends=(
+ xmlto kmod inetutils bc libelf git python-sphinx python-sphinx_rtd_theme
+ graphviz imagemagick
+)
+options=('!strip')
+
+source=(https://github.com/microsoft/WSL2-Linux-Kernel/archive/${_tag}.tar.gz)
+md5sums=('e2784adf1f52ff428a6b965cf49e214d')
+
+_kernelname=${_tag##*-}-grey
+_src_prefix="WSL2-Linux-Kernel-"
+prepare() {
+ cd "$_src_prefix$_tag"
+ scripts/setlocalversion --save-scmversion
+ echo "$_kernelname" > localversion.20-pkg
+ cp Microsoft/config-wsl arch/x86/x86_64_defconfig
+ make ARCH=x86_64 defconfig
+}
+
+build() {
+ cd "$_src_prefix$_tag"
+ make ARCH=x86_64 bzImage modules
+ #make KCONFIG_CONFIG=Microsoft/config-wsl image modules
+}
+
+package() {
+ cd "$_src_prefix$_tag"
+ # install modules
+ #make ARCH=x86_64 INSTALL_MOD_PATH="${pkgdir}" modules_install
+
+ make ARCH=x86_64 INSTALL_PATH="${pkgdir}" install
+}
+
+# vim:set ts=8 sts=2 sw=2 et: