summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPieter Lenaerts2017-12-17 14:26:55 +0100
committerPieter Lenaerts2017-12-17 15:20:16 +0100
commit5cc4821955a298137086902c50c782aeb0abd24f (patch)
tree2fc77becbdd1faf674784c6d23745810b2705132
downloadaur-5cc4821955a298137086902c50c782aeb0abd24f.tar.gz
Initial version
-rw-r--r--.SRCINFO18
-rw-r--r--90-linux.hook11
-rw-r--r--PKGBUILD50
-rw-r--r--linux.preset14
4 files changed, 93 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9cb7cc85871b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+# Generated by mksrcinfo v8
+# Sun Dec 17 14:04:10 UTC 2017
+pkgbase = linux-x205ta-sound
+ pkgdesc = Pre-built linux kernel with Pierre Bossart's patches to get the ASUS x205ta's Realtek RT5648 sound card working. Binary provided by harryharryharry.
+ pkgver = 24
+ pkgrel = 1
+ url = https://ubuntuforums.org/showthread.php?t=2254322&p=13595504#post13595504
+ arch = x86_64
+ license = GPL
+ depends = coreutils
+ depends = linux-firmware
+ depends = kmod
+ depends = mkinitcpio>=0.7
+ source = ftp://x205ta.myftp.org:1337/kernel/kernel-64bit-4.14.0-rc7-sound-24.tar
+ sha256sums = 25797436fee9a995b3d1e9d0a0ffb70f2f1f06ab19676e7a5914ae499464971b
+
+pkgname = linux-x205ta-sound
+
diff --git a/90-linux.hook b/90-linux.hook
new file mode 100644
index 000000000000..75cb432c81ed
--- /dev/null
+++ b/90-linux.hook
@@ -0,0 +1,11 @@
+[Trigger]
+Type = File
+Operation = Install
+Operation = Upgrade
+Target = boot/%KERNEL%
+Target = usr/lib/initcpio/*
+
+[Action]
+Description = Updating linux-x205ta-sound initcpios...
+When = PostTransaction
+Exec = /usr/bin/mkinitcpio -p linux-x205ta-sound
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..526a4a378d1d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,50 @@
+# Maintainer: Pieter Lenaerts <pieter dot aj dot lenaerts gmail>
+pkgname=linux-x205ta-sound
+pkgver=24
+pkgrel=1
+_kernver=4.14.0-rc7
+_kernel="vmlinuz-${_kernver}-sound-${pkgver}"
+_moddir="${_kernver}-sound-${pkgver}"
+pkgdesc="Pre-built linux kernel with Pierre Bossart's patches to get the ASUS x205ta's Realtek RT5648 sound card working. Binary provided by harryharryharry."
+arch=(x86_64)
+url="https://ubuntuforums.org/showthread.php?t=2254322&p=13595504#post13595504"
+license=('GPL')
+depends=('coreutils' 'linux-firmware' 'kmod' 'mkinitcpio>=0.7')
+makedepends=()
+checkdepends=()
+optdepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=("ftp://x205ta.myftp.org:1337/kernel/kernel-64bit-${_kernver}-sound-${pkgver}.tar")
+noextract=()
+sha256sums=("25797436fee9a995b3d1e9d0a0ffb70f2f1f06ab19676e7a5914ae499464971b")
+validpgpkeys=()
+
+prepare() {
+ tar -xf kernel-${_kernver}-sound-${pkgver}.tar.xz
+ rm ${srcdir}/lib/modules/${_moddir}/source ${srcdir}/lib/modules/${_moddir}/build
+}
+
+package() {
+ mkdir -p "${pkgdir}"/{boot,usr/lib/modules,usr/lib/firmware/brcm}
+ cp ${srcdir}/boot/${_kernel} ${pkgdir}/boot/${_kernel}
+ cp -r ${srcdir}/lib/modules/${_moddir} ${pkgdir}/usr/lib/modules/
+ cp -r ${srcdir}/lib/firmware/brcm/brcmfmac43340-sdio.txt ${pkgdir}/usr/lib/firmware/brcm/
+
+ local _subst="
+ s|%KERNEL%|${_kernel}|g
+ s|%INITRD%|${_kernel/vmlinuz/initramfs}|g
+ "
+
+ # install pacman hook
+ sed "${_subst}" ../90-linux.hook |
+ install -Dm644 /dev/stdin "${pkgdir}/usr/share/libalpm/hooks/90-${pkgname}.hook"
+ # install mkinitcpio preset
+ sed "${_subst}" ../linux.preset |
+ install -Dm644 /dev/stdin "${pkgdir}/etc/mkinitcpio.d/${pkgname}.preset"
+}
diff --git a/linux.preset b/linux.preset
new file mode 100644
index 000000000000..b09102751893
--- /dev/null
+++ b/linux.preset
@@ -0,0 +1,14 @@
+# mkinitcpio preset file for the 'linux-x205ta-sound' package
+
+ALL_config="/etc/mkinitcpio.conf"
+ALL_kver="/boot/%KERNEL%"
+
+PRESETS=('default' 'fallback')
+
+#default_config="/etc/mkinitcpio.conf"
+default_image="/boot/%INITRD%"
+#default_options=""
+
+#fallback_config="/etc/mkinitcpio.conf"
+fallback_image="/boot/%INITRD%-fallback.img"
+fallback_options="-S autodetect"