summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCyano Hao2021-05-14 23:11:07 +0800
committerCyano Hao2021-05-14 23:11:07 +0800
commit1fc84f7d776fc62f34a169fd0e60b1aa199f8388 (patch)
tree6657834c66876a8fd060f5b6e9afad70bb90cb14
parentfbc9ed57a811dd3bd686858a4946841f3c1233f8 (diff)
downloadaur-1fc84f7d776fc62f34a169fd0e60b1aa199f8388.tar.gz
5.12.4.arch1; use config fragment
-rw-r--r--PKGBUILD10
-rw-r--r--config2
-rw-r--r--x32.config1
3 files changed, 10 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 90ae3dcf87bb..5957c09e4bdf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Maintainer (core/linux): Jan Alexander Steffens (heftig) <heftig@archlinux.org>
pkgbase=linux-x32
-pkgver=5.12.2.arch1
+pkgver=5.12.4.arch1
pkgrel=1
pkgdesc='Linux with x32 ABI'
_srctag=v${pkgver%.*}-${pkgver##*.}
@@ -18,6 +18,7 @@ _srcname=archlinux-linux
source=(
"$_srcname::git+https://git.archlinux.org/linux.git?signed#tag=$_srctag"
config # the main kernel config file
+ x32.config # additional config fragment for linux-x32
)
validpgpkeys=(
'ABAF11C65A2970B130ABE3C479BE3E4300411886' # Linus Torvalds
@@ -25,7 +26,8 @@ validpgpkeys=(
'A2FF3A36AAA56654109064AB19802F8B0D70FC30' # Jan Alexander Steffens (heftig)
)
sha256sums=('SKIP'
- 'a276050b3b8084a202407821dd40d39ac8dd32a236834b2fc7a203a64f9ec318')
+ '6dde032690644a576fd36c4a7d3546d9cec0117dd3fb17cea6dc95e907ef9bef'
+ 'ef2be62540e48cc1d2343c619b9c8b7791db5e2f966e1a0bb8c86f5c7de74562')
export KBUILD_BUILD_HOST=archlinux
export KBUILD_BUILD_USER=$pkgbase
@@ -52,6 +54,10 @@ prepare() {
cp ../config .config
make olddefconfig
+ echo "Applying additional config fragment..."
+ cp ../x32.config kernel/configs/x32.config
+ make x32.config
+
make -s kernelrelease > version
echo "Prepared $pkgbase version $(<version)"
}
diff --git a/config b/config
index 3847f8626e80..5975fd07b380 100644
--- a/config
+++ b/config
@@ -670,7 +670,7 @@ CONFIG_AMD_NB=y
# Binary Emulations
#
CONFIG_IA32_EMULATION=y
-CONFIG_X86_X32=y
+# CONFIG_X86_X32 is not set
CONFIG_COMPAT_32=y
CONFIG_COMPAT=y
CONFIG_COMPAT_FOR_U64_ALIGNMENT=y
diff --git a/x32.config b/x32.config
new file mode 100644
index 000000000000..725e05fdcbbb
--- /dev/null
+++ b/x32.config
@@ -0,0 +1 @@
+CONFIG_X86_X32=y