summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCyano Hao2021-02-16 11:13:20 +0800
committerCyano Hao2021-02-16 11:13:20 +0800
commit5708c4d109ed657f198be01e146a05c7639fc2be (patch)
tree7ee8a0c756d7dec26da1b0240a1dcd382e70f216
parent6f32dfe7229439c94a189c1fefba31b88a6f72a7 (diff)
downloadaur-5708c4d109ed657f198be01e146a05c7639fc2be.tar.gz
backport sphinx workaround from core/linux
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD6
-rw-r--r--sphinx-workaround.patch19
3 files changed, 26 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 21743e564508..596016dbdd22 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = linux-x32
pkgdesc = Linux with x32 ABI
pkgver = 5.10.16.arch1
- pkgrel = 1
+ pkgrel = 2
url = https://git.archlinux.org/linux.git/log/?h=v5.10.16-arch1
arch = x86_64
license = GPL2
@@ -22,11 +22,13 @@ pkgbase = linux-x32
options = !strip
source = archlinux-linux::git+https://git.archlinux.org/linux.git?signed#tag=v5.10.16-arch1
source = config
+ source = sphinx-workaround.patch
validpgpkeys = ABAF11C65A2970B130ABE3C479BE3E4300411886
validpgpkeys = 647F28654894E3BD457199BE38DBBDC86092693E
validpgpkeys = A2FF3A36AAA56654109064AB19802F8B0D70FC30
sha256sums = SKIP
sha256sums = 8b7afebec505de0226d268730c1b65a4cf524bad1e870b2c9f880aaa6ed72c36
+ sha256sums = 52fc0fcd806f34e774e36570b2a739dbdf337f7ff679b1c1139bee54d03301eb
pkgname = linux-x32
pkgdesc = The Linux with x32 ABI kernel and modules
diff --git a/PKGBUILD b/PKGBUILD
index ac650d072da1..e8d106c3ca93 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgbase=linux-x32
pkgver=5.10.16.arch1
-pkgrel=1
+pkgrel=2
pkgdesc='Linux with x32 ABI'
_srctag=v${pkgver%.*}-${pkgver##*.}
url="https://git.archlinux.org/linux.git/log/?h=$_srctag"
@@ -19,6 +19,7 @@ _srcname=archlinux-linux
source=(
"$_srcname::git+https://git.archlinux.org/linux.git?signed#tag=$_srctag"
config # the main kernel config file
+ sphinx-workaround.patch # Sphinx 3.5 broke the build again
)
validpgpkeys=(
'ABAF11C65A2970B130ABE3C479BE3E4300411886' # Linus Torvalds
@@ -26,7 +27,8 @@ validpgpkeys=(
'A2FF3A36AAA56654109064AB19802F8B0D70FC30' # Jan Alexander Steffens (heftig)
)
sha256sums=('SKIP'
- '8b7afebec505de0226d268730c1b65a4cf524bad1e870b2c9f880aaa6ed72c36')
+ '8b7afebec505de0226d268730c1b65a4cf524bad1e870b2c9f880aaa6ed72c36'
+ '52fc0fcd806f34e774e36570b2a739dbdf337f7ff679b1c1139bee54d03301eb')
export KBUILD_BUILD_HOST=archlinux
export KBUILD_BUILD_USER=$pkgbase
diff --git a/sphinx-workaround.patch b/sphinx-workaround.patch
new file mode 100644
index 000000000000..a6e2c4900290
--- /dev/null
+++ b/sphinx-workaround.patch
@@ -0,0 +1,19 @@
+diff --git i/Documentation/conf.py w/Documentation/conf.py
+index 6a767294887e..d1d145759fed 100644
+--- i/Documentation/conf.py
++++ w/Documentation/conf.py
+@@ -267,11 +267,9 @@ except ImportError:
+
+ html_static_path = ['sphinx-static']
+
+-html_context = {
+- 'css_files': [
+- '_static/theme_overrides.css',
+- ],
+-}
++html_css_files = [
++ '_static/theme_overrides.css',
++]
+
+ # Add any extra paths that contain custom files (such as robots.txt or
+ # .htaccess) here, relative to this directory. These files are copied