summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorClaire R2020-09-07 23:18:34 -0500
committerGitHub2020-09-07 23:18:34 -0500
commitf9a6c5610bf14a75b47021d008a934a2392d7e5f (patch)
tree1d27fe7a77ecc4f74669802a8ce160a8fa724fc4
parent703a3f6a9058501abf14cb0fcc76f70850324044 (diff)
downloadaur-f9a6c5610bf14a75b47021d008a934a2392d7e5f.tar.gz
Update update.sh
-rwxr-xr-xupdate.sh2
1 files changed, 1 insertions, 1 deletions
diff --git a/update.sh b/update.sh
index 3498fcad693e..2ee574922e6b 100755
--- a/update.sh
+++ b/update.sh
@@ -1,6 +1,6 @@
#!/bin/bash
-ver=$(pacman -Ss linux | sed -rn 's/^core\/linux ([0-9]+(\.[0-9]+)*\.arch[0-9]+).* \[installed\]/\1/p')
+ver=$(pacman -Qs linux | grep "local/linux " | sed -rn 's/^local\/linux ([0-9]+(\.[0-9]+)*\.arch[0-9]+).*/\1/p')
sed -i "s/pkgver=.*$/pkgver=$ver/" PKGBUILD
updpkgsums
makepkg --printsrcinfo > .SRCINFO