summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoan Figueras2020-11-13 07:51:26 +0100
committerJoan Figueras2020-11-13 07:51:26 +0100
commit21feee493935d2ac09595e4c028649ea62229694 (patch)
tree32a16612fdcdccfdc321976a7410c5b05d337575
parent7c84c58a814506be33bfd562a38517a11d6aafd8 (diff)
downloadaur-21feee493935.tar.gz
Cachy is back
-rw-r--r--PKGBUILD13
1 files changed, 11 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 72dc89c04b2e..bbe775c47709 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -97,7 +97,6 @@ _commits=""
for _patch in $_commits; do
source+=("${_patch}.patch::https://git.archlinux.org/linux.git/patch/?id=${_patch}")
done
-
sha256sums=('3239a4ee1250bf2048be988cc8cb46c487b2c8a0de5b1b032d38394d5c6b1a06'
'SKIP'
@@ -105,6 +104,12 @@ sha256sums=('3239a4ee1250bf2048be988cc8cb46c487b2c8a0de5b1b032d38394d5c6b1a06'
'2c7369218e81dee86f8ac15bda741b9bb34fa9cefcb087760242277a8207d511'
'6c66dba73251440352f93ff32b72f5dd49536d0f17ef9347867660fd3a626991')
+# If use_cachy=y then download cachy patch
+if [ "$use_cachy" = "y" ]; then
+ source+=("https://github.com/xanmod/linux/releases/download/${pkgver}-xanmod${xanmod}-cachy/patch-${pkgver}-xanmod${xanmod}-cachy.xz")
+ sha256sums+=('66b05c60d91d444a35d2ce1ceb46e3325197c05911767049aac68e7e6d31185f')
+fi
+
export KBUILD_BUILD_HOST=${KBUILD_BUILD_HOST:-archlinux}
export KBUILD_BUILD_USER=${KBUILD_BUILD_USER:-makepkg}
export KBUILD_BUILD_TIMESTAMP=${KBUILD_BUILD_TIMESTAMP:-$(date -Ru${SOURCE_DATE_EPOCH:+d @$SOURCE_DATE_EPOCH})}
@@ -113,7 +118,11 @@ prepare() {
cd linux-${_major}
# Apply Xanmod patch
- patch -Np1 -i ../patch-${pkgver}-xanmod${xanmod}
+ if [ "$use_cachy" = "y" ]; then
+ patch -Np1 -i ../patch-${pkgver}-xanmod${xanmod}-cachy
+ else
+ patch -Np1 -i ../patch-${pkgver}-xanmod${xanmod}
+ fi
msg2 "Setting version..."
scripts/setlocalversion --save-scmversion