summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoan Figueras2023-07-06 16:32:46 +0200
committerJoan Figueras2023-07-06 16:32:46 +0200
commit811e14eafebc0d638f1b2e102854d0345c7a5cf7 (patch)
treeb47063bcf99276fe32b49e3a2fdbe148ef4876a6
parent4eab10b70df7693229a2db8131ff014b2c8d15a8 (diff)
downloadaur-811e14eafebc.tar.gz
Disable per-vma
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD10
2 files changed, 9 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f88c71ff6d8f..2b78ec6cee86 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = linux-xanmod
pkgdesc = Linux Xanmod - Current Stable (CURRENT)
pkgver = 6.4.2
- pkgrel = 1
+ pkgrel = 2
url = http://www.xanmod.org/
arch = x86_64
license = GPL2
@@ -17,12 +17,14 @@ pkgbase = linux-xanmod
source = https://cdn.kernel.org/pub/linux/kernel/v6.x/linux-6.4.tar.sign
source = patch-6.4.2-xanmod1.xz::https://github.com/xanmod/linux/releases/download/6.4.2-xanmod1/patch-6.4.2-xanmod1.xz
source = choose-gcc-optimization.sh
+ source = disable-per-VMA.patch::https://lore.kernel.org/linux-mm/20230703182150.2193578-1-surenb@google.com/raw
validpgpkeys = ABAF11C65A2970B130ABE3C479BE3E4300411886
validpgpkeys = 647F28654894E3BD457199BE38DBBDC86092693E
sha256sums = 8fa0588f0c2ceca44cac77a0e39ba48c9f00a6b9dc69761c02a5d3efac8da7f3
sha256sums = SKIP
sha256sums = f30ce7cf11e4819e90966c6e1fdd42d906168ffd38be1234ff0b2696d1740e9c
sha256sums = a8b38eb482eb685944757182c4886404abc12703e5e56ec39c7d61298d17d71f
+ sha256sums = b77accaf21974dea15f2ac7c8bf8f51ce1682ff0b9359d059292983e91ec5c75
pkgname = linux-xanmod
pkgdesc = The Linux kernel and modules with Xanmod patches
diff --git a/PKGBUILD b/PKGBUILD
index c5844ace4240..10fe0fc714d7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -44,7 +44,7 @@ fi
# This will be overwritten by selecting any option in microarchitecture script
# Source files: https://github.com/xanmod/linux/tree/5.17/CONFIGS/xanmod/gcc
if [ -z ${_config+x} ]; then
- _config=config_x86-64-v1
+ _config=config_x86-64-v2
fi
# Compress modules with ZSTD (to save disk space)
@@ -77,7 +77,7 @@ pkgver=${_major}.2
_branch=6.x
xanmod=1
_revision=
-pkgrel=${xanmod}
+pkgrel=2
pkgdesc='Linux Xanmod - Current Stable (CURRENT)'
url="http://www.xanmod.org/"
arch=(x86_64)
@@ -94,7 +94,8 @@ _srcname="linux-${pkgver}-xanmod${xanmod}"
source=("https://cdn.kernel.org/pub/linux/kernel/v${_branch}/linux-${_major}.tar."{xz,sign}
"patch-${pkgver}-xanmod${xanmod}${_revision}.xz::https://github.com/xanmod/linux/releases/download/${pkgver}-xanmod${xanmod}${_revision}/patch-${pkgver}-xanmod${xanmod}.xz"
- choose-gcc-optimization.sh)
+ choose-gcc-optimization.sh
+ "disable-per-VMA.patch::https://lore.kernel.org/linux-mm/20230703182150.2193578-1-surenb@google.com/raw")
#"patch-${pkgver}-xanmod${xanmod}.xz::https://sourceforge.net/projects/xanmod/files/releases/stable/${pkgver}-xanmod${xanmod}/patch-${pkgver}-xanmod${xanmod}.xz/download"
validpgpkeys=(
'ABAF11C65A2970B130ABE3C479BE3E4300411886' # Linux Torvalds
@@ -112,7 +113,8 @@ done
sha256sums=('8fa0588f0c2ceca44cac77a0e39ba48c9f00a6b9dc69761c02a5d3efac8da7f3'
'SKIP'
'f30ce7cf11e4819e90966c6e1fdd42d906168ffd38be1234ff0b2696d1740e9c'
- 'a8b38eb482eb685944757182c4886404abc12703e5e56ec39c7d61298d17d71f')
+ 'a8b38eb482eb685944757182c4886404abc12703e5e56ec39c7d61298d17d71f'
+ 'b77accaf21974dea15f2ac7c8bf8f51ce1682ff0b9359d059292983e91ec5c75')
export KBUILD_BUILD_HOST=${KBUILD_BUILD_HOST:-archlinux}
export KBUILD_BUILD_USER=${KBUILD_BUILD_USER:-makepkg}