summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoan Figueras2021-01-24 23:22:10 +0100
committerJoan Figueras2021-01-24 23:22:10 +0100
commitccc3ce5e4b834fcc26a144952ecf070be5ed4a0c (patch)
tree66390997e1256b0c4fb83e88c089bae0350efb5c
parent24973d4e4d7c2d7f86495e0d815dd1dde51efecb (diff)
downloadaur-ccc3ce5e4b83.tar.gz
Added /home/figue/.config/linux-xanmod/myconfig as a permanent myconfig file
-rw-r--r--PKGBUILD8
1 files changed, 4 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 6a5653a33e48..8d5387d6b506 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -172,18 +172,18 @@ prepare() {
sh ${srcdir}/choose-gcc-optimization.sh $_microarchitecture
# This is intended for the people that want to build this package with their own config
- # Put the file "myconfig" at the package folder to use this feature
+ # Put the file "myconfig" at the package folder (this will take preference) or "${XDG_CONFIG_HOME}/linux-xanmod/myconfig"
# If it's a full config, will be replaced
# If not, you should use scripts/config commands, one by line
- if [ -f "${startdir}/myconfig" ]; then
+ if [ -f "${startdir}/myconfig" ] || [ -f "${XDG_CONFIG_HOME}/linux-xanmod/myconfig" ]; then
if ! grep -q 'scripts/config' "${startdir}/myconfig"; then
# myconfig is a full config file. Replacing default .config
msg2 "Using user CUSTOM config..."
- cp -f "${startdir}"/myconfig .config
+ cp -f "${startdir}"/myconfig .config || cp -f "${XDG_CONFIG_HOME}/linux-xanmod/myconfig" .config
else
# myconfig is a partial file. Executing as a script
msg2 "Applying myconfig..."
- bash -x "${startdir}"/myconfig
+ bash -x "${startdir}"/myconfig || bash -x "${XDG_CONFIG_HOME}/linux-xanmod/myconfig"
fi
echo
fi