summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoan Figueras2023-11-12 10:06:41 +0100
committerJoan Figueras2023-11-12 10:06:41 +0100
commitdc842720ab691b7c4e06e26bbf4eb13b3922f234 (patch)
treed662220b201787886ac02c3d77bbd8d18d53d914
parent82537a9c1ad392430265483f366ca92643eb7b75 (diff)
downloadaur-dc842720ab691b7c4e06e26bbf4eb13b3922f234.tar.gz
Fixed tracers config if no _compiler set
-rw-r--r--PKGBUILD2
1 files changed, 1 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 87359eefacad..9f876c8b25fd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -160,7 +160,7 @@ prepare() {
# User set. See at the top of this file
if [ "$use_tracers" = "y" ]; then
msg2 "Enabling CONFIG_FTRACE only if we are not compiling with clang..."
- if [ "${_compiler}" = "gcc" ]; then
+ if [ "${_compiler}" = "gcc" ] || [ "${_compiler}q" = "q" ]; then
scripts/config --enable CONFIG_FTRACE \
--enable CONFIG_FUNCTION_TRACER \
--enable CONFIG_STACK_TRACER