summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMiklós Tóth2022-01-30 00:03:52 +0000
committerMiklós Tóth2022-01-30 00:03:52 +0000
commit394b6c3487a5231ac70451165f15efe9498e411a (patch)
tree84ffcf6ed7486ddc5e22e3cdcf9e47e4ea3c12b5
parentca8a262f667f460fcdefd41046ff3ea610af88dc (diff)
downloadaur-394b6c3487a5231ac70451165f15efe9498e411a.tar.gz
automatic update
-rw-r--r--PKGBUILD8
1 files changed, 6 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 584f1b4ce547..ccb2bf3faf71 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -54,7 +54,9 @@ if [ -z ${_localmodcfg} ]; then
fi
# Tweak kernel options prior to a build via nconfig
-_makenconfig=
+if [ -z ${_makenconfig} ]; then
+ _makenconfig=n
+fi
### IMPORTANT: Do no edit below this line unless you know what you're doing
@@ -208,7 +210,9 @@ prepare() {
make -s kernelrelease > version
msg2 "Prepared %s version %s" "$pkgbase" "$(<version)"
- [[ -z "$_makenconfig" ]] || make LLVM=$_LLVM LLVM_IAS=$_LLVM nconfig
+ if [ "$_makenconfig" = "y" ]; then
+ make LLVM=$_LLVM LLVM_IAS=$_LLVM nconfig
+ fi
# save configuration for later reuse
cat .config > "${SRCDEST}/config.last"