summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMiklós Tóth2023-07-20 12:02:26 +0000
committerMiklós Tóth2023-07-20 12:02:26 +0000
commit5764bfca7deaf83790b87f4fc7adbfa34db9d702 (patch)
treeecd1989a1b7d58c66a15844caf4a4e6b2d5a30fc
parent21b94a51da2ad2013f7d5829e127f4a850f416bb (diff)
downloadaur-5764bfca7deaf83790b87f4fc7adbfa34db9d702.tar.gz
automatic update
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD16
2 files changed, 16 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 67d8ab011016..42768e6c8917 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = linux-xanmod-anbox
- pkgdesc = Linux Xanmod with ashmem and binder enabled for Anbox - Current Stable (CURRENT)
- pkgver = 6.4.3
- pkgrel = 2
+ pkgdesc = Linux Xanmod with ashmem and binder enabled for Anbox - Stable Mainline [MAIN]
+ pkgver = 6.4.4
+ pkgrel = 1
url = http://www.xanmod.org/
arch = x86_64
license = GPL2
@@ -15,13 +15,13 @@ pkgbase = linux-xanmod-anbox
options = !strip
source = https://cdn.kernel.org/pub/linux/kernel/v6.x/linux-6.4.tar.xz
source = https://cdn.kernel.org/pub/linux/kernel/v6.x/linux-6.4.tar.sign
- source = patch-6.4.3-xanmod1.xz::https://github.com/xanmod/linux/releases/download/6.4.3-xanmod1/patch-6.4.3-xanmod1.xz
+ source = patch-6.4.4-xanmod1.xz::https://github.com/xanmod/linux/releases/download/6.4.4-xanmod1/patch-6.4.4-xanmod1.xz
source = choose-gcc-optimization.sh
validpgpkeys = ABAF11C65A2970B130ABE3C479BE3E4300411886
validpgpkeys = 647F28654894E3BD457199BE38DBBDC86092693E
sha256sums = 8fa0588f0c2ceca44cac77a0e39ba48c9f00a6b9dc69761c02a5d3efac8da7f3
sha256sums = SKIP
- sha256sums = c718aaba0f25cb90b9660ae4efeb0eca91e81c5573fea561deba20dce4bf8082
+ sha256sums = 03b3711b1465131219025aaa17783e1ac4fbc94df477180552ef0cc92e2ce5d6
sha256sums = a8b38eb482eb685944757182c4886404abc12703e5e56ec39c7d61298d17d71f
pkgname = linux-xanmod-anbox
@@ -37,5 +37,5 @@ pkgname = linux-xanmod-anbox
provides = NTFS3-MODULE
pkgname = linux-xanmod-anbox-headers
- pkgdesc = Headers and scripts for building modules for the Linux Xanmod with ashmem and binder enabled for Anbox - Current Stable (CURRENT) kernel
+ pkgdesc = Headers and scripts for building modules for the Linux Xanmod with ashmem and binder enabled for Anbox - Stable Mainline [MAIN] kernel
depends = pahole
diff --git a/PKGBUILD b/PKGBUILD
index 968214bca63e..1f2ba267de90 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -25,7 +25,7 @@ fi
## Since upstream disabled CONFIG_STACK_TRACER (limits debugging and analyzing of the kernel)
## you can enable them setting this option. Caution, because they have an impact in performance.
-## Stock Archlinux has this enabled.
+## Stock Archlinux has this enabled.
## Set variable "use_tracers" to: n to disable (possibly increase performance, XanMod default)
## y to enable (Archlinux default)
if [ -z ${use_tracers+x} ]; then
@@ -40,7 +40,7 @@ if [ "${_compiler}" = "clang" ]; then
fi
# Choose between the 4 main configs for stable branch. Default x86-64-v1 which use CONFIG_GENERIC_CPU2:
-# Possible values: config_x86-64-v1 (default) / config_x86-64-v2 / config_x86-64-v3 / config_x86-64-v4
+# Possible values: config_x86-64-v1 / config_x86-64-v2 (default) / config_x86-64-v3 / config_x86-64-v4
# This will be overwritten by selecting any option in microarchitecture script
# Source files: https://github.com/xanmod/linux/tree/5.17/CONFIGS/xanmod/gcc
if [ -z ${_config+x} ]; then
@@ -73,12 +73,12 @@ fi
pkgbase=linux-xanmod-anbox
_major=6.4
-pkgver=${_major}.3
+pkgver=${_major}.4
_branch=6.x
xanmod=1
_revision=
-pkgrel=2
-pkgdesc='Linux Xanmod with ashmem and binder enabled for Anbox - Current Stable (CURRENT)'
+pkgrel=${xanmod}
+pkgdesc='Linux Xanmod with ashmem and binder enabled for Anbox - Stable Mainline [MAIN]'
url="http://www.xanmod.org/"
arch=(x86_64)
@@ -111,7 +111,7 @@ done
sha256sums=('8fa0588f0c2ceca44cac77a0e39ba48c9f00a6b9dc69761c02a5d3efac8da7f3'
'SKIP'
- 'c718aaba0f25cb90b9660ae4efeb0eca91e81c5573fea561deba20dce4bf8082'
+ '03b3711b1465131219025aaa17783e1ac4fbc94df477180552ef0cc92e2ce5d6'
'a8b38eb482eb685944757182c4886404abc12703e5e56ec39c7d61298d17d71f')
export KBUILD_BUILD_HOST=${KBUILD_BUILD_HOST:-archlinux}
@@ -161,6 +161,10 @@ prepare() {
scripts/config --enable CONFIG_IKCONFIG \
--enable CONFIG_IKCONFIG_PROC
+ # Requested by Alexandre Frade to fix issues in python-gbinder
+ scripts/config --enable CONFIG_ANDROID_BINDERFS
+ scripts/config --enable CONFIG_ANDROID_BINDER_IPC
+
# User set. See at the top of this file
if [ "$use_tracers" = "y" ]; then
msg2 "Enabling CONFIG_FTRACE only if we are not compiling with clang..."