summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMiklós Tóth2021-03-03 00:10:12 +0000
committerMiklós Tóth2021-03-03 00:10:12 +0000
commitccf71cebe2056ef3518c6e846305674b191af6d3 (patch)
treeac27703d742ee0da6c0120ced36dd0dc63cec218
parent8333ff98fed7d76bff9f37fb1d65652b2028ddd0 (diff)
downloadaur-ccf71cebe2056ef3518c6e846305674b191af6d3.tar.gz
automatic update
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD7
2 files changed, 7 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7a09a37a1add..c6d428123d79 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -34,5 +34,6 @@ pkgname = linux-xanmod-anbox
optdepends = linux-firmware: firmware images needed for some devices
pkgname = linux-xanmod-anbox-headers
- pkgdesc = Header files and scripts for building modules for Xanmod Linux kernel with ashmem and binder enabled
+ pkgdesc = Headers and scripts for building modules for the Linux Xanmod with ashmem and binder enabled for Anbox kernel
+ depends = pahole
diff --git a/PKGBUILD b/PKGBUILD
index 772812e18c04..e3cdfe5189e1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -210,14 +210,15 @@ _package() {
echo "$pkgbase" | install -Dm644 /dev/stdin "$modulesdir/pkgbase"
msg2 "Installing modules..."
- make INSTALL_MOD_PATH="$pkgdir/usr" modules_install
+ make INSTALL_MOD_PATH="$pkgdir/usr" INSTALL_MOD_STRIP=1 modules_install
# remove build and source links
rm "$modulesdir"/{source,build}
}
_package-headers() {
- pkgdesc="Header files and scripts for building modules for Xanmod Linux kernel with ashmem and binder enabled"
+ pkgdesc="Headers and scripts for building modules for the $pkgdesc kernel"
+ depends=(pahole)
cd linux-${_major}
local builddir="$pkgdir/usr/lib/modules/$(<version)/build"
@@ -286,6 +287,8 @@ _package-headers() {
esac
done < <(find "$builddir" -type f -perm -u+x ! -name vmlinux -print0)
+ msg2 "Stripping vmlinux..."
+ strip -v $STRIP_STATIC "$builddir/vmlinux"
msg2 "Adding symlink..."
mkdir -p "$pkgdir/usr/src"
ln -sr "$builddir" "$pkgdir/usr/src/$pkgbase"