summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorptr13372021-05-04 21:55:06 +0200
committerptr13372021-05-04 21:55:06 +0200
commitd5cbde6bab44ca68b806428f22e5696e83ce4b83 (patch)
tree149999ba43bd4861a3dac98f7d34bc1c17f914b1
parent234913a843961a881a8645531be892fdfe3c5735 (diff)
downloadaur-d5cbde6bab44ca68b806428f22e5696e83ce4b83.tar.gz
fixed patches, updated checksums
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD4
-rw-r--r--configure2
3 files changed, 6 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fd81c4fcac59..c2da27317276 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = linux-xanmod-cacule-rt
pkgdesc = Linux XanMod CacULE RT
pkgver = 5.11.12
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/hamadmarri/cacule-cpu-scheduler
arch = x86_64
license = GPL2
@@ -20,8 +20,8 @@ pkgbase = linux-xanmod-cacule-rt
options = !strip
source = https://www.kernel.org/pub/linux/kernel/v5.x/linux-5.11.tar.xz
source = https://github.com/xanmod/linux/releases/download/5.11.12-rt11-xanmod1/patch-5.11.12-rt11-xanmod1.xz
- source = https://raw.githubusercontent.com/ptr1337/kernel-patches/main/5.11/cacule-patches/cacule-5.11-rt.patch
- source = https://raw.githubusercontent.com/ptr1337/kernel-patches/main/5.11/cacule-patches/0002-cacule-Change-default-preemption-latency-to-2ms-for-.patch
+ source = https://raw.githubusercontent.com/ptr1337/linux-cacule-aur/master/patches/5.11/cacule-patches/cacule-5.11-rt.patch
+ source = https://raw.githubusercontent.com/ptr1337/linux-cacule-aur/master/patches/5.11/cacule-patches/0002-cacule-Change-default-preemption-latency-to-2ms-for-.patch
sha256sums = 04f07b54f0d40adfab02ee6cbd2a942c96728d87c1ef9e120d0cb9ba3fe067b4
sha256sums = 0872bff9cdaf3924c7e6ad7a47cd822fd5239408a315286ea62cc10f6153a02a
sha256sums = b43d339574ec25e2f97483fe65c3bad30126057379089d7fee1ff0678f7d627e
diff --git a/PKGBUILD b/PKGBUILD
index 851d503ff230..5f503501141e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -63,7 +63,7 @@ pkgver=${_major}.${_minor}
_stable=${_major}.${_minor}
#_stablerc=${_major}-${_rcver}
_srcname=linux-${_major}
-pkgrel=1
+pkgrel=2
pkgdesc='Linux XanMod CacULE RT'
versiontag=5.11.12-rt11-xanmod1
arch=('x86_64')
@@ -72,7 +72,7 @@ license=('GPL2')
options=('!strip')
makedepends=('kmod' 'bc' 'libelf' 'python-sphinx' 'python-sphinx_rtd_theme'
'graphviz' 'imagemagick' 'pahole' 'cpio' 'perl' 'tar' 'xz')
-_patchsource="https://raw.githubusercontent.com/ptr1337/kernel-patches/main/$_major"
+_patchsource="https://raw.githubusercontent.com/ptr1337/linux-cacule-aur/master/patches/5.11"
source=("https://www.kernel.org/pub/linux/kernel/v5.x/linux-$_major.tar.xz"
"https://github.com/xanmod/linux/releases/download/$versiontag/patch-$versiontag.xz"
"${_patchsource}/cacule-patches/cacule-5.11-rt.patch"
diff --git a/configure b/configure
index 556baad5c93b..2f1411ccbfa4 100644
--- a/configure
+++ b/configure
@@ -66,7 +66,7 @@ cpu_arch() {
> 60) GENERIC_CPU4 : Generic x86-64 CPU with v4 instructions. Run equally well on all x86-64 CPUs with min support of x86-64-v4. - GCC 11 required\n \
> 61) MNATIVE_INTEL : Intel-Native optimizations autodetected by GCC.\n \
> 62) MNATIVE_AMD : AMD-Native optimizations autodetected by GCC.\n \
- > Default (57 : Gneric CPU)\nchoice[0-56]: '`" _microarchitecture
+ > Default (57 : Gneric CPU)\nchoice[0-62]: '`" _microarchitecture
if [[ "$_microarchitecture" = "1" ]]; then
scripts/config --disable CONFIG_GENERIC_CPU