summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorptr13372021-04-20 21:58:03 +0200
committerptr13372021-04-20 21:58:03 +0200
commita3ed94d72a0d456acedb7fee495a411010370d7c (patch)
tree76066593ecc2e08fa0222e26609811098c7b1d8b
downloadaur-a3ed94d72a0d456acedb7fee495a411010370d7c.tar.gz
frst push
-rw-r--r--.SRCINFO42
-rw-r--r--PKGBUILD364
-rw-r--r--configure263
3 files changed, 669 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..34c404804c6f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,42 @@
+pkgbase = linux-xanmod-cacule-rt-stable
+ pkgdesc = Linux XanMod CacULE RT stable Version
+ pkgver = 5.10.27
+ pkgrel = 1
+ url = https://github.com/hamadmarri/cacule-cpu-scheduler
+ arch = x86_64
+ license = GPL2
+ makedepends = kmod
+ makedepends = bc
+ makedepends = libelf
+ makedepends = python-sphinx
+ makedepends = python-sphinx_rtd_theme
+ makedepends = graphviz
+ makedepends = imagemagick
+ makedepends = pahole
+ makedepends = cpio
+ makedepends = perl
+ makedepends = tar
+ makedepends = xz
+ options = !strip
+ source = https://www.kernel.org/pub/linux/kernel/v5.x/linux-5.10.tar.xz
+ source = https://github.com/xanmod/linux/releases/download/5.10.27-rt36-xanmod1/patch-5.10.27-rt36-xanmod1.xz
+ source = https://raw.githubusercontent.com/ptr1337/kernel-patches/main/5.10/cacule/cacule5.10-rt.patch
+ source = https://raw.githubusercontent.com/ptr1337/kernel-patches/main/5.10/cacule/0002-cacule-Change-default-preemption-latency-to-2ms-for-.patch
+ sha256sums = dcdf99e43e98330d925016985bfbc7b83c66d367b714b2de0cbbfcbf83d8ca43
+ sha256sums = 80b75594f05cb6f318af15b02261255f9cf33da1cb3352b3fa444724cc774953
+ sha256sums = bdf093d5ed34b9c6907253fbc0b564363a18fe64fa78cbd106f1b49d6906404a
+ sha256sums = cf00507d6881b737a9814d152e27b1db02f45a4d8a8ba3f4c9f542f0964ac697
+
+pkgname = linux-xanmod-cacule-rt-stable
+ pkgdesc = The Linux XanMod CacULE RT stable Version kernel and modules
+ depends = coreutils
+ depends = kmod
+ depends = initramfs
+ optdepends = crda: to set the correct wireless channels of your country
+ optdepends = linux-firmware: firmware images needed for some devices
+ optdepends = modprobed-db: Keeps track of EVERY kernel module that has ever been probed - useful for those of us who make localmodconfig
+
+pkgname = linux-xanmod-cacule-rt-stable-headers
+ pkgdesc = Headers and scripts for building modules for the Linux XanMod CacULE RT stable Version kernel
+ depends = pahole
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c98814a113a7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,364 @@
+# Maintainer: ptr1337 <admin@ptr1337.dev>
+# Contributor: Piotr Gorski <lucjan.lucjanov@gmail.com>
+# Contributor: Jan Alexander Steffens (heftig) <jan.steffens@gmail.com>
+# Contributor: Tobias Powalowski <tpowa@archlinux.org>
+# Contributor: Thomas Baechler <thomas@archlinux.org>
+
+### BUILD OPTIONS
+# Set these variables to ANYTHING that is not null to enable them
+
+# NUMA is optimized for multi-socket motherboards.
+# A single multi-core CPU actually runs slower with NUMA enabled.
+# See, https://bugs.archlinux.org/task/31187
+_NUMAdisable=y
+
+_fsync=y
+
+_futex2=y
+
+### Set performance governor as default
+_per_gov=y
+### Disable Deadline I/O scheduler
+_deadline_disable=y
+### Disable Kyber I/O scheduler
+_kyber_disable=y
+### Running with a 1000 HZ, 750HZ or 500HZ tick rate
+_1k_HZ_ticks=y
+_500_HZ_ticks=
+### Tweak kernel options prior to a build via nconfig
+_makenconfig=
+### Tweak kernel options prior to a build via menuconfig
+_makemenuconfig=
+### Tweak kernel options prior to a build via xconfig
+_makexconfig=
+### Tweak kernel options prior to a build via gconfig
+_makegconfig=
+# Compile ONLY used modules to VASTLYreduce the number of modules built
+# and the build time.
+#
+# To keep track of which modules are needed for your specific system/hardware,
+# give module_db script a try: https://aur.archlinux.org/packages/modprobed-db
+# This PKGBUILD read the database kept if it exists
+#
+# More at this wiki page ---> https://wiki.archlinux.org/index.php/Modprobed-db
+_localmodcfg=
+
+# Use the current kernel's .config file
+# Enabling this option will use the .config of the RUNNING kernel rather than
+# the ARCH defaults. Useful when the package gets updated and you already went
+# through the trouble of customizing your config options. NOT recommended when
+# a new kernel is released, but again, convenient for package bumps.
+_use_current=
+
+### IMPORTANT: Do no edit below this line unless you know what you're doing
+
+pkgbase=linux-xanmod-cacule-rt-stable
+# pkgname=('linux-xanmod-cacule-rt-stable' linux-xanmod-cacule-rt-stable)
+_major=5.10
+_minor=27
+#_minorc=$((_minor+1))
+#_rcver=rc7
+_rt=36
+pkgver=${_major}.${_minor}
+_stable=${_major}.${_minor}
+#_stablerc=${_major}-${_rcver}
+_srcname=linux-${_major}
+pkgrel=1
+pkgdesc='Linux XanMod CacULE RT stable Version'
+versiontag=5.10.27-rt36-xanmod1
+arch=('x86_64')
+url="https://github.com/hamadmarri/cacule-cpu-scheduler"
+license=('GPL2')
+options=('!strip')
+makedepends=('kmod' 'bc' 'libelf' 'python-sphinx' 'python-sphinx_rtd_theme'
+ 'graphviz' 'imagemagick' 'pahole' 'cpio' 'perl' 'tar' 'xz')
+_patchsource="https://raw.githubusercontent.com/ptr1337/kernel-patches/main/$_major"
+source=("https://www.kernel.org/pub/linux/kernel/v5.x/linux-$_major.tar.xz"
+ "https://github.com/xanmod/linux/releases/download/$versiontag/patch-$versiontag.xz"
+ "${_patchsource}/cacule/cacule5.10-rt.patch"
+ "${_patchsource}/cacule/0002-cacule-Change-default-preemption-latency-to-2ms-for-.patch")
+sha256sums=('dcdf99e43e98330d925016985bfbc7b83c66d367b714b2de0cbbfcbf83d8ca43'
+ '80b75594f05cb6f318af15b02261255f9cf33da1cb3352b3fa444724cc774953'
+ 'bdf093d5ed34b9c6907253fbc0b564363a18fe64fa78cbd106f1b49d6906404a'
+ 'cf00507d6881b737a9814d152e27b1db02f45a4d8a8ba3f4c9f542f0964ac697')
+
+export KBUILD_BUILD_HOST=${KBUILD_BUILD_HOST:-archlinux}
+export KBUILD_BUILD_USER=${KBUILD_BUILD_USER:-makepkg}
+export KBUILD_BUILD_TIMESTAMP=${KBUILD_BUILD_TIMESTAMP:-$(date -Ru${SOURCE_DATE_EPOCH:+d @$SOURCE_DATE_EPOCH})}
+
+prepare() {
+ cd $_srcname
+
+ # hacky work around for xz not getting extracted
+ # https://bbs.archlinux.org/viewtopic.php?id=265115
+ if [[ ! -f "$srcdir/patch-$versiontag" ]]; then
+ unlink "$srcdir/patch-$versiontag.xz"
+ xz -dc "$startdir/patch-$versiontag.xz" > "$srcdir/patch-$versiontag"
+ fi
+
+ # Apply Xanmod-RT patch
+ patch -Np1 -i ../patch-$versiontag
+
+ ### Setting version
+ echo "Setting version..."
+ scripts/setlocalversion --save-scmversion
+ echo "-$pkgrel" > localversion.10-pkgrel
+ echo "${pkgbase#linux-xanmod}" > localversion.20-pkgname
+
+ ### Patching sources
+ local src
+ for src in "${source[@]}"; do
+ src="${src%%::*}"
+ src="${src##*/}"
+ [[ $src = *.patch ]] || continue
+ echo "Applying patch $src..."
+ patch -Np1 < "../$src"
+ done
+
+
+ ### Optionally use running kernel's config
+ # code originally by nous; http://aur.archlinux.org/packages.php?ID=40191
+ if [ -n "$_use_current" ]; then
+ if [[ -s /proc/config.gz ]]; then
+ echo "Extracting config from /proc/config.gz..."
+ # modprobe configs
+ zcat /proc/config.gz > ./.config
+ else
+ warning "Your kernel was not compiled with IKCONFIG_PROC!"
+ warning "You cannot read the current config!"
+ warning "Aborting!"
+ exit
+ fi
+ fi
+
+ source "${startdir}"/configure
+
+ cpu_arch
+
+ ### Optionally set tickrate to 1000
+ if [ -n "$_1k_HZ_ticks" ]; then
+ echo "Setting tick rate to 1k..."
+ scripts/config --disable CONFIG_HZ_300
+ scripts/config --enable CONFIG_HZ_1000
+ scripts/config --set-val CONFIG_HZ 1000
+ fi
+
+ ### Optionally set tickrate to 750HZ
+ if [ -n "$_750_HZ_ticks" ]; then
+ echo "Setting tick rate to 1k..."
+ scripts/config --disable CONFIG_HZ_300
+ scripts/config --enable CONFIG_HZ_750
+ scripts/config --set-val CONFIG_HZ 750
+ fi
+
+ ### Optionally set tickrate to 500HZ
+ if [ -n "$_500_HZ_ticks" ]; then
+ echo "Setting tick rate to 1k..."
+ scripts/config --disable CONFIG_HZ_300
+ scripts/config --enable CONFIG_HZ_500
+ scripts/config --set-val CONFIG_HZ 500
+ fi
+
+ ### Optionally disable NUMA for 64-bit kernels only
+ # (x86 kernels do not support NUMA)
+ if [ -n "$_NUMAdisable" ]; then
+ echo "Disabling NUMA from kernel config..."
+ scripts/config --disable CONFIG_NUMA
+ fi
+
+ if [ -n "$_fsync" ]; then
+ echo "Enable Fsync support"
+ scripts/config --enable CONFIG_FUTEX
+ scripts/config --enable CONFIG_FUTEX_PI
+ fi
+
+ if [ -n "$_futex2" ]; then
+ echo "Enable Futex2 support"
+ scripts/config --enable CONFIG_FUTEX2
+ fi
+
+ ### Set performance governor
+ if [ -n "$_per_gov" ]; then
+ echo "Setting performance governor..."
+ scripts/config --disable CONFIG_CPU_FREQ_DEFAULT_GOV_SCHEDUTIL
+ scripts/config --enable CONFIG_CPU_FREQ_DEFAULT_GOV_PERFORMANCE
+ echo "Disabling uneeded governors..."
+ scripts/config --disable CONFIG_CPU_FREQ_GOV_ONDEMAND
+ scripts/config --disable CONFIG_CPU_FREQ_GOV_CONSERVATIVE
+ scripts/config --disable CONFIG_CPU_FREQ_GOV_USERSPACE
+ scripts/config --disable CONFIG_CPU_FREQ_GOV_SCHEDUTIL
+ fi
+
+ ### Disable Deadline I/O scheduler
+ if [ -n "$_deadline_disable" ]; then
+ echo "Disabling Deadline I/O scheduler..."
+ scripts/config --disable CONFIG_MQ_IOSCHED_DEADLINE
+ fi
+
+ ### Disable Kyber I/O scheduler
+ if [ -n "$_kyber_disable" ]; then
+ echo "Disabling Kyber I/O scheduler..."
+ scripts/config --disable CONFIG_MQ_IOSCHED_KYBER
+ fi
+
+ echo "Setting Cacule Config"
+ scripts/config --enable CONFIG_CACULE_SCHED
+ scripts/config --disable CONFIG_SCHED_DEBUG
+ scripts/config --disable CONFIG_SCHED_INFO
+ scripts/config --disable CONFIG_SCHEDSTATS
+ scripts/config --disable CONFIG_DEBUG_KERNEL
+ scripts/config --disable CONFIG_EXPERT
+
+
+ make olddefconfig
+
+ ### Optionally load needed modules for the make localmodconfig
+ # See https://aur.archlinux.org/packages/modprobed-db
+ if [ -n "$_localmodcfg" ]; then
+ if [ -f $HOME/.config/modprobed.db ]; then
+ echo "Running Steven Rostedt's make localmodconfig now"
+ make LSMOD=$HOME/.config/modprobed.db localmodconfig
+ else
+ echo "No modprobed.db data found"
+ exit
+ fi
+ fi
+
+ make -s kernelrelease > version
+ msg2 "Prepared %s version %s" "$pkgbase" "$(<version)"
+
+ ### Running make nconfig
+ [[ -z "$_makenconfig" ]] || make nconfig
+
+ ### Running make menuconfig
+ [[ -z "$_makemenuconfig" ]] || make menuconfig
+
+ ### Running make xconfig
+ [[ -z "$_makexconfig" ]] || make xconfig
+
+ ### Running make gconfig
+ [[ -z "$_makegconfig" ]] || make gconfig
+
+ ### Save configuration for later reuse
+ cat .config > "${startdir}/config.last"
+}
+
+build() {
+ cd $_srcname
+
+ make all
+}
+
+_package() {
+ pkgdesc="The $pkgdesc kernel and modules"
+ depends=('coreutils' 'kmod' 'initramfs')
+ optdepends=('crda: to set the correct wireless channels of your country'
+ 'linux-firmware: firmware images needed for some devices'
+ 'modprobed-db: Keeps track of EVERY kernel module that has ever been probed - useful for those of us who make localmodconfig')
+
+
+ cd $_srcname
+ local kernver="$(<version)"
+ local modulesdir="$pkgdir/usr/lib/modules/$kernver"
+
+ echo "Installing boot image..."
+ # systemd expects to find the kernel here to allow hibernation
+ # https://github.com/systemd/systemd/commit/edda44605f06a41fb86b7ab8128dcf99161d2344
+ install -Dm644 "$(make -s image_name)" "$modulesdir/vmlinuz"
+
+ # Used by mkinitcpio to name the kernel
+ echo "$pkgbase" | install -Dm644 /dev/stdin "$modulesdir/pkgbase"
+
+ echo "Installing modules..."
+ make INSTALL_MOD_PATH="$pkgdir/usr" INSTALL_MOD_STRIP=1 modules_install
+
+ # remove build and source links
+ rm "$modulesdir"/{source,build}
+}
+
+_package-headers() {
+ pkgdesc="Headers and scripts for building modules for the $pkgdesc kernel"
+ depends=('pahole')
+
+ cd $_srcname
+ local builddir="$pkgdir/usr/lib/modules/$(<version)/build"
+
+ echo "Installing build files..."
+ install -Dt "$builddir" -m644 .config Makefile Module.symvers System.map \
+ localversion.* version vmlinux
+ install -Dt "$builddir/kernel" -m644 kernel/Makefile
+ install -Dt "$builddir/arch/x86" -m644 arch/x86/Makefile
+ cp -t "$builddir" -a scripts
+
+ # add objtool for external module building and enabled VALIDATION_STACK option
+ install -Dt "$builddir/tools/objtool" tools/objtool/objtool
+
+ # add xfs and shmem for aufs building
+ mkdir -p "$builddir"/{fs/xfs,mm}
+
+ echo "Installing headers..."
+ cp -t "$builddir" -a include
+ cp -t "$builddir/arch/x86" -a arch/x86/include
+ install -Dt "$builddir/arch/x86/kernel" -m644 arch/x86/kernel/asm-offsets.s
+
+ install -Dt "$builddir/drivers/md" -m644 drivers/md/*.h
+ install -Dt "$builddir/net/mac80211" -m644 net/mac80211/*.h
+
+ # http://bugs.archlinux.org/task/13146
+ install -Dt "$builddir/drivers/media/i2c" -m644 drivers/media/i2c/msp3400-driver.h
+
+ # http://bugs.archlinux.org/task/20402
+ install -Dt "$builddir/drivers/media/usb/dvb-usb" -m644 drivers/media/usb/dvb-usb/*.h
+ install -Dt "$builddir/drivers/media/dvb-frontends" -m644 drivers/media/dvb-frontends/*.h
+ install -Dt "$builddir/drivers/media/tuners" -m644 drivers/media/tuners/*.h
+
+ echo "Installing KConfig files..."
+ find . -name 'Kconfig*' -exec install -Dm644 {} "$builddir/{}" \;
+
+ echo "Removing unneeded architectures..."
+ local arch
+ for arch in "$builddir"/arch/*/; do
+ [[ $arch = */x86/ ]] && continue
+ echo "Removing $(basename "$arch")"
+ rm -r "$arch"
+ done
+
+ echo "Removing documentation..."
+ rm -r "$builddir/Documentation"
+
+ echo "Removing broken symlinks..."
+ find -L "$builddir" -type l -printf 'Removing %P\n' -delete
+
+ echo "Removing loose objects..."
+ find "$builddir" -type f -name '*.o' -printf 'Removing %P\n' -delete
+
+ echo "Stripping build tools..."
+ local file
+ while read -rd '' file; do
+ case "$(file -bi "$file")" in
+ application/x-sharedlib\;*) # Libraries (.so)
+ strip -v $STRIP_SHARED "$file" ;;
+ application/x-archive\;*) # Libraries (.a)
+ strip -v $STRIP_STATIC "$file" ;;
+ application/x-executable\;*) # Binaries
+ strip -v $STRIP_BINARIES "$file" ;;
+ application/x-pie-executable\;*) # Relocatable binaries
+ strip -v $STRIP_SHARED "$file" ;;
+ esac
+ done < <(find "$builddir" -type f -perm -u+x ! -name vmlinux -print0)
+
+ echo "Stripping vmlinux..."
+ strip -v $STRIP_STATIC "$builddir/vmlinux"
+
+ echo "Adding symlink..."
+ mkdir -p "$pkgdir/usr/src"
+ ln -sr "$builddir" "$pkgdir/usr/src/$pkgbase"
+}
+
+pkgname=("$pkgbase" "$pkgbase-headers")
+for _p in "${pkgname[@]}"; do
+ eval "package_$_p() {
+ $(declare -f "_package${_p#$pkgbase}")
+ _package${_p#$pkgbase}
+ }"
+done
diff --git a/configure b/configure
new file mode 100644
index 000000000000..556baad5c93b
--- /dev/null
+++ b/configure
@@ -0,0 +1,263 @@
+#!/usr/bin/bash
+
+cpu_arch() {
+ plain ""
+ plain "#########################################"
+ plain "Set cpu microarchitecture optimization in GCC"
+ read -rp "`echo $' > 1) M486SX : Select this for an 486-class CPU without an FPU such as AMD/Cyrix/IBM/Intel SL/SLC/SLC2/SLC3/SX/SX2 and UMC U5S.\n \
+ > 2) M486 : Select this for an 486-class CPU such as AMD/Cyrix/IBM/Intel 486DX/DX2/DX4 and UMC U5D.\n \
+ > 3) M586 : Select this for an 586 or 686 series processor such as the AMD K5,the Cyrix 5x86, 6x86 and 6x86MX. This choice does not assume the RDTSC (Read Time Stamp Counter) instruction.\n \
+ > 4) M586TSC : Select this for a Pentium Classic processor with the RDTSC (Read Time Stamp Counter) instruction for benchmarking.\n \
+ > 5) M586MMX : Select this for a Pentium with the MMX graphics/multimedia extended instructions.\n \
+ > 6) M686 : Select this for Intel Pentium Pro chips.\n \
+ > 7) MPENTIUMII : Select this for Intel chips based on the Pentium-II and pre-Coppermine Celeron core.\n \
+ > 8) MPENTIUMIII : Select this for Intel chips based on the Pentium-III and Celeron-Coppermine core.\n \
+ > 9) MPENTIUMM : Select this for Intel Pentium M (not Pentium-4 M) notebook chips.\n \
+ > 10) MPENTIUM4 : Select this for Intel Pentium 4 chips.\n \
+ > 11) MK6 : Select this for an AMD K6-family processor.\n \
+ > 12) MK7 : Select this for an AMD Athlon K7-family processor.\n \
+ > 13) MK8 : Select this for an AMD Opteron or Athlon64 Hammer-family processor.\n \
+ > 14) MK8SSE3 : Select this for improved AMD Opteron or Athlon64 Hammer-family processors.\n \
+ > 15) MK10 : Select this for an AMD 61xx Eight-Core Magny-Cours, Athlon X2 7x50,Phenom X3/X4/II, Athlon II X2/X3/X4, or Turion II-family processor.\n \
+ > 16) MBARCELONA : Select this for AMD Family 10h Barcelona processors.\n \
+ > 17) MBOBCAT : Select this for AMD Family 14h Bobcat processors.\n \
+ > 18) MJAGUAR : Select this for AMD Family 16h Jaguar processors.\n \
+ > 19) MBULLDOZER : Select this for AMD Family 15h Bulldozer processors.\n \
+ > 20) MPILEDRIVER : Select this for AMD Family 15h Piledriver processors.\n \
+ > 21) MSTEAMROLLER : Select this for AMD Family 15h Steamroller processors.\n \
+ > 22) MEXCAVATOR : Select this for AMD Family 15h Excavator processors.\n \
+ > 23) MZEN : Select this for AMD Family 17h Zen processors.\n \
+ > 24) MZEN2 : Select this for AMD Family 17h Zen 2 processors.\n \
+ > 25) MZEN3 : Select this for AMD Family 19h Zen 3 processors. - GCC 10.3 required\n \
+ > 26) MCRUSOE : Select this for a Transmeta Crusoe processor.\n \
+ > 27) MEFFICEON : Select this for a Transmeta Efficeon processor.\n \
+ > 28) MWINCHIPC6 : Select this for an IDT Winchip C6 chip.\n \
+ > 29) MWINCHIP3D : Select this for an IDT Winchip-2, 2A or 3.\n \
+ > 30) MELAN : Select this for an AMD Elan processor.\n \
+ > 31) MGEODEGX1 : Select this for a Geode GX1 (Cyrix MediaGX) chip.\n \
+ > 32) MGEODE_LX Select this for AMD Geode GX and LX processors.\n \
+ > 33) MCYRIXIII : Select this for a Cyrix III or C3 chip.\n \
+ > 34) MVIAC3_2 : Select this for a VIA C3 "Nehemiah".\n \
+ > 35) MVIAC7 : Select this for a VIA C7.\n \
+ > 36) MPSC : Optimize for Intel Pentium 4, Pentium D and older Nocona/Dempsey Xeon CPUs with Intel 64bit which is compatible with x86-64.\n \
+ > 37) MATOM : Select this for the Intel Atom platform.\n \
+ > 38) MCORE2 : Select this for Intel Core 2 and newer Core 2 Xeons (Xeon 51xx and 53xx) CPUs.\n \
+ > 39) MNEHALEM : Select this for 1st Gen Core processors in the Nehalem family.\n \
+ > 40) MWESTMERE : Select this for the Intel Westmere formerly Nehalem-C family.\n \
+ > 41) MSILVERMONT Select this for the Intel Silvermont platform.\n \
+ > 42) MGOLDMONT : Select this for the Intel Goldmont platform including Apollo Lake and Denverton.\n \
+ > 43) MGOLDMONTPLUS : Select this for the Intel Goldmont Plus platform including Gemini Lake.\n \
+ > 44) MSANDYBRIDGE : Select this for 2nd Gen Core processors in the Sandy Bridge family.\n \
+ > 45) MIVYBRIDGE : Select this for 3rd Gen Core processors in the Ivy Bridge family.\n \
+ > 46) MHASWELL : Select this for 4th Gen Core processors in the Haswell family.\n \
+ > 47) MBROADWELL : Select this for 5th Gen Core processors in the Broadwell family.\n \
+ > 48) MSKYLAKE : Select this for 6th Gen Core processors in the Skylake family.\n \
+ > 49) MSKYLAKEX : Select this for 6th Gen Core processors in the Skylake X family.\n \
+ > 50) MCANNONLAKE : Select this for 8th Gen Core processors.\n \
+ > 51) MICELAKE : Select this for 10th Gen Core processors in the Ice Lake family.\n \
+ > 52) MCASCADELAKE : Select this for Xeon processors in the Cascade Lake family.\n \
+ > 53) MCOOPERLAKE : Select this for Xeon processors in the Cooper Lake family. - GCC 10.1 required\n \
+ > 54) MTIGERLAKE : Select this for third-generation 10 nm process processors in the Tiger Lake family. - GCC 10.1 required\n \
+ > 55) MSAPPHIRERAPIDS : Select this for third-generation 10 nm process processors in the Sapphire Rapids family. - GCC 11 required\n \
+ > 56) MALDERLAKE : Select this for twelfth-generation processors in the Alder Lake family.- GCC 11 required\n \
+ > 57) GENERIC_CPU : Generic x86-64 CPU. Run equally well on all x86-64 CPUs.\n \
+ > 58) GENERIC_CPU2 : Run equally well on all x86-64 CPUs with min support of x86-64-v2. - GCC 11 required\n \
+ > 59) GENERIC_CPU3 : Generic x86-64-v3 CPU with v3 instructions. Run equally well on all x86-64 CPUs with min support of x86-64-v3. - GCC 11 required\n \
+ > 60) GENERIC_CPU4 : Generic x86-64 CPU with v4 instructions. Run equally well on all x86-64 CPUs with min support of x86-64-v4. - GCC 11 required\n \
+ > 61) MNATIVE_INTEL : Intel-Native optimizations autodetected by GCC.\n \
+ > 62) MNATIVE_AMD : AMD-Native optimizations autodetected by GCC.\n \
+ > Default (57 : Gneric CPU)\nchoice[0-56]: '`" _microarchitecture
+
+ if [[ "$_microarchitecture" = "1" ]]; then
+ scripts/config --disable CONFIG_GENERIC_CPU
+ scripts/config --enable CONFIG_M486
+ elif [[ "$_microarchitecture" = "2" ]]; then
+ scripts/config --disable CONFIG_GENERIC_CPU
+ scripts/config --enable CONFIG_M486
+ elif [[ "$_microarchitecture" = "3" ]]; then
+ scripts/config --disable CONFIG_GENERIC_CPU
+ scripts/config --enable CONFIG_M586
+ elif [[ "$_microarchitecture" = "4" ]]; then
+ scripts/config --disable CONFIG_GENERIC_CPU
+ scripts/config --enable CONFIG_M586TSC
+ elif [[ "$_microarchitecture" = "5" ]]; then
+ scripts/config --disable CONFIG_GENERIC_CPU
+ scripts/config --enable CONFIG_M586MMX
+ elif [[ "$_microarchitecture" = "6" ]]; then
+ scripts/config --disable CONFIG_GENERIC_CPU
+ scripts/config --enable CONFIG_M686
+ elif [[ "$_microarchitecture" = "7" ]]; then
+ scripts/config --disable CONFIG_GENERIC_CPU
+ scripts/config --enable CONFIG_MPENTIUMII
+ elif [[ "$_microarchitecture" = "8" ]]; then
+ scripts/config --disable CONFIG_GENERIC_CPU
+ scripts/config --enable CONFIG_MPENTIUMIII
+ elif [[ "$_microarchitecture" = "9" ]]; then
+ scripts/config --disable CONFIG_GENERIC_CPU
+ scripts/config --enable CONFIG_MPENTIUMM
+ elif [[ "$_microarchitecture" = "10" ]]; then
+ scripts/config --disable CONFIG_GENERIC_CPU
+ scripts/config --enable CONFIG_MPENTIUM4
+ elif [[ "$_microarchitecture" = "11" ]]; then
+ scripts/config --disable CONFIG_GENERIC_CPU
+ scripts/config --enable CONFIG_MK6
+ elif [[ "$_microarchitecture" = "12" ]]; then
+ scripts/config --disable CONFIG_GENERIC_CPU
+ scripts/config --enable CONFIG_MK7
+ elif [[ "$_microarchitecture" = "13" ]]; then
+ scripts/config --disable CONFIG_GENERIC_CPU
+ scripts/config --enable CONFIG_MK8
+ elif [[ "$_microarchitecture" = "14" ]]; then
+ scripts/config --disable CONFIG_GENERIC_CPU
+ scripts/config --enable CONFIG_MK8SSE3
+ elif [[ "$_microarchitecture" = "15" ]]; then
+ scripts/config --disable CONFIG_GENERIC_CPU
+ scripts/config --enable CONFIG_MK10
+ elif [[ "$_microarchitecture" = "16" ]]; then
+ scripts/config --disable CONFIG_GENERIC_CPU
+ scripts/config --enable CONFIG_MBARCELONA
+ elif [[ "$_microarchitecture" = "17" ]]; then
+ scripts/config --disable CONFIG_GENERIC_CPU
+ scripts/config --enable CONFIG_MBOBCAT
+ elif [[ "$_microarchitecture" = "18" ]]; then
+ scripts/config --disable CONFIG_GENERIC_CPU
+ scripts/config --enable CONFIG_MJAGUAR
+ elif [[ "$_microarchitecture" = "19" ]]; then
+ scripts/config --disable CONFIG_GENERIC_CPU
+ scripts/config --enable CONFIG_MBULLDOZER
+ elif [[ "$_microarchitecture" = "20" ]]; then
+ scripts/config --disable CONFIG_GENERIC_CPU
+ scripts/config --enable CONFIG_MPILEDRIVER
+ elif [[ "$_microarchitecture" = "21" ]]; then
+ scripts/config --disable CONFIG_GENERIC_CPU
+ scripts/config --enable CONFIG_MSTEAMROLLER
+ elif [[ "$_microarchitecture" = "22" ]]; then
+ scripts/config --disable CONFIG_GENERIC_CPU
+ scripts/config --enable CONFIG_MEXCAVATOR
+ elif [[ "$_microarchitecture" = "23" ]]; then
+ scripts/config --disable CONFIG_GENERIC_CPU
+ scripts/config --enable CONFIG_MZEN
+ elif [[ "$_microarchitecture" = "24" ]]; then
+ scripts/config --disable CONFIG_GENERIC_CPU
+ scripts/config --enable CONFIG_MZEN2
+ elif [[ "$_microarchitecture" = "25" ]]; then
+ scripts/config --disable CONFIG_GENERIC_CPU
+ scripts/config --enable CONFIG_MZEN3
+ elif [[ "$_microarchitecture" = "26" ]]; then
+ scripts/config --disable CONFIG_GENERIC_CPU
+ scripts/config --enable CONFIG_MCRUSOE
+ elif [[ "$_microarchitecture" = "27" ]]; then
+ scripts/config --disable CONFIG_GENERIC_CPU
+ scripts/config --enable CONFIG_MEFFICEON
+ elif [[ "$_microarchitecture" = "28" ]]; then
+ scripts/config --disable CONFIG_GENERIC_CPU
+ scripts/config --enable CONFIG_MWINCHIPC6
+ elif [[ "$_microarchitecture" = "29" ]]; then
+ scripts/config --disable CONFIG_GENERIC_CPU
+ scripts/config --enable CONFIG_MWINCHIP3D
+ elif [[ "$_microarchitecture" = "30" ]]; then
+ scripts/config --disable CONFIG_GENERIC_CPU
+ scripts/config --enable CONFIG_MELAN
+ elif [[ "$_microarchitecture" = "31" ]]; then
+ scripts/config --disable CONFIG_GENERIC_CPU
+ scripts/config --enable CONFIG_MGEODEGX1
+ elif [[ "$_microarchitecture" = "32" ]]; then
+ scripts/config --disable CONFIG_GENERIC_CPU
+ scripts/config --enable CONFIG_MGEODE_LX
+ elif [[ "$_microarchitecture" = "33" ]]; then
+ scripts/config --disable CONFIG_GENERIC_CPU
+ scripts/config --enable CONFIG_MCYRIXIII
+ elif [[ "$_microarchitecture" = "34" ]]; then
+ scripts/config --disable CONFIG_GENERIC_CPU
+ scripts/config --enable CONFIG_MVIAC3_2
+ elif [[ "$_microarchitecture" = "35" ]]; then
+ scripts/config --disable CONFIG_GENERIC_CPU
+ scripts/config --enable CONFIG_MVIAC7
+ elif [[ "$_microarchitecture" = "36" ]]; then
+ scripts/config --disable CONFIG_GENERIC_CPU
+ scripts/config --enable CONFIG_MPSC
+ elif [[ "$_microarchitecture" = "37" ]]; then
+ scripts/config --disable CONFIG_GENERIC_CPU
+ scripts/config --enable CONFIG_MATOM
+ elif [[ "$_microarchitecture" = "38" ]]; then
+ scripts/config --disable CONFIG_GENERIC_CPU
+ scripts/config --enable CONFIG_MCORE2
+ elif [[ "$_microarchitecture" = "39" ]]; then
+ scripts/config --disable CONFIG_GENERIC_CPU
+ scripts/config --enable CONFIG_MNEHALEM
+ elif [[ "$_microarchitecture" = "40" ]]; then
+ scripts/config --disable CONFIG_GENERIC_CPU
+ scripts/config --enable CONFIG_MWESTMERE
+ elif [[ "$_microarchitecture" = "41" ]]; then
+ scripts/config --disable CONFIG_GENERIC_CPU
+ scripts/config --enable CONFIG_MSILVERMONT
+ elif [[ "$_microarchitecture" = "42" ]]; then
+ scripts/config --disable CONFIG_GENERIC_CPU
+ scripts/config --enable CONFIG_MGOLDMONT
+ elif [[ "$_microarchitecture" = "43" ]]; then
+ scripts/config --disable CONFIG_GENERIC_CPU
+ scripts/config --enable CONFIG_MGOLDMONTPLUS
+ elif [[ "$_microarchitecture" = "44" ]]; then
+ scripts/config --disable CONFIG_GENERIC_CPU
+ scripts/config --enable CONFIG_MSANDYBRIDGE
+ elif [[ "$_microarchitecture" = "45" ]]; then
+ scripts/config --disable CONFIG_GENERIC_CPU
+ scripts/config --enable CONFIG_MIVYBRIDGE
+ elif [[ "$_microarchitecture" = "46" ]]; then
+ scripts/config --disable CONFIG_GENERIC_CPU
+ scripts/config --enable CONFIG_MHASWELL
+ elif [[ "$_microarchitecture" = "47" ]]; then
+ scripts/config --disable CONFIG_GENERIC_CPU
+ scripts/config --enable CONFIG_MBROADWELL
+ elif [[ "$_microarchitecture" = "48" ]]; then
+ scripts/config --disable CONFIG_GENERIC_CPU
+ scripts/config --enable CONFIG_MSKYLAKE
+ elif [[ "$_microarchitecture" = "49" ]]; then
+ scripts/config --disable CONFIG_GENERIC_CPU
+ scripts/config --enable CONFIG_MSKYLAKEX
+ elif [[ "$_microarchitecture" = "50" ]]; then
+ scripts/config --disable CONFIG_GENERIC_CPU
+ scripts/config --enable CONFIG_MCANNONLAKE
+ elif [[ "$_microarchitecture" = "51" ]]; then
+ scripts/config --disable CONFIG_GENERIC_CPU
+ scripts/config --enable CONFIG_MICELAKE
+ elif [[ "$_microarchitecture" = "52" ]]; then
+ scripts/config --disable CONFIG_GENERIC_CPU
+ scripts/config --enable CONFIG_MCASCADELAKE
+ elif [[ "$_microarchitecture" = "53" ]]; then
+ scripts/config --disable CONFIG_GENERIC_CPU
+ scripts/config --enable CONFIG_MCOOPERLAKE
+ elif [[ "$_microarchitecture" = "54" ]]; then
+ scripts/config --disable CONFIG_GENERIC_CPU
+ scripts/config --enable CONFIG_MTIGERLAKE
+ elif [[ "$_microarchitecture" = "55" ]]; then
+ scripts/config --disable CONFIG_GENERIC_CPU
+ scripts/config --enable CONFIG_MSAPPHIRERAPIDS
+ elif [[ "$_microarchitecture" = "56" ]]; then
+ scripts/config --disable CONFIG_GENERIC_CPU
+ scripts/config --enable CONFIG_MALDERLAKE
+ elif [[ "$_microarchitecture" = "57" ]]; then
+ scripts/config --enable CONFIG_GENERIC_CPU
+ elif [[ "$_microarchitecture" = "58" ]]; then
+ scripts/config --disable CONFIG_GENERIC_CPU
+ scripts/config --enable CONFIG_GENERIC_CPU2
+ elif [[ "$_microarchitecture" = "59" ]]; then
+ scripts/config --disable CONFIG_GENERIC_CPU
+ scripts/config --enable CONFIG_GENERIC_CPU3
+ elif [[ "$_microarchitecture" = "60" ]]; then
+ scripts/config --disable CONFIG_GENERIC_CPU
+ scripts/config --enable CONFIG_GENERIC_CPU4
+ elif [[ "$_microarchitecture" = "61" ]]; then
+ scripts/config --disable CONFIG_GENERIC_CPU
+ scripts/config --enable CONFIG_MNATIVE_INTEL
+ elif [[ "$_microarchitecture" = "62" ]]; then
+ scripts/config --disable CONFIG_GENERIC_CPU
+ scripts/config --enable CONFIG_MNATIVE_AMD
+ else
+ scripts/config --enable CONFIG_GENERIC_CPU
+ fi
+
+ plain ""
+
+ sleep 2
+}