summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorantman6662021-07-29 18:46:47 +0800
committerantman6662021-07-29 18:46:47 +0800
commite6a976f9ae1aff4c5e5ec957afd459e8f853aa05 (patch)
tree850faafa5025e68ef5ea0ea4b58821e13cbfda95
parentc0f6ab7b9a23a66c58f35b90a35afcd1a0aec4e9 (diff)
downloadaur-e6a976f9ae1aff4c5e5ec957afd459e8f853aa05.tar.gz
update linux-xanmod-cacule-uksm-cjktty to 5.13.6-2
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD53
2 files changed, 50 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b1c9602c4c70..89a4a0461e98 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = linux-xanmod-cacule-uksm-cjktty
pkgdesc = Linux Xanmod. Branch with Cacule scheduler by Hamad Marri
- pkgver = 5.13.5
- pkgrel = 1
+ pkgver = 5.13.6
+ pkgrel = 2
url = http://www.xanmod.org/
arch = x86_64
license = GPL2
@@ -14,20 +14,20 @@ pkgbase = linux-xanmod-cacule-uksm-cjktty
options = !strip
source = https://cdn.kernel.org/pub/linux/kernel/v5.x/linux-5.13.tar.xz
source = https://cdn.kernel.org/pub/linux/kernel/v5.x/linux-5.13.tar.sign
- source = https://github.com/xanmod/linux/releases/download/5.13.5-xanmod1-cacule/patch-5.13.5-xanmod1-cacule.xz
+ source = https://github.com/xanmod/linux/releases/download/5.13.6-xanmod2-cacule/patch-5.13.6-xanmod2-cacule.xz
source = choose-gcc-optimization.sh
source = 0001-cjktty.patch::https://gitlab.com/sirlucjan/kernel-patches/-/raw/master/5.13/cjktty-patches/0001-cjktty-5.13-initial-import-from-https-github.com-zhm.patch
source = 0002-UKSM.patch::https://gitlab.com/sirlucjan/kernel-patches/-/raw/master/5.13/uksm-patches/0001-UKSM-for-5.13.patch
- source = 0003-zstd.patch::https://gitlab.com/sirlucjan/kernel-patches/-/raw/master/5.13/zstd-patches-v4/0001-zstd-patches.patch
+ source = 0003-zstd.patch::https://gitlab.com/sirlucjan/kernel-patches/-/raw/master/5.13/zstd-patches-v5/0001-zstd-patches.patch
validpgpkeys = ABAF11C65A2970B130ABE3C479BE3E4300411886
validpgpkeys = 647F28654894E3BD457199BE38DBBDC86092693E
b2sums = 9c4c12e2394dec064adff51f7ccdf389192eb27ba7906db5eda543afe3d04afca6b9ea0848a057571bf2534eeb98e1e3a67734deff82c0d3731be205ad995668
b2sums = SKIP
- b2sums = c17e1f98e5ec81f5ba2724d0bf3132933b8e1276329f24f076c23d8476fe1a3518fb7314b85e0446be355b65d94c3c5d2d8f5f19468df0f9c7dbbbd2e86fe84d
+ b2sums = c1996772cd377d81b810b74c26367320780c28e6d93b2bdfe81b0a84fd05d0327873e8a8ccb3882be9e0f96578456ed3d0370083b8b55e8bbf9bf7f4ad92979c
b2sums = 2f0d5ddc9a1003958e8a3745cb42e47af8e7ff9961dd3d2ea070cc72444b5c63763f953b393bdd7c8a31f3ea29e8d3c86cc8647ae67bb054e22bce34af492ce1
b2sums = cb72248c2226b5c1a39422d9d9a79a4f9331c965a888185f421619185231a290d74e273c2323ab2c9340adfb269259825da781af423674abfbc9be909db0cc35
b2sums = 066e1d2cf209eed973957b00eebe3cbcce37b77e9ab0ef115da0aa6984ac6dea1b5d43fedd6e87dbda042b620a7684eae6c36a739f7a49e0f96ebd41867947f4
- b2sums = 676ea6c04f0e531c15b42e1548ebdba087f593d059947763cce879b23c759bd183234649ed3d2fc4255fea7a32a7605076fc0b65f5125e74abab735e0f331394
+ b2sums = c88d3053e0e1d1145ec7d487df7ed1c18b8a4e8cf62f8fc9e05baa5f1b270aa64177f33b13c1d409e63a83691cc530e5f848ab73bfd2b10f60cdb681b9e310c1
pkgname = linux-xanmod-cacule-uksm-cjktty
pkgdesc = The Linux kernel and modules with Xanmod patches
diff --git a/PKGBUILD b/PKGBUILD
index 7b151b292f5b..2d4d444ffd59 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -27,16 +27,15 @@ fi
## Archlinux and Xanmod enable it by default.
## Set variable "use_numa" to: n to disable (possibly increase performance)
## y to enable (stock default)
-## Here keep default is ok
+## Here keeps default is ok
if [ -z ${use_numa+x} ]; then
- use_numa=y
+ use_numa=n
fi
## For performance you can disable FUNCTION_TRACER/GRAPH_TRACER. Limits debugging and analyzing of the kernel.
## Stock Archlinux and Xanmod have this enabled.
## Set variable "use_tracers" to: n to disable (possibly increase performance)
## y to enable (stock default)
-## I think close this is better
if [ -z ${use_tracers+x} ]; then
use_tracers=y
fi
@@ -46,6 +45,12 @@ if [ -z ${_compiler+x} ]; then
_compiler=gcc
fi
+## Setting some security options
+use_selinux=n
+use_tomoyo=n
+use_yama=n
+use_apparmor=
+
# Compile ONLY used modules to VASTLYreduce the number of modules built
# and the build time.
#
@@ -65,10 +70,10 @@ _makenconfig=
pkgbase=linux-xanmod-cacule-uksm-cjktty
_major=5.13
-pkgver=${_major}.5
+pkgver=${_major}.6
_branch=5.x
-xanmod=1
-pkgrel=1
+xanmod=2
+pkgrel=${xanmod}
pkgdesc='Linux Xanmod. Branch with Cacule scheduler by Hamad Marri'
_patches_url="https://gitlab.com/sirlucjan/kernel-patches/-/raw/master/${_major}"
url="http://www.xanmod.org/"
@@ -91,8 +96,9 @@ source=("https://cdn.kernel.org/pub/linux/kernel/v${_branch}/linux-${_major}.tar
choose-gcc-optimization.sh
"0001-cjktty.patch::${_patches_url}/cjktty-patches/0001-cjktty-${_major}-initial-import-from-https-github.com-zhm.patch"
"0002-UKSM.patch::${_patches_url}/uksm-patches/0001-UKSM-for-${_major}.patch"
- "0003-zstd.patch::${_patches_url}/zstd-patches-v4/0001-zstd-patches.patch"
+ "0003-zstd.patch::${_patches_url}/zstd-patches-v5/0001-zstd-patches.patch"
)
+
validpgpkeys=(
'ABAF11C65A2970B130ABE3C479BE3E4300411886' # Linux Torvalds
'647F28654894E3BD457199BE38DBBDC86092693E' # Greg Kroah-Hartman
@@ -106,11 +112,11 @@ done
b2sums=('9c4c12e2394dec064adff51f7ccdf389192eb27ba7906db5eda543afe3d04afca6b9ea0848a057571bf2534eeb98e1e3a67734deff82c0d3731be205ad995668'
'SKIP'
- 'c17e1f98e5ec81f5ba2724d0bf3132933b8e1276329f24f076c23d8476fe1a3518fb7314b85e0446be355b65d94c3c5d2d8f5f19468df0f9c7dbbbd2e86fe84d'
+ 'c1996772cd377d81b810b74c26367320780c28e6d93b2bdfe81b0a84fd05d0327873e8a8ccb3882be9e0f96578456ed3d0370083b8b55e8bbf9bf7f4ad92979c'
'2f0d5ddc9a1003958e8a3745cb42e47af8e7ff9961dd3d2ea070cc72444b5c63763f953b393bdd7c8a31f3ea29e8d3c86cc8647ae67bb054e22bce34af492ce1'
'cb72248c2226b5c1a39422d9d9a79a4f9331c965a888185f421619185231a290d74e273c2323ab2c9340adfb269259825da781af423674abfbc9be909db0cc35'
'066e1d2cf209eed973957b00eebe3cbcce37b77e9ab0ef115da0aa6984ac6dea1b5d43fedd6e87dbda042b620a7684eae6c36a739f7a49e0f96ebd41867947f4'
- '676ea6c04f0e531c15b42e1548ebdba087f593d059947763cce879b23c759bd183234649ed3d2fc4255fea7a32a7605076fc0b65f5125e74abab735e0f331394'
+ 'c88d3053e0e1d1145ec7d487df7ed1c18b8a4e8cf62f8fc9e05baa5f1b270aa64177f33b13c1d409e63a83691cc530e5f848ab73bfd2b10f60cdb681b9e310c1'
)
export KBUILD_BUILD_HOST=${KBUILD_BUILD_HOST:-archlinux}
@@ -160,12 +166,41 @@ prepare() {
msg2 "Disabling NUMA..."
scripts/config --disable CONFIG_NUMA
fi
+
+ if [ "$use_selinux" = "n" ]; then
+ msg2 "Disabling SELinux..."
+ scripts/config --disable CONFIG_SECURITY_SELINUX
+ fi
+
+ if [ "$use_tomoyo" = "n" ]; then
+ msg2 "Disabling TOMOYO..."
+ scripts/config --disable CONFIG_SECURITY_TOMOYO
+ fi
+
+ if [ "$use_apparmor" = "n" ]; then
+ msg2 "Disabling AppArmor..."
+ scripts/config --disable CONFIG_SECURITY_APPARMOR
+ scripts/config --set-str CONFIG_LSM lockdown,yama,integrity
+ fi
+
+ if [ "$use_yama" = "n" ]; then
+ msg2 "Disabling YAMA..."
+ scripts/config --disable CONFIG_SECURITY_YAMA
+ scripts/config --set-str CONFIG_LSM lockdown,integrity,apparmor
+ fi
+
+ scripts/config --disable CONFIG_DEFAULT_SECURITY_APPARMOR
+ scripts/config --enable CONFIG_DEFAULT_SECURITY_DAC
scripts/config --disable CONFIG_KVM_WERROR
scripts/config --disable CONFIG_X86_X32
scripts/config --disable CONFIG_MQ_IOSCHED_DEADLINE
scripts/config --disable CONFIG_MQ_IOSCHED_KYBER
scripts/config --module CONFIG_EXT4_FS
+ scripts/config --set-val CONFIG_KERNEL_ZSTD_LEVEL 15
+ scripts/config --enable CONFIG_KERNEL_ZSTD_LEVEL_ULTRA
+ scripts/config --disable CONFIG_CC_OPTIMIZE_FOR_PERFORMANCE_O3
+ scripts/config --enable CONFIG_CC_OPTIMIZE_FOR_SIZE
msg2 "Enable LRU"
scripts/config --enable CONFIG_LRU_GEN