summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoan Figueras2022-01-28 00:13:50 +0100
committerJoan Figueras2022-01-28 00:13:50 +0100
commit55c59082697aed0566269577115ec0ba1ae86d2d (patch)
tree183a7381d91cbd01a0cc0d4a7e5d30de0712543c
parentf1711be2a3c24efcb0aea0fe5a31481ff796df3f (diff)
downloadaur-55c59082697aed0566269577115ec0ba1ae86d2d.tar.gz
Workaround for #240
-rw-r--r--PKGBUILD3
1 files changed, 3 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 272d5362bd1e..8ba85a599901 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -162,6 +162,9 @@ prepare() {
# Let's user choose microarchitecture optimization in GCC
sh ${srcdir}/choose-gcc-optimization.sh $_microarchitecture
+ # Disable CONFIG_GENERIC_CPU2 if we have choosen another microarchitecture
+ # https://github.com/xanmod/linux/issues/240
+ [ "$_microarchitecture" = "0" ] || scripts/config --disable CONFIG_GENERIC_CPU2
# This is intended for the people that want to build this package with their own config
# Put the file "myconfig" at the package folder (this will take preference) or "${XDG_CONFIG_HOME}/linux-xanmod/myconfig"