summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoan Figueras2023-11-09 01:16:19 +0100
committerJoan Figueras2023-11-09 01:16:19 +0100
commit59480a2b6188eb93076c88bc62a1b2a227894701 (patch)
tree3e2c89e1659b879631adf02d41f64e515ec7e1b2
parent46083e7973da4ce2c701ade04ea699ee939fc0cf (diff)
downloadaur-59480a2b6188eb93076c88bc62a1b2a227894701.tar.gz
Fixed tracers config if no _compiler set
-rw-r--r--PKGBUILD2
1 files changed, 1 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 6fe19aadfce3..2570b3c77530 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -167,7 +167,7 @@ prepare() {
# User set. See at the top of this file
if [ "$use_tracers" = "y" ]; then
msg2 "Enabling CONFIG_FTRACE only if we are not compiling with clang..."
- if [ "${_compiler}" = "gcc" ]; then
+ if [ "${_compiler}" = "gcc" ] || [ "${_compiler}q" = "q" ]; then
scripts/config --enable CONFIG_FTRACE \
--enable CONFIG_FUNCTION_TRACER \
--enable CONFIG_STACK_TRACER