summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoan Figueras2022-01-13 09:41:13 +0100
committerJoan Figueras2022-01-13 09:41:13 +0100
commit95ac1b3cb5df225cf7c2629304a1f6315a0c58cb (patch)
tree4550c161d5dea0a08efc023601a731bde7755ba3
parentc40119baf8061ccf95f460865f4be6b9759e3740 (diff)
downloadaur-95ac1b3cb5df225cf7c2629304a1f6315a0c58cb.tar.gz
5.16.0-xanmod1
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD27
2 files changed, 20 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c4f7ddf0af21..05e27a928a17 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = linux-xanmod-edge
pkgdesc = Linux Xanmod - Latest Mainline (EDGE)
- pkgver = 5.15.14
+ pkgver = 5.16.0
pkgrel = 1
url = http://www.xanmod.org/
arch = x86_64
@@ -13,15 +13,15 @@ pkgbase = linux-xanmod-edge
makedepends = tar
makedepends = xz
options = !strip
- source = https://cdn.kernel.org/pub/linux/kernel/v5.x/linux-5.15.tar.xz
- source = https://cdn.kernel.org/pub/linux/kernel/v5.x/linux-5.15.tar.sign
- source = https://github.com/xanmod/linux/releases/download/5.15.14-xanmod1/patch-5.15.14-xanmod1.xz
+ source = https://cdn.kernel.org/pub/linux/kernel/v5.x/linux-5.16.tar.xz
+ source = https://cdn.kernel.org/pub/linux/kernel/v5.x/linux-5.16.tar.sign
+ source = https://github.com/xanmod/linux/releases/download/5.16.0-xanmod1/patch-5.16.0-xanmod1.xz
source = choose-gcc-optimization.sh
validpgpkeys = ABAF11C65A2970B130ABE3C479BE3E4300411886
validpgpkeys = 647F28654894E3BD457199BE38DBBDC86092693E
- sha256sums = 57b2cf6991910e3b67a1b3490022e8a0674b6965c74c12da1e99d138d1991ee8
+ sha256sums = 027d7e8988bb69ac12ee92406c3be1fe13f990b1ca2249e226225cd1573308bb
sha256sums = SKIP
- sha256sums = ea5dceb862b22e645d72e0d759b646643bc6569d0910f1711aedb66447962c76
+ sha256sums = 8d54d0c699a77c93b743a3cdd6e6af62c46707d4781534a837e84aaa5fcc5978
sha256sums = 1ac18cad2578df4a70f9346f7c6fccbb62f042a0ee0594817fdef9f2704904ee
pkgname = linux-xanmod-edge
diff --git a/PKGBUILD b/PKGBUILD
index 52ee2066a22f..cf4de4ce0c63 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,6 @@
# Maintainer: Joan Figueras <ffigue at gmail dot com>
# Contributor: Torge Matthies <openglfreak at googlemail dot com>
# Contributor: Jan Alexander Steffens (heftig) <jan.steffens@gmail.com>
-# Contributor: Yoshi2889 <rick.2889 at gmail dot com>
-# Contributor: Tobias Powalowski <tpowa@archlinux.org>
-# Contributor: Thomas Baechler <thomas@archlinux.org>
##
## The following variables can be customized at build time. Use env or export to change at your wish
@@ -62,8 +59,8 @@ _makenconfig=
### IMPORTANT: Do no edit below this line unless you know what you're doing
pkgbase=linux-xanmod-edge
-_major=5.15
-pkgver=${_major}.14
+_major=5.16
+pkgver=${_major}.0
_branch=5.x
xanmod=1
pkgrel=${xanmod}
@@ -98,9 +95,9 @@ for _patch in ${_patches[@]}; do
source+=("${_patch}::https://raw.githubusercontent.com/archlinux/svntogit-packages/${_commit}/trunk/${_patch}")
done
-sha256sums=('57b2cf6991910e3b67a1b3490022e8a0674b6965c74c12da1e99d138d1991ee8'
+sha256sums=('027d7e8988bb69ac12ee92406c3be1fe13f990b1ca2249e226225cd1573308bb'
'SKIP'
- 'ea5dceb862b22e645d72e0d759b646643bc6569d0910f1711aedb66447962c76'
+ '8d54d0c699a77c93b743a3cdd6e6af62c46707d4781534a837e84aaa5fcc5978'
'1ac18cad2578df4a70f9346f7c6fccbb62f042a0ee0594817fdef9f2704904ee')
export KBUILD_BUILD_HOST=${KBUILD_BUILD_HOST:-archlinux}
@@ -253,11 +250,11 @@ _package-headers() {
install -Dt "$builddir/arch/x86" -m644 arch/x86/Makefile
cp -t "$builddir" -a scripts
- # add objtool for external module building and enabled VALIDATION_STACK option
+ # required when STACK_VALIDATION is enabled
install -Dt "$builddir/tools/objtool" tools/objtool/objtool
- # add xfs and shmem for aufs building
- mkdir -p "$builddir"/{fs/xfs,mm}
+ # required when DEBUG_INFO_BTF_MODULES is enabled
+ if [ -f "$builddir/tools/bpf/resolve_btfids" ]; then install -Dt "$builddir/tools/bpf/resolve_btfids" tools/bpf/resolve_btfids/resolve_btfids ; fi
msg2 "Installing headers..."
cp -t "$builddir" -a include
@@ -267,15 +264,18 @@ _package-headers() {
install -Dt "$builddir/drivers/md" -m644 drivers/md/*.h
install -Dt "$builddir/net/mac80211" -m644 net/mac80211/*.h
- # http://bugs.archlinux.org/task/13146
+ # https://bugs.archlinux.org/task/13146
install -Dt "$builddir/drivers/media/i2c" -m644 drivers/media/i2c/msp3400-driver.h
- # http://bugs.archlinux.org/task/20402
+ # https://bugs.archlinux.org/task/20402
install -Dt "$builddir/drivers/media/usb/dvb-usb" -m644 drivers/media/usb/dvb-usb/*.h
install -Dt "$builddir/drivers/media/dvb-frontends" -m644 drivers/media/dvb-frontends/*.h
install -Dt "$builddir/drivers/media/tuners" -m644 drivers/media/tuners/*.h
- msg2 "Installing KConfig files..."
+ # https://bugs.archlinux.org/task/71392
+ install -Dt "$builddir/drivers/iio/common/hid-sensors" -m644 drivers/iio/common/hid-sensors/*.h
+
+ echo "Installing KConfig files..."
find . -name 'Kconfig*' -exec install -Dm644 {} "$builddir/{}" \;
msg2 "Removing unneeded architectures..."
@@ -312,6 +312,7 @@ _package-headers() {
msg2 "Stripping vmlinux..."
strip -v $STRIP_STATIC "$builddir/vmlinux"
+
msg2 "Adding symlink..."
mkdir -p "$pkgdir/usr/src"
ln -sr "$builddir" "$pkgdir/usr/src/$pkgbase"