summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoan Figueras2022-01-29 16:05:30 +0100
committerJoan Figueras2022-01-29 16:05:30 +0100
commitc1d7e0ca0c714f013e3bbdd3cd348cb1d7ce09e0 (patch)
treebc22a047c5cd3686806e2724afe06ddf7381349d
parent55c59082697aed0566269577115ec0ba1ae86d2d (diff)
downloadaur-c1d7e0ca0c714f013e3bbdd3cd348cb1d7ce09e0.tar.gz
Convert _makenconfig as external variable, as requested by Gobidev
-rw-r--r--PKGBUILD8
1 files changed, 6 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8ba85a599901..1ad9520de97b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -54,7 +54,9 @@ if [ -z ${_localmodcfg} ]; then
fi
# Tweak kernel options prior to a build via nconfig
-_makenconfig=
+if [ -z ${_makenconfig} ]; then
+ _makenconfig=n
+fi
### IMPORTANT: Do no edit below this line unless you know what you're doing
@@ -203,7 +205,9 @@ prepare() {
make -s kernelrelease > version
msg2 "Prepared %s version %s" "$pkgbase" "$(<version)"
- [[ -z "$_makenconfig" ]] || make LLVM=$_LLVM LLVM_IAS=$_LLVM nconfig
+ if [ "$_makenconfig" = "y" ]; then
+ make LLVM=$_LLVM LLVM_IAS=$_LLVM nconfig
+ fi
# save configuration for later reuse
cat .config > "${SRCDEST}/config.last"