summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoan Figueras2023-01-29 01:20:59 +0100
committerJoan Figueras2023-01-29 01:20:59 +0100
commita6fa48b2e682af49cf0a62f6ab797a4c217ab64d (patch)
tree54620e0e90a2297e1aa144b37cb5ad7d21c09bea
parent14efc4f3a387c393e2f80134a3eb9dc3b89e53ac (diff)
downloadaur-a6fa48b2e682af49cf0a62f6ab797a4c217ab64d.tar.gz
6.1.8-xanmod1
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD25
2 files changed, 14 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 57182731fdad..ce85d993b906 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -7,11 +7,11 @@ pkgbase = linux-xanmod-linux-bin-x64v1
license = GPL2
makedepends = jq
makedepends = curl
- noextract = linux-image-6.1.8-x64v1-xanmod1_6.1.8-x64v1-xanmod1-0.20230124.3dcd53f_amd64.deb
- noextract = linux-headers-6.1.8-x64v1-xanmod1_6.1.8-x64v1-xanmod1-0.20230124.3dcd53f_amd64.deb
+ noextract = linux-image-6.1.8-x64v1-xanmod1_6.1.8-x64v1-xanmod1-0~20230124.3dcd53f_amd64.deb
+ noextract = linux-headers-6.1.8-x64v1-xanmod1_6.1.8-x64v1-xanmod1-0~20230124.3dcd53f_amd64.deb
options = !strip
- source = https://github.com/xanmod/linux/releases/download/6.1.8-xanmod1/linux-image-6.1.8-x64v1-xanmod1_6.1.8-x64v1-xanmod1-0.20230124.3dcd53f_amd64.deb
- source = https://github.com/xanmod/linux/releases/download/6.1.8-xanmod1/linux-headers-6.1.8-x64v1-xanmod1_6.1.8-x64v1-xanmod1-0.20230124.3dcd53f_amd64.deb
+ source = linux-image-6.1.8-x64v1-xanmod1_6.1.8-x64v1-xanmod1-0~20230124.3dcd53f_amd64.deb::https://sourceforge.net/projects/xanmod/files/releases/main/6.1.8-x64v1-xanmod1/linux-image-6.1.8-x64v1-xanmod1_6.1.8-x64v1-xanmod1-0~20230124.3dcd53f_amd64.deb/download
+ source = linux-headers-6.1.8-x64v1-xanmod1_6.1.8-x64v1-xanmod1-0~20230124.3dcd53f_amd64.deb::https://sourceforge.net/projects/xanmod/files/releases/main/6.1.8-x64v1-xanmod1/linux-headers-6.1.8-x64v1-xanmod1_6.1.8-x64v1-xanmod1-0~20230124.3dcd53f_amd64.deb/download
validpgpkeys = ABAF11C65A2970B130ABE3C479BE3E4300411886
validpgpkeys = 647F28654894E3BD457199BE38DBBDC86092693E
sha256sums = bf1d556e6f62c5ddc88f11cdf41af737cff65f0b1e70490b8f410db6f2f18709
diff --git a/PKGBUILD b/PKGBUILD
index c18dbd11445d..4c0b2a2b4d0c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -16,15 +16,11 @@ license=(GPL2)
options=('!strip')
makedepends=('jq' 'curl')
-# Resolve URL of sources
-_url_image=$(curl -L -s https://api.github.com/repos/xanmod/linux/releases/tags/${pkgver}-xanmod${xanmod} | jq --arg PKGVER "${pkgver}" --arg XANMOD "${xanmod}" --arg ARCH "${_arch}" -r '.assets[] | select(.name | contains("linux-image-" + $PKGVER + "-" + $ARCH + "-xanmod" + $XANMOD)).browser_download_url')
-_url_headers=$(curl -L -s https://api.github.com/repos/xanmod/linux/releases/tags/${pkgver}-xanmod${xanmod} | jq --arg PKGVER "${pkgver}" --arg XANMOD "${xanmod}" --arg ARCH "${_arch}" -r '.assets[] | select(.name | contains("linux-headers-" + $PKGVER + "-" + $ARCH + "-xanmod" + $XANMOD)).browser_download_url')
-source=("${_url_image}" "${_url_headers}")
-
-# Save files we will extract later manually
-_file_image="${_url_image##*/}"
-_file_headers="${_url_headers##*/}"
-noextract=("${_file_image}" "${_file_headers}")
+# Resolve URL of sources from Sourceforge provider
+_image_files=($(curl -sL https://sourceforge.net/projects/xanmod/files/releases/main/${pkgver}-${_arch}-xanmod${xanmod}/ | grep net.sf.files | cut -d'=' -f2- | jq '.[].name' 2>/dev/null | grep "\.deb" | grep -v linux-libc-dev | cut -d'"' -f2))
+source=("${_image_files[0]}::https://sourceforge.net/projects/xanmod/files/releases/main/${pkgver}-${_arch}-xanmod${xanmod}/${_image_files[0]}/download"
+ "${_image_files[1]}::https://sourceforge.net/projects/xanmod/files/releases/main/${pkgver}-${_arch}-xanmod${xanmod}/${_image_files[1]}/download")
+noextract=("${_image_files[0]}" "${_image_files[1]}")
validpgpkeys=(
'ABAF11C65A2970B130ABE3C479BE3E4300411886' # Linux Torvalds
@@ -34,12 +30,11 @@ sha256sums=('bf1d556e6f62c5ddc88f11cdf41af737cff65f0b1e70490b8f410db6f2f18709'
'91bd7f4c944f059072f8c2611836376dd1075bf79918e85cd7c4422f739e1d63')
prepare() {
- bsdtar -xf ${_file_image} data.tar.xz
- bsdtar -xf data.tar.xz
- rm -f data.tar.xz
- bsdtar -xf ${_file_headers} data.tar.xz
- bsdtar -xf data.tar.xz
- rm -f data.tar.xz
+ for _f in ${_image_files[@]} ; do
+ bsdtar -xf ${_f} data.tar.xz
+ bsdtar -xf data.tar.xz
+ rm -f data.tar.xz
+ done
}
_package() {