summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoan Figueras2022-12-12 18:30:58 +0100
committerJoan Figueras2022-12-12 18:30:58 +0100
commiteba3b836a05bc270a25d8ce7a49aa7faaec5a27b (patch)
tree3759f268cc3428da4415b61503a2751a6ab4e23f
parentd77424bbcb51ff01d40a0810ca56c1ce9f89c0db (diff)
downloadaur-eba3b836a05bc270a25d8ce7a49aa7faaec5a27b.tar.gz
6.0.12-x64v1
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD64
2 files changed, 56 insertions, 31 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 447200f0c99a..bcb0359c8461 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,25 +1,22 @@
-pkgbase = linux-xanmod-linux-bin-x64v1
+pkgbase = linux-xanmod
pkgdesc = The Linux kernel and modules with Xanmod patches - Current Stable (MAIN) - Prebuilt version - x64v1
- pkgver = 6.0.11
+ pkgver = 6.0.12
pkgrel = 1
url = http://www.xanmod.org/
arch = x86_64
license = GPL2
makedepends = jq
makedepends = curl
- depends = coreutils
- depends = kmod
- depends = initramfs
- optdepends = crda: to set the correct wireless channels of your country
- optdepends = linux-firmware: firmware images needed for some devices
- provides = VIRTUALBOX-GUEST-MODULES
- provides = WIREGUARD-MODULE
- provides = KSMBD-MODULE
- provides = NTFS3-MODULE
+ noextract = linux-image-6.0.12-x64v1-xanmod1_6.0.12-x64v1-xanmod1-0.20221208.ff9eceb_amd64.deb
+ noextract = linux-headers-6.0.12-x64v1-xanmod1_6.0.12-x64v1-xanmod1-0.20221208.ff9eceb_amd64.deb
options = !strip
- source = https://github.com/xanmod/linux/releases/download/6.0.11-xanmod1/linux-image-6.0.11-x64v1-xanmod1_6.0.11-x64v1-xanmod1-0.20221202.bfbe1c1_amd64.deb
+ source = https://github.com/xanmod/linux/releases/download/6.0.12-xanmod1/linux-image-6.0.12-x64v1-xanmod1_6.0.12-x64v1-xanmod1-0.20221208.ff9eceb_amd64.deb
+ source = https://github.com/xanmod/linux/releases/download/6.0.12-xanmod1/linux-headers-6.0.12-x64v1-xanmod1_6.0.12-x64v1-xanmod1-0.20221208.ff9eceb_amd64.deb
validpgpkeys = ABAF11C65A2970B130ABE3C479BE3E4300411886
validpgpkeys = 647F28654894E3BD457199BE38DBBDC86092693E
- sha256sums = 71ae2cb23d48979368325efdc23ee956addcf9d09ce5fd929e1b8e76b9239de2
+ sha256sums = f1eb4299d7c5e65c2e944dfbe037325370e6dd1afd0fea52486e11224579323a
+ sha256sums = 29e4b7d077b0ac0f50c93a8b15db6e7c5a13d9bc75ce52b56936fbca8683976c
pkgname = linux-xanmod-linux-bin-x64v1
+
+pkgname = linux-xanmod-linux-headers-bin-x64v1
diff --git a/PKGBUILD b/PKGBUILD
index 89b333551966..39c8cda9ccec 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,48 +3,64 @@
# Contributor: Jan Alexander Steffens (heftig) <jan.steffens@gmail.com>
_arch=x64v1
-pkgbase=linux-xanmod-linux-bin-${_arch}
-pkgname=linux-xanmod-linux-bin-${_arch}
+pkgbase=linux-xanmod
_major=6.0
-pkgver=${_major}.11
+pkgver=${_major}.12
xanmod=1
pkgrel=${xanmod}
pkgdesc="The Linux kernel and modules with Xanmod patches - Current Stable (MAIN) - Prebuilt version - ${_arch}"
url="http://www.xanmod.org/"
arch=(x86_64)
-
license=(GPL2)
options=('!strip')
-depends=(coreutils kmod initramfs)
-optdepends=('crda: to set the correct wireless channels of your country'
- 'linux-firmware: firmware images needed for some devices')
makedepends=('jq' 'curl')
-provides=(VIRTUALBOX-GUEST-MODULES
- WIREGUARD-MODULE
- KSMBD-MODULE
- NTFS3-MODULE)
-_url=$(curl -L -s https://api.github.com/repos/xanmod/linux/releases/tags/${pkgver}-xanmod${xanmod} | jq --arg PKGVER "${pkgver}" --arg XANMOD "${xanmod}" --arg ARCH "${_arch}" -r '.assets[] | select(.name | contains("linux-image-" + $PKGVER + "-" + $ARCH + "-xanmod" + $XANMOD)).browser_download_url')
-source=("${_url}")
+
+# Resolve URL of sources
+_url_image=$(curl -L -s https://api.github.com/repos/xanmod/linux/releases/tags/${pkgver}-xanmod${xanmod} | jq --arg PKGVER "${pkgver}" --arg XANMOD "${xanmod}" --arg ARCH "${_arch}" -r '.assets[] | select(.name | contains("linux-image-" + $PKGVER + "-" + $ARCH + "-xanmod" + $XANMOD)).browser_download_url')
+_url_headers=$(curl -L -s https://api.github.com/repos/xanmod/linux/releases/tags/${pkgver}-xanmod${xanmod} | jq --arg PKGVER "${pkgver}" --arg XANMOD "${xanmod}" --arg ARCH "${_arch}" -r '.assets[] | select(.name | contains("linux-headers-" + $PKGVER + "-" + $ARCH + "-xanmod" + $XANMOD)).browser_download_url')
+source=("${_url_image}" "${_url_headers}")
+
+# Save files we will extract later manually
+_file_image="${_url_image##*/}"
+_file_headers="${_url_headers##*/}"
+noextract=("${_file_image}" "${_file_headers}")
+
validpgpkeys=(
'ABAF11C65A2970B130ABE3C479BE3E4300411886' # Linux Torvalds
'647F28654894E3BD457199BE38DBBDC86092693E' # Greg Kroah-Hartman
)
-
-sha256sums=('71ae2cb23d48979368325efdc23ee956addcf9d09ce5fd929e1b8e76b9239de2')
+sha256sums=('f1eb4299d7c5e65c2e944dfbe037325370e6dd1afd0fea52486e11224579323a'
+ '29e4b7d077b0ac0f50c93a8b15db6e7c5a13d9bc75ce52b56936fbca8683976c')
prepare() {
+ bsdtar -xf ${_file_image} data.tar.xz
bsdtar -xf data.tar.xz
+ rm -f data.tar.xz
+ bsdtar -xf ${_file_headers} data.tar.xz
+ bsdtar -xf data.tar.xz
+ rm -f data.tar.xz
}
-package() {
+_package() {
+ pkgdesc="The Linux kernel and modules with Xanmod patches - Current Stable (MAIN) - Prebuilt version - ${_arch}"
+ depends=(coreutils kmod initramfs)
+ optdepends=('crda: to set the correct wireless channels of your country'
+ 'linux-firmware: firmware images needed for some devices')
+ provides=(VIRTUALBOX-GUEST-MODULES
+ WIREGUARD-MODULE
+ KSMBD-MODULE
+ NTFS3-MODULE)
local kernver="${pkgver}-${_arch}-xanmod${xanmod}"
- local modulesdir="$pkgdir/usr/lib/modules/${kernver}"
- mkdir -p "${modulesdir}"
+ local modulesdir="${pkgdir}/usr/lib/modules/${kernver}"
+ mkdir -p "${modulesdir}" "${pkgdir}/usr/share/doc"
msg2 "Installing modules..."
cp -r lib/modules/${kernver}/* "${modulesdir}/"
+ # Docs
+ cp -r usr/share/doc/linux-image-* "${pkgdir}/usr/share/doc/"
+
msg2 "Installing boot image..."
# systemd expects to find the kernel here to allow hibernation
# https://github.com/systemd/systemd/commit/edda44605f06a41fb86b7ab8128dcf99161d2344
@@ -52,7 +68,19 @@ package() {
# Used by mkinitcpio to name the kernel
echo "${pkgname}" | install -Dm644 /dev/stdin "$modulesdir/pkgbase"
+}
+_package-headers() {
+ pkgdesc="Headers and scripts for building modules for the Linux Xanmod - Current Stable (MAIN) - Prebuilt version - ${_arch}"
+ depends=(pahole)
+
+ mkdir -p "${pkgdir}"/usr/share/doc
+ cp -r usr/share/doc/linux-headers-* "${pkgdir}/usr/share/doc/"
+ cp -r usr/src "${pkgdir}/usr/"
}
+pkgname=("${pkgbase}-linux-bin-${_arch}" "${pkgbase}-linux-headers-bin-${_arch}")
+eval "package_${pkgname[0]}() { _package \"\$@\"; }"
+eval "package_${pkgname[1]}() { _package-headers \"\$@\"; }"
+
# vim:set ts=8 sts=2 sw=2 et: