summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSoftExpert2023-08-12 12:01:49 +0200
committerSoftExpert2023-08-12 12:01:49 +0200
commit782aced6338e6f7067735ef42b69dca4c18d801a (patch)
tree45aec8c639da59ff378b9898b958239be1bc31ae
parentead316589ac5017ec2f015c59793763fcb055cb5 (diff)
downloadaur-782aced6338e6f7067735ef42b69dca4c18d801a.tar.gz
6.4.10-xanmod1
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD26
2 files changed, 27 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c7ff449f624b..e9c8cdc40753 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,21 +1,21 @@
pkgbase = linux-xanmod-linux-bin-x64v2
pkgdesc = The Linux kernel and modules with Xanmod patches - Current Stable (MAIN) - Prebuilt version - x64v2
- pkgver = 6.4.8
+ pkgver = 6.4.10
pkgrel = 1
url = http://www.xanmod.org/
arch = x86_64
license = GPL2
makedepends = jq
makedepends = curl
- noextract = https://github.com/xanmod/linux/releases/download/6.4.8-xanmod1/linux-image-6.4.8-x64v2-xanmod1_6.4.8-x64v2-xanmod1-0.20230804.g731bac0_amd64.deb
- noextract = https://github.com/xanmod/linux/releases/download/6.4.8-xanmod1/linux-headers-6.4.8-x64v2-xanmod1_6.4.8-x64v2-xanmod1-0.20230804.g731bac0_amd64.deb
+ noextract = https://sourceforge.net/projects/xanmod/files/releases/main/6.4.10-xanmod1/6.4.10-x64v2-xanmod1/linux-image-6.4.10-x64v2-xanmod1_6.4.10-x64v2-xanmod1-0~20230811.g489fabdc_amd64.deb
+ noextract = https://sourceforge.net/projects/xanmod/files/releases/main/6.4.10-xanmod1/6.4.10-x64v2-xanmod1/linux-headers-6.4.10-x64v2-xanmod1_6.4.10-x64v2-xanmod1-0~20230811.g489fabdc_amd64.deb
options = !strip
- source = https://github.com/xanmod/linux/releases/download/6.4.8-xanmod1/linux-image-6.4.8-x64v2-xanmod1_6.4.8-x64v2-xanmod1-0.20230804.g731bac0_amd64.deb
- source = https://github.com/xanmod/linux/releases/download/6.4.8-xanmod1/linux-headers-6.4.8-x64v2-xanmod1_6.4.8-x64v2-xanmod1-0.20230804.g731bac0_amd64.deb
+ source = https://sourceforge.net/projects/xanmod/files/releases/main/6.4.10-xanmod1/6.4.10-x64v2-xanmod1/linux-image-6.4.10-x64v2-xanmod1_6.4.10-x64v2-xanmod1-0~20230811.g489fabdc_amd64.deb
+ source = https://sourceforge.net/projects/xanmod/files/releases/main/6.4.10-xanmod1/6.4.10-x64v2-xanmod1/linux-headers-6.4.10-x64v2-xanmod1_6.4.10-x64v2-xanmod1-0~20230811.g489fabdc_amd64.deb
validpgpkeys = ABAF11C65A2970B130ABE3C479BE3E4300411886
validpgpkeys = 647F28654894E3BD457199BE38DBBDC86092693E
- sha256sums = fe93d0254eeea6fc8f4955f8c4ecbdf3baeed7dd848380993ada2994c38da4fb
- sha256sums = fffe46577b852bed79c4542c86308ec1a6021689f0af32868a0394042e73357c
+ sha256sums = 77cb97cafcb1356aec93d6c90cd51bb32c14925aab3a6e376a1ec34a60f27392
+ sha256sums = a2657ddf0793fcdfe0fdb676094fd78e0ad783fffa0108aadf11c574f2b6253f
pkgname = linux-xanmod-linux-bin-x64v2
diff --git a/PKGBUILD b/PKGBUILD
index 1764118ab8f9..30fbfa525c76 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@
_arch=x64v2
_pkgbase=linux-xanmod
_major=6.4
-_minor=8
+_minor=10
_branch=6.x
_xanmodrel=1
_xanmodrev=
@@ -22,16 +22,30 @@ license=(GPL2)
options=('!strip')
makedepends=('jq' 'curl')
+# Resolve URL of sources from SourceForge provider and cache the response of the API to reduce the number of calls made
+_xml_data=$(curl -L -s "https://sourceforge.net/projects/xanmod/rss?path=/releases/main")
+
+# retrieve the headers URL and remove the "/download" suffix
+_t=$(echo "${_xml_data}" | xmllint --debug --xpath "string(//*[local-name()='content'][@type='application/x-debian-package; charset=binary' and contains(@url, '"${_arch}"') and contains(@url, 'linux-headers') and contains(@url, '"${pkgver}"')]/@url)" -)
+_url_headers="${_t//'/download'}"
+
+# retrieve the image URL and remove the "/download" suffix
+_t=$(echo "${_xml_data}" | xmllint --debug --xpath "string(//*[local-name()='content'][@type='application/x-debian-package; charset=binary' and contains(@url, '"${_arch}"') and contains(@url, 'linux-image') and not(contains(@url, '-dbg_')) and contains(@url, '"${pkgver}"')]/@url)" -)
+_url_image="${_t//'/download'}"
+
# Resolve URL of sources from GiHub provider
# cache the response of the API to reduce the number of calls made to GitHub; not authenticated calls are limited to 60 per hour
-_json_data=$(curl -L -s https://api.github.com/repos/xanmod/linux/releases/tags/${pkgver}-xanmod${_xanmodrel}${_xanmodrev})
-_url_image=$(echo "${_json_data}" | jq --arg PKGVER "${pkgver}" --arg PKGREL "${_xanmodrel}" --arg ARCH "${_arch}" -r '.assets[] | select(.name | startswith("linux-image-" + $PKGVER + "-" + $ARCH + "-xanmod" + $PKGREL) and endswith(".deb")).browser_download_url')
-_url_headers=$(echo "${_json_data}" | jq --arg PKGVER "${pkgver}" --arg PKGREL "${_xanmodrel}" --arg ARCH "${_arch}" -r '.assets[] | select(.name | startswith("linux-headers-" + $PKGVER + "-" + $ARCH + "-xanmod" + $PKGREL) and endswith(".deb")).browser_download_url')
+#_json_data=$(curl -L -s https://api.github.com/repos/xanmod/linux/releases/tags/${pkgver}-xanmod${_xanmodrel}${_xanmodrev})
+#_url_image=$(echo "${_json_data}" | jq --arg PKGVER "${pkgver}" --arg PKGREL "${_xanmodrel}" --arg ARCH "${_arch}" -r '.assets[] | select(.name | startswith("linux-image-" + $PKGVER + "-" + $ARCH + "-xanmod" + $PKGREL) and endswith(".deb")).browser_download_url')
+#_url_headers=$(echo "${_json_data}" | jq --arg PKGVER "${pkgver}" --arg PKGREL "${_xanmodrel}" --arg ARCH "${_arch}" -r '.assets[] | select(.name | startswith("linux-headers-" + $PKGVER + "-" + $ARCH + "-xanmod" + $PKGREL) and endswith(".deb")).browser_download_url')
+
source=("${_url_image}" "${_url_headers}")
noextract=("${_url_image}" "${_url_headers}")
+
# Save files we will extract later manually
_file_image="${_url_image##*/}"
_file_headers="${_url_headers##*/}"
+
prepare() {
bsdtar -xf ${_file_image} data.tar.xz
bsdtar -xf data.tar.xz
@@ -45,8 +59,8 @@ validpgpkeys=(
'ABAF11C65A2970B130ABE3C479BE3E4300411886' # Linux Torvalds
'647F28654894E3BD457199BE38DBBDC86092693E' # Greg Kroah-Hartman
)
-sha256sums=('fe93d0254eeea6fc8f4955f8c4ecbdf3baeed7dd848380993ada2994c38da4fb'
- 'fffe46577b852bed79c4542c86308ec1a6021689f0af32868a0394042e73357c')
+sha256sums=('77cb97cafcb1356aec93d6c90cd51bb32c14925aab3a6e376a1ec34a60f27392'
+ 'a2657ddf0793fcdfe0fdb676094fd78e0ad783fffa0108aadf11c574f2b6253f')
_package() {
pkgdesc="The Linux kernel and modules with Xanmod patches - Current Stable (MAIN) - Prebuilt version - ${_arch}"