summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSoftExpert2023-08-12 12:08:59 +0200
committerSoftExpert2023-08-12 12:08:59 +0200
commit205624e5877ae30645882347b18fbbe150c33868 (patch)
treeb3082a93c4ab03356e513317059627b0600e5a8e
parent2f9a6ddabdeba98e635f83eadbd8fe48b2bacbca (diff)
downloadaur-205624e5877ae30645882347b18fbbe150c33868.tar.gz
6.4.10-xanmod1
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD26
2 files changed, 27 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 432b84c2cc30..042254a12c76 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,21 +1,21 @@
pkgbase = linux-xanmod-linux-bin-x64v3
pkgdesc = The Linux kernel and modules with Xanmod patches - Current Stable (MAIN) - Prebuilt version - x64v3
- pkgver = 6.4.8
+ pkgver = 6.4.10
pkgrel = 1
url = http://www.xanmod.org/
arch = x86_64
license = GPL2
makedepends = jq
makedepends = curl
- noextract = https://github.com/xanmod/linux/releases/download/6.4.8-xanmod1/linux-image-6.4.8-x64v3-xanmod1_6.4.8-x64v3-xanmod1-0.20230804.g731bac0_amd64.deb
- noextract = https://github.com/xanmod/linux/releases/download/6.4.8-xanmod1/linux-headers-6.4.8-x64v3-xanmod1_6.4.8-x64v3-xanmod1-0.20230804.g731bac0_amd64.deb
+ noextract = https://sourceforge.net/projects/xanmod/files/releases/main/6.4.10-xanmod1/6.4.10-x64v3-xanmod1/linux-image-6.4.10-x64v3-xanmod1_6.4.10-x64v3-xanmod1-0~20230811.g489fabdc_amd64.deb
+ noextract = https://sourceforge.net/projects/xanmod/files/releases/main/6.4.10-xanmod1/6.4.10-x64v3-xanmod1/linux-headers-6.4.10-x64v3-xanmod1_6.4.10-x64v3-xanmod1-0~20230811.g489fabdc_amd64.deb
options = !strip
- source = https://github.com/xanmod/linux/releases/download/6.4.8-xanmod1/linux-image-6.4.8-x64v3-xanmod1_6.4.8-x64v3-xanmod1-0.20230804.g731bac0_amd64.deb
- source = https://github.com/xanmod/linux/releases/download/6.4.8-xanmod1/linux-headers-6.4.8-x64v3-xanmod1_6.4.8-x64v3-xanmod1-0.20230804.g731bac0_amd64.deb
+ source = https://sourceforge.net/projects/xanmod/files/releases/main/6.4.10-xanmod1/6.4.10-x64v3-xanmod1/linux-image-6.4.10-x64v3-xanmod1_6.4.10-x64v3-xanmod1-0~20230811.g489fabdc_amd64.deb
+ source = https://sourceforge.net/projects/xanmod/files/releases/main/6.4.10-xanmod1/6.4.10-x64v3-xanmod1/linux-headers-6.4.10-x64v3-xanmod1_6.4.10-x64v3-xanmod1-0~20230811.g489fabdc_amd64.deb
validpgpkeys = ABAF11C65A2970B130ABE3C479BE3E4300411886
validpgpkeys = 647F28654894E3BD457199BE38DBBDC86092693E
- sha256sums = 9ffc738c6c92efed3f163d5b3f4ece0728f253aa8574f98e1bddd4dd254d419a
- sha256sums = ce1ea5abdd9d2fa215f400b3a0295204f910333b8fb9d335bfcb1c0cca284d1f
+ sha256sums = 6f10c815e0746bfb65af2bd66c6d430500c45f5049f9cfec0c11ef0beeb9268c
+ sha256sums = 4d39104a5be9f41d007c2a58241a149fdcff9fe737c490857cf6ebe0d15138cc
pkgname = linux-xanmod-linux-bin-x64v3
diff --git a/PKGBUILD b/PKGBUILD
index 892476d9943e..0bac044bebb5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@
_arch=x64v3
_pkgbase=linux-xanmod
_major=6.4
-_minor=8
+_minor=10
_branch=6.x
_xanmodrel=1
_xanmodrev=
@@ -22,16 +22,30 @@ license=(GPL2)
options=('!strip')
makedepends=('jq' 'curl')
+# Resolve URL of sources from SourceForge provider and cache the response of the API to reduce the number of calls made
+_xml_data=$(curl -L -s "https://sourceforge.net/projects/xanmod/rss?path=/releases/main")
+
+# retrieve the headers URL and remove the "/download" suffix
+_t=$(echo "${_xml_data}" | xmllint --debug --xpath "string(//*[local-name()='content'][@type='application/x-debian-package; charset=binary' and contains(@url, '"${_arch}"') and contains(@url, 'linux-headers') and contains(@url, '"${pkgver}"')]/@url)" -)
+_url_headers="${_t//'/download'}"
+
+# retrieve the image URL and remove the "/download" suffix
+_t=$(echo "${_xml_data}" | xmllint --debug --xpath "string(//*[local-name()='content'][@type='application/x-debian-package; charset=binary' and contains(@url, '"${_arch}"') and contains(@url, 'linux-image') and not(contains(@url, '-dbg_')) and contains(@url, '"${pkgver}"')]/@url)" -)
+_url_image="${_t//'/download'}"
+
# Resolve URL of sources from GiHub provider
# cache the response of the API to reduce the number of calls made to GitHub; not authenticated calls are limited to 60 per hour
-_json_data=$(curl -L -s https://api.github.com/repos/xanmod/linux/releases/tags/${pkgver}-xanmod${_xanmodrel}${_xanmodrev})
-_url_image=$(echo "${_json_data}" | jq --arg PKGVER "${pkgver}" --arg PKGREL "${_xanmodrel}" --arg ARCH "${_arch}" -r '.assets[] | select(.name | startswith("linux-image-" + $PKGVER + "-" + $ARCH + "-xanmod" + $PKGREL) and endswith(".deb")).browser_download_url')
-_url_headers=$(echo "${_json_data}" | jq --arg PKGVER "${pkgver}" --arg PKGREL "${_xanmodrel}" --arg ARCH "${_arch}" -r '.assets[] | select(.name | startswith("linux-headers-" + $PKGVER + "-" + $ARCH + "-xanmod" + $PKGREL) and endswith(".deb")).browser_download_url')
+#_json_data=$(curl -L -s https://api.github.com/repos/xanmod/linux/releases/tags/${pkgver}-xanmod${_xanmodrel}${_xanmodrev})
+#_url_image=$(echo "${_json_data}" | jq --arg PKGVER "${pkgver}" --arg PKGREL "${_xanmodrel}" --arg ARCH "${_arch}" -r '.assets[] | select(.name | startswith("linux-image-" + $PKGVER + "-" + $ARCH + "-xanmod" + $PKGREL) and endswith(".deb")).browser_download_url')
+#_url_headers=$(echo "${_json_data}" | jq --arg PKGVER "${pkgver}" --arg PKGREL "${_xanmodrel}" --arg ARCH "${_arch}" -r '.assets[] | select(.name | startswith("linux-headers-" + $PKGVER + "-" + $ARCH + "-xanmod" + $PKGREL) and endswith(".deb")).browser_download_url')
+
source=("${_url_image}" "${_url_headers}")
noextract=("${_url_image}" "${_url_headers}")
+
# Save files we will extract later manually
_file_image="${_url_image##*/}"
_file_headers="${_url_headers##*/}"
+
prepare() {
bsdtar -xf ${_file_image} data.tar.xz
bsdtar -xf data.tar.xz
@@ -45,8 +59,8 @@ validpgpkeys=(
'ABAF11C65A2970B130ABE3C479BE3E4300411886' # Linux Torvalds
'647F28654894E3BD457199BE38DBBDC86092693E' # Greg Kroah-Hartman
)
-sha256sums=('9ffc738c6c92efed3f163d5b3f4ece0728f253aa8574f98e1bddd4dd254d419a'
- 'ce1ea5abdd9d2fa215f400b3a0295204f910333b8fb9d335bfcb1c0cca284d1f')
+sha256sums=('6f10c815e0746bfb65af2bd66c6d430500c45f5049f9cfec0c11ef0beeb9268c'
+ '4d39104a5be9f41d007c2a58241a149fdcff9fe737c490857cf6ebe0d15138cc')
_package() {
pkgdesc="The Linux kernel and modules with Xanmod patches - Current Stable (MAIN) - Prebuilt version - ${_arch}"