summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoan Figueras2024-01-24 01:16:54 +0100
committerJoan Figueras2024-01-24 01:16:54 +0100
commit20cd1e62b784652f2cc82b28687879264c85e14c (patch)
treef49735503a3cc3679a520d50f600bd45d7ba8c89
parent629c3a14dc75f4af7503bb0b1bc61452cdd3036c (diff)
downloadaur-20cd1e62b784652f2cc82b28687879264c85e14c.tar.gz
Fixed dkms upgrade
-rw-r--r--PKGBUILD11
1 files changed, 7 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 28da612141b7..0893c5879cd0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -101,17 +101,20 @@ _package() {
# add real version for building modules and running depmod from hook
echo "${kernver}" | install -Dm644 /dev/stdin "${pkgdir}/usr/lib/modules/${_extramodules}/version"
- # now we call depmod...
- # depmod -b "${pkgdir}/usr" -F "${srcdir}/boot/System.map-${kernver}"
+ # Remove builddir because is a symbolic link and it belongs to headers
+ rm -f "${modulesdir}/build"
}
_package-headers() {
pkgdesc="Headers and scripts for building modules for the Linux Xanmod - Current Stable (MAIN) - Prebuilt version - ${_arch}"
depends=(pahole)
- mkdir -p "${pkgdir}"/usr/share/doc
+ local kernver="${pkgver}-${_arch}-xanmod${_xanmodrel}"
+ local builddir="${pkgdir}/usr/lib/modules/${kernver}/build"
+ mkdir -p "${pkgdir}"/usr/share/doc "${pkgdir}"/usr/src "${pkgdir}/usr/lib/modules/${kernver}"
cp -r usr/share/doc/linux-headers-* "${pkgdir}/usr/share/doc/"
- cp -r usr/src "${pkgdir}/usr/"
+ cp -r usr/src/linux-headers-${kernver} "${builddir}"
+ ln -sr "$builddir" "$pkgdir/usr/src/$pkgbase"
}
eval "package_${pkgname[0]}() { _package \"\$@\"; }"