summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoan Figueras2024-02-18 22:47:04 +0100
committerJoan Figueras2024-02-18 22:47:04 +0100
commit143e5062db72159e0155f8f3f33f168f1776704f (patch)
tree81cda762e9936468144c4d2626f28a86d42e667a
parent0c1acf578f04a6281340ad8705a756b1bae19057 (diff)
downloadaur-143e5062db72159e0155f8f3f33f168f1776704f.tar.gz
Pushed the right PKGBUILD
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD65
2 files changed, 53 insertions, 30 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b3c28875a841..9c7bb551792f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,17 @@
pkgbase = linux-xanmod-lts
- pkgdesc = Linux Xanmod LTS
+ pkgdesc = Linux Xanmod - Long Term Support [LTS]
pkgver = 6.6.17
- pkgrel = 1
+ pkgrel = 2
url = http://www.xanmod.org/
arch = x86_64
license = GPL2
makedepends = bc
makedepends = cpio
- makedepends = kmod
+ makedepends = gettext
makedepends = libelf
+ makedepends = pahole
makedepends = perl
+ makedepends = python
makedepends = tar
makedepends = xz
options = !strip
@@ -27,15 +29,17 @@ pkgbase = linux-xanmod-lts
pkgname = linux-xanmod-lts
pkgdesc = The Linux kernel and modules with Xanmod patches
depends = coreutils
- depends = kmod
depends = initramfs
- optdepends = crda: to set the correct wireless channels of your country
+ depends = kmod
+ optdepends = wireless-regdb: to set the correct wireless channels of your country
optdepends = linux-firmware: firmware images needed for some devices
+ provides = KSMBD-MODULE
provides = VIRTUALBOX-GUEST-MODULES
provides = WIREGUARD-MODULE
- provides = KSMBD-MODULE
provides = NTFS3-MODULE
+ replaces = virtualbox-guest-modules-arch
+ replaces = wireguard-arch
pkgname = linux-xanmod-lts-headers
- pkgdesc = Headers and scripts for building modules for the Linux Xanmod LTS kernel
+ pkgdesc = Headers and scripts for building modules for the Linux Xanmod - Long Term Support [LTS] kernel
depends = pahole
diff --git a/PKGBUILD b/PKGBUILD
index 7c837dd357bb..aad5700882d7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Joan Figueras <ffigue at gmail dot com>
# Contributor: Torge Matthies <openglfreak at googlemail dot com>
-# Contributor: Jan Alexander Steffens (heftig) <jan.steffens@gmail.com>
+# Contributor: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
##
## The following variables can be customized at build time. Use env or export to change at your wish
@@ -25,7 +25,7 @@ fi
## Since upstream disabled CONFIG_STACK_TRACER (limits debugging and analyzing of the kernel)
## you can enable them setting this option. Caution, because they have an impact in performance.
-## Stock Archlinux has this enabled.
+## Stock Archlinux has this enabled.
## Set variable "use_tracers" to: n to disable (possibly increase performance, XanMod default)
## y to enable (Archlinux default)
if [ -z ${use_tracers+x} ]; then
@@ -76,17 +76,26 @@ _major=6.6
pkgver=${_major}.17
_branch=6.x
xanmod=1
-pkgrel=${xanmod}
-pkgdesc='Linux Xanmod LTS'
+_revision=
+pkgrel=2
+pkgdesc='Linux Xanmod - Long Term Support [LTS]'
url="http://www.xanmod.org/"
arch=(x86_64)
license=(GPL2)
makedepends=(
- bc cpio kmod libelf perl tar xz
+ bc
+ cpio
+ gettext
+ libelf
+ pahole
+ perl
+ python
+ tar
+ xz
)
if [ "${_compiler}" = "clang" ]; then
- makedepends+=(clang llvm lld python)
+ makedepends+=(clang llvm lld)
fi
options=('!strip')
_srcname="linux-${pkgver}-xanmod${xanmod}"
@@ -103,7 +112,6 @@ validpgpkeys=(
_commit="ec9e9a4219fe221dec93fa16fddbe44a34933d8d"
_patches=()
for _patch in ${_patches[@]}; do
- #source+=("${_patch}::https://git.archlinux.org/svntogit/packages.git/plain/trunk/${_patch}?h=packages/linux&id=${_commit}")
source+=("${_patch}::https://raw.githubusercontent.com/archlinux/svntogit-packages/${_commit}/trunk/${_patch}")
done
@@ -120,10 +128,9 @@ prepare() {
cd linux-${_major}
# Apply Xanmod patch
- patch -Np1 -i ../patch-${pkgver}-xanmod${xanmod}
+ patch -Np1 -i ../patch-${pkgver}-xanmod${xanmod}${_revision}
msg2 "Setting version..."
- scripts/setlocalversion --save-scmversion
echo "-$pkgrel" > localversion.10-pkgrel
echo "${pkgbase#linux-xanmod}" > localversion.20-pkgname
@@ -234,17 +241,28 @@ build() {
_package() {
pkgdesc="The Linux kernel and modules with Xanmod patches"
- depends=(coreutils kmod initramfs)
- optdepends=('crda: to set the correct wireless channels of your country'
- 'linux-firmware: firmware images needed for some devices')
- provides=(VIRTUALBOX-GUEST-MODULES
- WIREGUARD-MODULE
- KSMBD-MODULE
- NTFS3-MODULE)
+ depends=(
+ coreutils
+ initramfs
+ kmod
+ )
+ optdepends=(
+ 'wireless-regdb: to set the correct wireless channels of your country'
+ 'linux-firmware: firmware images needed for some devices'
+ )
+ provides=(
+ KSMBD-MODULE
+ VIRTUALBOX-GUEST-MODULES
+ WIREGUARD-MODULE
+ NTFS3-MODULE
+ )
+ replaces=(
+ virtualbox-guest-modules-arch
+ wireguard-arch
+ )
cd linux-${_major}
- local kernver="$(<version)"
- local modulesdir="$pkgdir/usr/lib/modules/$kernver"
+ local modulesdir="$pkgdir/usr/lib/modules/$(<version)"
msg2 "Installing boot image..."
# systemd expects to find the kernel here to allow hibernation
@@ -255,10 +273,11 @@ _package() {
echo "$pkgbase" | install -Dm644 /dev/stdin "$modulesdir/pkgbase"
msg2 "Installing modules..."
- make INSTALL_MOD_PATH="$pkgdir/usr" INSTALL_MOD_STRIP=1 modules_install
+ ZSTD_CLEVEL=19 make INSTALL_MOD_PATH="$pkgdir/usr" INSTALL_MOD_STRIP=1 \
+ DEPMOD=/doesnt/exist modules_install # Suppress depmod
- # remove build and source links
- rm "$modulesdir"/{source,build}
+ # remove build link
+ rm "$modulesdir"/build
}
_package-headers() {
@@ -323,7 +342,7 @@ _package-headers() {
msg2 "Stripping build tools..."
local file
while read -rd '' file; do
- case "$(file -bi "$file")" in
+ case "$(file -Sib "$file")" in
application/x-sharedlib\;*) # Libraries (.so)
strip -v $STRIP_SHARED "$file" ;;
application/x-archive\;*) # Libraries (.a)
@@ -337,7 +356,7 @@ _package-headers() {
msg2 "Stripping vmlinux..."
strip -v $STRIP_STATIC "$builddir/vmlinux"
-
+
msg2 "Adding symlink..."
mkdir -p "$pkgdir/usr/src"
ln -sr "$builddir" "$pkgdir/usr/src/$pkgbase"