aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorScott B2021-12-08 10:08:12 -0800
committerScott B2021-12-08 10:08:12 -0800
commit0092ac92017f657608ca949783feb6db6d3c084f (patch)
treed9461a4354bf2aae6e2a77bf6a82d43631c57dc0
parentaefa0dbdf7a756630e76bcb7b1733ae900c979b0 (diff)
downloadaur-0092ac92017f657608ca949783feb6db6d3c084f.tar.gz
pkgbuild: fix O3 toggle
-rw-r--r--PKGBUILD7
1 files changed, 4 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 37c89cb58c1e..f21b3fdf458b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,7 +10,8 @@
## The following variables can be customized at build time. Use env or export to change at your wish
##
-## Example: env _microarchitecture=98 use_numa=n use_tracers=n makepkg -sc
+## Eg: env _microarchitecture=98 use_numa=n use_tracers=n makepkg -sc
+## Or: makepkg -sc -- _microarchitecture=98 use_numa=n use_tracers=n
##
## Xanmod-ROG options:
@@ -24,9 +25,9 @@
## Set "no_makeflags_check" to anything to skip this.
: "${makeflags_check:=y}"
-## '_O3' - Enable -O3 optimization - this isn't generally worth much, especially in the face of
+## '_O3' - Enable -O3 optimization - this isn't generally worth much, especially in the face of
## -march=native (or -march=x86-64-v3) and clang ThinLTO; set _O3 to anything to enable
-: "${_O3:=y}"
+[[ -v _O3 ]] && _O3='y'
##
## Xanmod options: