aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorScott B2021-10-29 23:35:38 -0700
committerScott B2021-10-29 23:35:38 -0700
commit3436de225b168fce35fb4db4dacaceabc4fc3c12 (patch)
tree3879f949800544309004afd7e0dd54c0514c7e23
parent687eaefa17354d7a466d2bb39114e335a4aecbf6 (diff)
downloadaur-3436de225b168fce35fb4db4dacaceabc4fc3c12.tar.gz
pkgbuild: small cleanup, comments
-rw-r--r--PKGBUILD15
1 files changed, 7 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 36d3370172a2..2de285968540 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -271,6 +271,9 @@ prepare() {
--enable CONFIG_MODULE_COMPRESS_ZSTD
fi
+ # let user choose microarchitecture optimization target;
+ sh "${srcdir}/choose-gcc-optimization.sh" $_microarchitecture
+
# This is intended for the people that want to build this package with their own config
# Put the file "myconfig" at the package folder (this will take preference) or "${XDG_CONFIG_HOME}/linux-xanmod/myconfig"
# If we detect partial file with scripts/config commands, we execute as a script
@@ -306,22 +309,18 @@ prepare() {
make LLVM=$_LLVM LLVM_IAS=$_LLVM olddefconfig
- # let user choose microarchitecture optimization target;
- # NOTE: this script must run *after* make olddefconfig so any new uarch macros exist
- sh "${srcdir}/choose-gcc-optimization.sh" $_microarchitecture
-
## bake in s0ix debugging parameters
scripts/config --enable CONFIG_CMDLINE_BOOL \
--set-str CONFIG_CMDLINE "makepkgplaceholderyolo" \
--disable CMDLINE_OVERRIDE
## HACK: forcibly fixup CONFIG_CMDLINE as scripts/config mangles quote escapes
-
- # note the double escaped quotes here, sed strips one;
- # the final result in .config needs to look like CONFIG_CMDLINE="foo.dyndbg=\"+p\"" to avoid dyndbg parse errors at boot
-
sed -i 's#makepkgplaceholderyolo#pm_debug_messages amd_pmc.enable_stb=1 amd_pmc.dyndbg=\\"+p\\" acpi.dyndbg=\\"file drivers/acpi/x86/s2idle.c +p\\"#' .config
+# note the double escaped quotes above, sed strips one; the final result in .config needs to contain
+# single slash escaped quotes (eg: `CONFIG_CMDLINE="foo.dyndbg=\"+p\""`) to avoid dyndbg parse errors
+# at boot. this is impossible with the kernel config script.
+
make -s kernelrelease > version
msg2 "Prepared %s version %s" "$pkgbase" "$(<version)"