aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorScott B2022-02-14 05:42:45 -0800
committerScott B2022-02-14 05:45:06 -0800
commit62a2df5a7ff7b0290d14cf41d4f32d833824694b (patch)
treee13092aa7aeb5df3161093acb743394f239d49ae
parent02e4a6448036e9b933a165d4ae1f5fc8c9d6714a (diff)
downloadaur-62a2df5a7ff7b0290d14cf41d4f32d833824694b.tar.gz
patch: fix asus-wmi regression
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD2
-rw-r--r--platform-x86-asus-wmi-Fix-regression-when-probing-for-fan-curve-control.patch40
3 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f71037eda944..eca0cfc2166f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -38,6 +38,7 @@ pkgbase = linux-xanmod-rog
source = cfg80211-dont-WARN-if-a-self-managed-device.patch
source = HID-asus-Reduce-object-size-by-consolidating-calls.patch
source = v16-asus-wmi-Add-support-for-custom-fan-curves.patch
+ source = platform-x86-asus-wmi-Fix-regression-when-probing-for-fan-curve-control.patch
source = HID-asus-wmi-ROG-x13-flow-tablet-mode-support.patch
source = mt76-mt7921-enable-VO-tx-aggregation.patch
source = 1-2-Bluetooth-btusb-Add-Mediatek-MT7921-support-for-Foxconn.patch
@@ -71,6 +72,7 @@ pkgbase = linux-xanmod-rog
sha256sums = 3d8961438b5c8110588ff0b881d472fc71a4304d306808d78a4055a4150f351e
sha256sums = 544464bf0807b324120767d55867f03014a9fda4e1804768ca341be902d7ade4
sha256sums = 0c422d8f420c1518aab1b980c6cdb6e029a4fa9cde1fd99a63670bb105a44f36
+ sha256sums = fb8103239ac6fa53c9492b63d81cdab4ec0f7b5b1d7dfde362816be768a12a76
sha256sums = 38ec0dd8a20bae77b677eb65207c61aa4d668741d9b25aea9876d075365b26ef
sha256sums = 1ce9fd988201c4d2e48794c58acda5b768ec0fea1d29555e99d35cd2712281e4
sha256sums = 236cdadf0b1472945c0d7570caeed7b95929aabed6872319c9d0969a819689e9
diff --git a/PKGBUILD b/PKGBUILD
index 01c46f12ea51..94a9e43585dc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -156,6 +156,7 @@ source=("https://cdn.kernel.org/pub/linux/kernel/v${_branch}/linux-${_major}.tar
# 5.17: ASUS ROG laptop custom fan curve support
"v16-asus-wmi-Add-support-for-custom-fan-curves.patch"
+ "platform-x86-asus-wmi-Fix-regression-when-probing-for-fan-curve-control.patch"
# -- ASUS ROG Flow X13 tablet mode
"HID-asus-wmi-ROG-x13-flow-tablet-mode-support.patch"
@@ -199,6 +200,7 @@ sha256sums=('027d7e8988bb69ac12ee92406c3be1fe13f990b1ca2249e226225cd1573308bb'
'3d8961438b5c8110588ff0b881d472fc71a4304d306808d78a4055a4150f351e'
'544464bf0807b324120767d55867f03014a9fda4e1804768ca341be902d7ade4'
'0c422d8f420c1518aab1b980c6cdb6e029a4fa9cde1fd99a63670bb105a44f36'
+ 'fb8103239ac6fa53c9492b63d81cdab4ec0f7b5b1d7dfde362816be768a12a76'
'38ec0dd8a20bae77b677eb65207c61aa4d668741d9b25aea9876d075365b26ef'
'1ce9fd988201c4d2e48794c58acda5b768ec0fea1d29555e99d35cd2712281e4'
'236cdadf0b1472945c0d7570caeed7b95929aabed6872319c9d0969a819689e9'
diff --git a/platform-x86-asus-wmi-Fix-regression-when-probing-for-fan-curve-control.patch b/platform-x86-asus-wmi-Fix-regression-when-probing-for-fan-curve-control.patch
new file mode 100644
index 000000000000..762756b5918f
--- /dev/null
+++ b/platform-x86-asus-wmi-Fix-regression-when-probing-for-fan-curve-control.patch
@@ -0,0 +1,40 @@
+From: Hans de Goede <hdegoede@redhat.com>
+Subject: [PATCH] platform/x86: asus-wmi: Fix regression when probing for fan curve control
+Date: Sat, 5 Feb 2022 12:28:40 +0100
+Message-Id: <20220205112840.33095-1-hdegoede@redhat.com>
+List-ID: <platform-driver-x86.vger.kernel.org>
+
+The fan curve control patches introduced a regression for at least the
+TUF FX506 and possibly other TUF series laptops that do not have support
+for fan curve control.
+
+As part of the probing process, asus_wmi_evaluate_method_buf is called
+to get the factory default fan curve . The WMI management function
+returns 0 on certain laptops to indicate lack of fan curve control
+instead of ASUS_WMI_UNSUPPORTED_METHOD. This 0 is transformed to
+-ENODATA which results in failure when probing.
+
+Fixes: 0f0ac158d28f ("platform/x86: asus-wmi: Add support for custom fan curves")
+Reported-by: Abhijeet V <abhijeetviswa@gmail.com>
+Signed-off-by: Hans de Goede <hdegoede@redhat.com>
+---
+ drivers/platform/x86/asus-wmi.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/drivers/platform/x86/asus-wmi.c b/drivers/platform/x86/asus-wmi.c
+index a3b83b22a3b1..2104a2621e50 100644
+--- a/drivers/platform/x86/asus-wmi.c
++++ b/drivers/platform/x86/asus-wmi.c
+@@ -2223,7 +2223,7 @@ static int fan_curve_check_present(struct asus_wmi *asus, bool *available,
+
+ err = fan_curve_get_factory_default(asus, fan_dev);
+ if (err) {
+- if (err == -ENODEV)
++ if (err == -ENODEV || err == -ENODATA)
+ return 0;
+ return err;
+ }
+--
+2.33.1
+
+