aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorScott B2021-11-13 04:59:55 -0800
committerScott B2021-11-13 07:19:27 -0800
commita457f68b03cedf4722f75d43dd95e3b43916e38c (patch)
tree52d162da5d7c191265d6960ba3bc091c693d8c73
parent6961feda1fa117064267bb9122ad3abe4e1506be (diff)
downloadaur-a457f68b03cedf4722f75d43dd95e3b43916e38c.tar.gz
pkg: Update README for asusctl 4.0.0
-rw-r--r--README.md43
1 files changed, 31 insertions, 12 deletions
diff --git a/README.md b/README.md
index 5387a7e6fdc0..119b71267838 100644
--- a/README.md
+++ b/README.md
@@ -17,19 +17,30 @@ Package repo: https://gitlab.com/arglebargle-arch/xanmod-rog-PKGBUILD
to supply SmartTrace Buffer (STB) logs during a suspend failure, the script will gather them for you automatically
during every suspend. These STB logs can be found in /root/amd-stb-captures/.
- - Xanmod builds with the performance governor by default; this is great for performance but doesn't clock down easily
- and reduces battery life when used on mobile devices. Since this kernel package is primarily targeted at ROG
- laptop users I've switched the build config to default to the schedutil governor. I strongly suggest making a
- couple of bash aliases to make switching modes/governors easier, this allows you to easily boost performance or
- conserve battery power as needed.
+ - Upstream Xanmod builds with the `performance` governor set as the boot-time default; this is great for performance
+ but reduces battery life when used on laptops. Since this kernel package is primarily targeted at ROG laptop users
+ I've switched the build config to use `schedutil` instead. I strongly suggest making a couple of bash aliases to
+ make switching modes/governors easier, this wll allow you to easily boost performance or conserve battery power as
+ needed.
+
+ for asusctl >= 4.0.0:
+
+ * `alias goboost='(set -x; powerprofilesctl set performance; sudo cpupower frequency-set -g performance >&/dev/null;)'`
+ * `alias gonormal='(set -x; powerprofilesctl set balanced; sudo cpupower frequency-set -g schedutil >&/dev/null;)'`
+ * `alias gosilent='(set -x; powerprofilesctl set power-saver; sudo cpupower frequency-set -g schedutil >&/dev/null;)'`
+
+ for asusctl <= 3.7.2:
- * `alias gosilent='(set -x; asusctl profile silent -t false -f silent; sudo cpupower frequency-set -g schedutil >&/dev/null;)'`
- * `alias gonormal='(set -x; asusctl profile normal -t true -f normal; sudo cpupower frequency-set -g schedutil >&/dev/null;)'`
* `alias goboost='(set -x; asusctl profile boost -t true -f boost; sudo cpupower frequency-set -g performance >&/dev/null;)'`
+ * `alias gonormal='(set -x; asusctl profile normal -t true -f normal; sudo cpupower frequency-set -g schedutil >&/dev/null;)'`
+ * `alias gosilent='(set -x; asusctl profile silent -t false -f silent; sudo cpupower frequency-set -g schedutil >&/dev/null;)'`
* Eg: To switch performance profiles during a kernel build you'd run something like: `goboost; makepkg -Ccsr; gonormal`
+ You can use powerprofilesctl directly if you like but the aliases will alow you to switch governors as well as
+ profiles.
- - Use the included `myconfig` script fragment to make minor changes to the kernel configuration during build.
+ - You can place a script named `myconfig` in the package directory to make minor changes to the kernel configuration
+ during build. See the comments near the end of the prepare() section in the PKGBUILD.
- We now build for the `x86-64-v3` target by default; this supports Haswell era and newer CPUs and should be ~10%
more performant than a generic `x86_64` build while maintaining wide compatibility. This supports all recent ROG
@@ -41,11 +52,16 @@ Package repo: https://gitlab.com/arglebargle-arch/xanmod-rog-PKGBUILD
* `_microarchitecture=15 makepkg ...` Zen3 optimization; most AMD 5000 series CPUs, 2021 AMD ROG laptops
* `_microarchitecture=38 makepkg ...` Skylake optimization; Use this on [Comet Lake][1] machines
* `_microarchitecture=92 makepkg ...` x86-64-v2; compatible with most machines from 2008 onward
- * `_microarchitecture=93 makepkg ...` x86-64-v3; the PKGBUILD default, most machines from 2013/2014 onward are supported
+ * `_microarchitecture=93 makepkg ...` x86-64-v3; PKGBUILD default, most machines from 2013/2014 onward are supported
* `_microarchitecture=98 makepkg ...` Intel -march=native
* `_microarchitecture=99 makepkg ...` AMD -march=native
- - GA503Q models hava an ACPI DSDT table bug in all currently available BIOS that prevents the machine from suspending correctly.
+ - Building using Clang ThinLTO is well tested and stable but may not be compatible with some DKMS modules, and you'll
+ need to patch your `/usr/bin/dkms` script for it to work with LLVM/clang at all. See further discussion here:
+ https://github.com/dell/dkms/issues/124 if you're going to use this feature.
+
+ - GA503Q models hava an ACPI DSDT table bug in all currently available BIOS that prevents the machine from suspending
+ correctly.
Errors generated by this will look like the following in `dmesg` or the system journal:
```log
@@ -59,11 +75,14 @@ Package repo: https://gitlab.com/arglebargle-arch/xanmod-rog-PKGBUILD
Jun 19 18:56:26 arch-zephyrus kernel: nvme nvme0: Abort status: 0x371
Jun 19 18:56:26 arch-zephyrus kernel: nvme nvme0: Abort status: 0x371
```
- See this project to generate an ACPI override ramdisk that works around the issue while you wait for ASUS to publish a fixed BIOS:
+ If you're experiencing this yourself *please* go make a vendor support ticket with ASUS and ask them to fix their
+ BIOS.
+
+ See the project below to generate an ACPI override ramdisk that works around the issue while you wait for ASUS to
+ publish a fixed BIOS:
https://gitlab.com/smbruce/GA503QR-StorageD3Enable-DSDT-Patch
- If you're experiencing this yourself *please* go make a vendor support ticket with ASUS and ask them to fix their BIOS.
See the commit log for full version history and changes.