aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorScott B2021-11-01 17:25:12 -0700
committerScott B2021-11-02 14:39:09 -0700
commitc610bb3248bd787f4975ad5c37aed2eaf5d4a8ca (patch)
tree2a3dcba0147d4d83be906a21dadc71624d193d4c
parent851816a8bd6550c5e5263c35202451f46a8a6b5b (diff)
downloadaur-c610bb3248bd787f4975ad5c37aed2eaf5d4a8ca.tar.gz
patch: Add r8169 PCI IDs for the 2021 G14?/G15
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD4
-rw-r--r--r8169-Add-device-10ec-8162-to-driver-r8169.patch31
3 files changed, 37 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b0ace4a1ecff..8ddda1738090 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -27,6 +27,7 @@ pkgbase = linux-xanmod-rog
source = hwmon-k10temp-support-Zen3-APUs.patch
source = cfg80211-dont-WARN-if-a-self-managed-device.patch
source = r8152-fix-spurious-wakeups-from-s0i3.patch
+ source = r8169-Add-device-10ec-8162-to-driver-r8169.patch
source = asus-wmi-Add-panel-overdrive-functionality.patch
source = asus-wmi-Add-dgpu-disable-method.patch
source = asus-wmi-Add-egpu-enable-method.patch
@@ -66,6 +67,7 @@ pkgbase = linux-xanmod-rog
sha256sums = de8c9747637768c4356c06aa65c3f157c526aa420f21fdd5edd0ed06f720a62e
sha256sums = 3d8961438b5c8110588ff0b881d472fc71a4304d306808d78a4055a4150f351e
sha256sums = f47a5a5e329e410a0ae7d46b450707d5575a4deda5b3b58281f5eca14938fb21
+ sha256sums = e4e55dd548c7689596a7c5c42e49c8f072bd2613bd416c6910b5c6410120eb1d
sha256sums = 1ab75535772c63567384eb2ac74753e4d5db2f3317cb265aedf6151b9f18c6c2
sha256sums = 8cc771f37ee08ad5796e6db64f180c1415a5f6e03eb3045272dade30ca754b53
sha256sums = f3461e7cc759fd4cef2ec5c4fa15b80fa6d37e16008db223f77ed88a65aa938e
diff --git a/PKGBUILD b/PKGBUILD
index 13a31135ea5d..8301a86cd0ff 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -125,6 +125,9 @@ source=("https://cdn.kernel.org/pub/linux/kernel/v${_branch}/linux-${_major}.tar
# r8152 s0i3 wake fix
"r8152-fix-spurious-wakeups-from-s0i3.patch"
+ # r8169 hwIDs for the G14?/G15
+ "r8169-Add-device-10ec-8162-to-driver-r8169.patch"
+
# ASUS ROG enablement
"asus-wmi-Add-panel-overdrive-functionality.patch" # landing in 5.15
"asus-wmi-Add-dgpu-disable-method.patch" # "
@@ -173,6 +176,7 @@ sha256sums=('7e068b5e0d26a62b10e5320b25dce57588cbbc6f781c090442138c9c9c3271b2'
'de8c9747637768c4356c06aa65c3f157c526aa420f21fdd5edd0ed06f720a62e'
'3d8961438b5c8110588ff0b881d472fc71a4304d306808d78a4055a4150f351e'
'f47a5a5e329e410a0ae7d46b450707d5575a4deda5b3b58281f5eca14938fb21'
+ 'e4e55dd548c7689596a7c5c42e49c8f072bd2613bd416c6910b5c6410120eb1d'
'1ab75535772c63567384eb2ac74753e4d5db2f3317cb265aedf6151b9f18c6c2'
'8cc771f37ee08ad5796e6db64f180c1415a5f6e03eb3045272dade30ca754b53'
'f3461e7cc759fd4cef2ec5c4fa15b80fa6d37e16008db223f77ed88a65aa938e'
diff --git a/r8169-Add-device-10ec-8162-to-driver-r8169.patch b/r8169-Add-device-10ec-8162-to-driver-r8169.patch
new file mode 100644
index 000000000000..08fd526045ae
--- /dev/null
+++ b/r8169-Add-device-10ec-8162-to-driver-r8169.patch
@@ -0,0 +1,31 @@
+From 72f898ca0ab85fde6facf78b14d9f67a4a7b32d1 Mon Sep 17 00:00:00 2001
+From: Janghyub Seo <jhyub06@gmail.com>
+Date: Tue, 26 Oct 2021 07:12:42 +0000
+Subject: [PATCH] r8169: Add device 10ec:8162 to driver r8169
+
+This patch makes the driver r8169 pick up device Realtek Semiconductor Co.
+, Ltd. Device [10ec:8162].
+
+Signed-off-by: Janghyub Seo <jhyub06@gmail.com>
+Suggested-by: Rushab Shah <rushabshah32@gmail.com>
+Link: https://lore.kernel.org/r/1635231849296.1489250046.441294000@gmail.com
+Signed-off-by: Jakub Kicinski <kuba@kernel.org>
+---
+ drivers/net/ethernet/realtek/r8169_main.c | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/drivers/net/ethernet/realtek/r8169_main.c b/drivers/net/ethernet/realtek/r8169_main.c
+index 46a6ff9a782d..2918947dd57c 100644
+--- a/drivers/net/ethernet/realtek/r8169_main.c
++++ b/drivers/net/ethernet/realtek/r8169_main.c
+@@ -157,6 +157,7 @@ static const struct pci_device_id rtl8169_pci_tbl[] = {
+ { PCI_VDEVICE(REALTEK, 0x8129) },
+ { PCI_VDEVICE(REALTEK, 0x8136), RTL_CFG_NO_GBIT },
+ { PCI_VDEVICE(REALTEK, 0x8161) },
++ { PCI_VDEVICE(REALTEK, 0x8162) },
+ { PCI_VDEVICE(REALTEK, 0x8167) },
+ { PCI_VDEVICE(REALTEK, 0x8168) },
+ { PCI_VDEVICE(NCUBE, 0x8168) },
+--
+2.33.1
+