aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorScott B2022-01-24 18:06:32 -0800
committerScott B2022-01-27 17:49:49 -0800
commitc7945e46fd6ceaa44961e465b3ae83c278828709 (patch)
tree19b205e939c5c8b58140cbb63e639fc3e9b7cf9e
parentdacba94be86b12a9539ee4c845f6ee060d43f550 (diff)
downloadaur-c7945e46fd6ceaa44961e465b3ae83c278828709.tar.gz
pkg: comment cleanup
-rw-r--r--PKGBUILD22
-rw-r--r--xanmod-rog-config8
2 files changed, 14 insertions, 16 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 05dfe3313c8a..b563296cd75f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -112,21 +112,19 @@ source=("https://cdn.kernel.org/pub/linux/kernel/v${_branch}/linux-${_major}.tar
# 5.17 TCP Optimizations included in Xanmod
# 5.17 TCP csum optimization included in Xanmod
- # 5.17 UDP/IPv6 optimizations
+ # 5.17: UDP/IPv6 optimizations
"UDP-IPv6-Optimizations-from-5.17-partial.patch"
- # 5.16: zstd 1.4.10 update stack size regression fixes
- # 5.16: don't drop shared caches on C3 state transitions
- # 5.16 spectre defaults
-
# -- patch from Chromium developers; more accurately report battery state changes
"acpi-battery-Always-read-fresh-battery-state-on-update.patch"
# -- squelch overzealous 802.11 regdomain not set warnings
"cfg80211-dont-WARN-if-a-self-managed-device.patch"
- # ASUS ROG patches
+ # -- Reduce hid-asus object size by consolidating calls
"HID-asus-Reduce-object-size-by-consolidating-calls.patch"
+
+ # 5.17: ASUS ROG laptop custom fan curve support
"v16-asus-wmi-Add-support-for-custom-fan-curves.patch"
# mediatek mt7921 bt/wifi patches
@@ -199,6 +197,7 @@ prepare() {
esac
done
+ # Set kernel version
msg2 "Setting version..."
scripts/setlocalversion --save-scmversion
echo "-$pkgrel" > localversion.99-pkgrel
@@ -206,9 +205,8 @@ prepare() {
# xanmod release localversion
local _xanlver=${xanmod##*\-}
- # pkgver localversion
+ # pkgver localversion, chop the +clang off clang builds
local _localversion=${pkgver##*\.}
- # chop the +clang off clang builds
_localversion=${_localversion%\+*}
# Monkey patch: If we're applying a point release on top of Xanmod official then we'll monkey with the
@@ -218,9 +216,10 @@ prepare() {
sed -Ei "s/xanmod[0-9]+/${_localversion}/" localversion
fi
+ # Apply configuration
msg2 "Applying kernel config..."
- # Applying configuration
cp -vf CONFIGS/xanmod/${_compiler}/config .config
+
# enable LTO_CLANG_THIN
if [ "$_compiler" = "clang" ]; then
msg2 "Enabling Clang ThinLTO ..."
@@ -250,6 +249,7 @@ prepare() {
fi
fi
+ # User set. See at the top of this file
if [ "$use_numa" = "n" ]; then
msg2 "Disabling NUMA..."
scripts/config --disable CONFIG_NUMA
@@ -267,10 +267,10 @@ prepare() {
scripts/config --enable CONFIG_X86_AMD_PSTATE
fi
- # let user choose microarchitecture optimization target;
+ # Let user choose microarchitecture optimization target;
sh "${srcdir}/choose-gcc-optimization.sh" $_microarchitecture
- # apply package config customizations
+ # Apply package config customizations
if [[ -s ${startdir}/xanmod-rog-config ]]; then
msg2 "Applying package config customization..."
bash -x "${startdir}/xanmod-rog-config"
diff --git a/xanmod-rog-config b/xanmod-rog-config
index 2be1d3c0ac60..f363d14ab78b 100644
--- a/xanmod-rog-config
+++ b/xanmod-rog-config
@@ -11,9 +11,7 @@
# WARNING: DO NOT EDIT THIS FILE, it will be over-written by future updates -- use myconfig instead
#
-# XXX: As this kernel package is primarily targeted at ASUS laptops we default to schedutil so the machine properly
-# XXX: clocks down. Consider using 'ondemand' to trade efficiency for performance when needed
-
+# XXX: Switch to a more power-friendly cpufreq default, this is a laptop-focused kernel package
scripts/config --disable CONFIG_CPU_FREQ_DEFAULT_GOV_PERFORMANCE \
--enable CONFIG_CPU_FREQ_DEFAULT_GOV_SCHEDUTIL
@@ -35,6 +33,7 @@ scripts/config --enable CONFIG_DEBUG_INFO \
--enable CONFIG_DEBUG_INFO_BTF \
--enable CONFIG_DEBUG_INFO_BTF_MODULES
+# sync up some BPF defaults with mainline
# FIXME: BPF preloading is still causing boot-time errors for people, disable for now
#scripts/config --enable CONFIG_BPF_PRELOAD \
# --module CONFIG_BPF_PRELOAD_UMD \
@@ -81,8 +80,7 @@ scripts/config --enable CONFIG_TRACEPOINTS \
--enable CONFIG_PCIE_ECRC \
--enable CONFIG_PCI_P2PDMA
-# XXX: I'm going to make an opinionated decision here and save everyone some compilation time
-# XXX: on drivers almost no-one is going to use; if you need any of theese turn them on in myconfig
+# XXX: switch off drivers we're probably not going to use
scripts/config --disable CONFIG_INFINIBAND \
--disable CONFIG_DRM_NOUVEAU \
--disable CONFIG_PCMCIA_WL3501 \