aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorScott B2021-10-01 08:29:39 -0700
committerAntoine Viallon2021-10-25 10:18:37 +0200
commitca4f636aa1d4fcaabac27dd8648db6ebaf81e6c7 (patch)
tree4b253dabac624e8b2cdcd34547e65d7f468b5dbe
parentccbdadfaf8e8c3397c040ca4e3d5be41e8c4e571 (diff)
downloadaur-ca4f636aa1d4fcaabac27dd8648db6ebaf81e6c7.tar.gz
update s0ix patches
-rw-r--r--.SRCINFO4
-rw-r--r--9001-v5.14.9-s0ix-patch-2021-10-01.patch (renamed from 9001-v5.14.9-s0ix-patch-2021-09-30.patch)66
-rw-r--r--PKGBUILD4
3 files changed, 66 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1b3d1b8f5949..ffcebc5ac9be 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -49,7 +49,7 @@ pkgbase = linux-xanmod-rog
source = 1-2-Bluetooth-btusb-Add-Mediatek-MT7921-support-for-Foxconn.patch
source = 2-2-Bluetooth-btusb-Add-Mediatek-MT7921-support-for-IMC-Network.patch
source = Bluetooth-btusb-Add-support-for-IMC-Networks-Mediatek-Chip.patch
- source = 9001-v5.14.9-s0ix-patch-2021-09-30.patch
+ source = 9001-v5.14.9-s0ix-patch-2021-10-01.patch
validpgpkeys = ABAF11C65A2970B130ABE3C479BE3E4300411886
validpgpkeys = 647F28654894E3BD457199BE38DBBDC86092693E
sha256sums = 7e068b5e0d26a62b10e5320b25dce57588cbbc6f781c090442138c9c9c3271b2
@@ -85,7 +85,7 @@ pkgbase = linux-xanmod-rog
sha256sums = 236cdadf0b1472945c0d7570caeed7b95929aabed6872319c9d0969a819689e9
sha256sums = cc2aa580d69801aa1afb0d72ecf094fe13c797363d3d5928c868d3a389910b7b
sha256sums = 292a7e32b248c7eee6e2f5407d609d03d985f367d329adb02b9d6dba1f85b44c
- sha256sums = afba1c30063692c0ad836c00bfb29bc5a9d975cfdf4653498038eff803cd97aa
+ sha256sums = dd5b0df91e7c17e26af4839b3a23ba5e8850d329aeb28137ec6468502418f2bd
pkgname = linux-xanmod-rog
pkgdesc = The Linux kernel and modules with Xanmod and ASUS ROG laptop patches (Zephyrus G14, G15, etc)
diff --git a/9001-v5.14.9-s0ix-patch-2021-09-30.patch b/9001-v5.14.9-s0ix-patch-2021-10-01.patch
index 0132e9139703..b623f875f138 100644
--- a/9001-v5.14.9-s0ix-patch-2021-09-30.patch
+++ b/9001-v5.14.9-s0ix-patch-2021-10-01.patch
@@ -1,10 +1,28 @@
-From f2ec21c0b73d37ce252afc4d74072f80fe336edf Mon Sep 17 00:00:00 2001
+From 6b1881a52169644ae314fa082a2c4daa152c46b3 Mon Sep 17 00:00:00 2001
From: Scott B <arglebargle@arglebargle.dev>
-Date: Thu, 30 Sep 2021 04:11:49 -0700
-Subject: [PATCH] v5.14.9 s0ix patch 2021-09-30
+Date: Fri, 1 Oct 2021 08:26:54 -0700
+Subject: [PATCH] v5.14.9 s0ix patch 2021-10-01
Squashed commit of the following:
+commit 9d22c6f69dce036dab2a4d17911bc2ce84df9537
+Author: Lijo Lazar <lijo.lazar@amd.com>
+Date: Fri Oct 1 18:16:25 2021 +0800
+
+ drm/amdgpu: During s0ix don't wait to signal GFXOFF
+
+ In the rare event when GFX IP suspend coincides with a s0ix entry, don't
+ schedule a delayed work, instead signal PMFW immediately to allow GFXOFF
+ entry. GFXOFF is a prerequisite for s0ix entry. PMFW needs to be
+ signaled about GFXOFF status before amd-pmc module passes OS HINT
+ to PMFW telling that everything is ready for a safe s0ix entry.
+
+ Bug: https://gitlab.freedesktop.org/drm/amd/-/issues/1712
+
+ Signed-off-by: Lijo Lazar <lijo.lazar@amd.com>
+ Reviewed-by: Alex Deucher <alexander.deucher@amd.com>
+ Reviewed-by: Mario Limonciello <mario.limonciell@amd.com>
+
commit 0c5d3b01b4d999992439ca9f749e202cc0cc8578
Author: Sanket Goswami <Sanket.Goswami@amd.com>
Date: Tue Sep 21 17:30:20 2021 +0530
@@ -139,12 +157,13 @@ Date: Tue Jul 20 23:31:31 2021 -0700
Signed-off-by: Mario Limonciello <mario.limonciello at amd.com>
---
drivers/acpi/processor_idle.c | 3 +-
+ drivers/gpu/drm/amd/amdgpu/amdgpu_gfx.c | 14 ++-
.../gpu/drm/amd/pm/swsmu/smu11/smu_v11_0.c | 3 +
.../gpu/drm/amd/pm/swsmu/smu12/smu_v12_0.c | 3 +
drivers/pinctrl/pinctrl-amd.c | 19 ++--
drivers/pinctrl/pinctrl-amd.h | 1 +
drivers/platform/x86/amd-pmc.c | 90 +++++++++++++++++--
- 6 files changed, 108 insertions(+), 11 deletions(-)
+ 7 files changed, 120 insertions(+), 13 deletions(-)
diff --git a/drivers/acpi/processor_idle.c b/drivers/acpi/processor_idle.c
index 095c8aca141e..1b6529396371 100644
@@ -160,6 +179,45 @@ index 095c8aca141e..1b6529396371 100644
state->enter_dead = acpi_idle_play_dead;
drv->safe_state_index = count;
}
+diff --git a/drivers/gpu/drm/amd/amdgpu/amdgpu_gfx.c b/drivers/gpu/drm/amd/amdgpu/amdgpu_gfx.c
+index b4ced45301be..1795d448c700 100644
+--- a/drivers/gpu/drm/amd/amdgpu/amdgpu_gfx.c
++++ b/drivers/gpu/drm/amd/amdgpu/amdgpu_gfx.c
+@@ -31,6 +31,8 @@
+ /* delay 0.1 second to enable gfx off feature */
+ #define GFX_OFF_DELAY_ENABLE msecs_to_jiffies(100)
+
++#define GFX_OFF_NO_DELAY 0
++
+ /*
+ * GPU GFX IP block helpers function.
+ */
+@@ -558,6 +560,8 @@ int amdgpu_gfx_enable_kcq(struct amdgpu_device *adev)
+
+ void amdgpu_gfx_off_ctrl(struct amdgpu_device *adev, bool enable)
+ {
++ unsigned long delay = GFX_OFF_DELAY_ENABLE;
++
+ if (!(adev->pm.pp_feature & PP_GFXOFF_MASK))
+ return;
+
+@@ -573,8 +577,14 @@ void amdgpu_gfx_off_ctrl(struct amdgpu_device *adev, bool enable)
+
+ adev->gfx.gfx_off_req_count--;
+
+- if (adev->gfx.gfx_off_req_count == 0 && !adev->gfx.gfx_off_state)
+- schedule_delayed_work(&adev->gfx.gfx_off_delay_work, GFX_OFF_DELAY_ENABLE);
++ if (adev->gfx.gfx_off_req_count == 0 &&
++ !adev->gfx.gfx_off_state) {
++ /* If going to s2idle, no need to wait */
++ if (adev->in_s0ix)
++ delay = GFX_OFF_NO_DELAY;
++ schedule_delayed_work(&adev->gfx.gfx_off_delay_work,
++ delay);
++ }
+ } else {
+ if (adev->gfx.gfx_off_req_count == 0) {
+ cancel_delayed_work_sync(&adev->gfx.gfx_off_delay_work);
diff --git a/drivers/gpu/drm/amd/pm/swsmu/smu11/smu_v11_0.c b/drivers/gpu/drm/amd/pm/swsmu/smu11/smu_v11_0.c
index 0a5d46ac9ccd..626d7c2bdf66 100644
--- a/drivers/gpu/drm/amd/pm/swsmu/smu11/smu_v11_0.c
diff --git a/PKGBUILD b/PKGBUILD
index 8a9ef4a4faef..1e4800b1201e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -151,7 +151,7 @@ source=("https://cdn.kernel.org/pub/linux/kernel/v${_branch}/linux-${_major}.tar
"Bluetooth-btusb-Add-support-for-IMC-Networks-Mediatek-Chip.patch"
# squashed s0ix enablement
- "9001-v5.14.9-s0ix-patch-2021-09-30.patch"
+ "9001-v5.14.9-s0ix-patch-2021-10-01.patch"
)
validpgpkeys=(
'ABAF11C65A2970B130ABE3C479BE3E4300411886' # Linux Torvalds
@@ -191,7 +191,7 @@ sha256sums=('7e068b5e0d26a62b10e5320b25dce57588cbbc6f781c090442138c9c9c3271b2'
'236cdadf0b1472945c0d7570caeed7b95929aabed6872319c9d0969a819689e9'
'cc2aa580d69801aa1afb0d72ecf094fe13c797363d3d5928c868d3a389910b7b'
'292a7e32b248c7eee6e2f5407d609d03d985f367d329adb02b9d6dba1f85b44c'
- 'afba1c30063692c0ad836c00bfb29bc5a9d975cfdf4653498038eff803cd97aa')
+ 'dd5b0df91e7c17e26af4839b3a23ba5e8850d329aeb28137ec6468502418f2bd')
# apply UKSM patch; TODO: note to self: don't forget to update the sum here during major version changes
#