summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoan Figueras2024-03-24 20:13:36 +0100
committerJoan Figueras2024-03-24 20:13:36 +0100
commit9374c87da699b3be16f58c0c26749b90c637069d (patch)
treece7d17f1deb8d658e81a92a3d291a607ec3dee97
parentb5e82fad5e91b4abc2ecfb0f2710f0a79cfc2db3 (diff)
downloadaur-linux-xanmod-rt.tar.gz
6.6.22-rt27-xanmod1
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD14
2 files changed, 11 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e6d5aea3f09a..82d782229108 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = linux-xanmod-rt
pkgdesc = Linux Xanmod real-time version
- pkgver = 6.6.21
+ pkgver = 6.6.22
pkgrel = 1
url = http://www.xanmod.org/
arch = x86_64
@@ -17,13 +17,13 @@ pkgbase = linux-xanmod-rt
options = !strip
source = https://cdn.kernel.org/pub/linux/kernel/v6.x/linux-6.6.tar.xz
source = https://cdn.kernel.org/pub/linux/kernel/v6.x/linux-6.6.tar.sign
- source = patch-6.6.21-rt26-xanmod1.xz::https://sourceforge.net/projects/xanmod/files/releases/rt/6.6.21-rt26-xanmod1/patch-6.6.21-rt26-xanmod1.xz/download
+ source = patch-6.6.22-rt27-xanmod1.xz::https://sourceforge.net/projects/xanmod/files/releases/rt/6.6.22-rt27-xanmod1/patch-6.6.22-rt27-xanmod1.xz/download
source = choose-gcc-optimization.sh
validpgpkeys = ABAF11C65A2970B130ABE3C479BE3E4300411886
validpgpkeys = 647F28654894E3BD457199BE38DBBDC86092693E
sha256sums = d926a06c63dd8ac7df3f86ee1ffc2ce2a3b81a2d168484e76b5b389aba8e56d0
sha256sums = SKIP
- sha256sums = cfa6fc66030488187bd292e239f8045949bcb6b7f9a98f009123eb6e330fa829
+ sha256sums = 21fa004ad4824ed9e80ba5d063be6a62ac3ccf4578575327ae827a8c968343ff
sha256sums = a8b38eb482eb685944757182c4886404abc12703e5e56ec39c7d61298d17d71f
pkgname = linux-xanmod-rt
diff --git a/PKGBUILD b/PKGBUILD
index 8278f1855536..0fc6ec0caf67 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -73,9 +73,9 @@ fi
pkgbase=linux-xanmod-rt
_major=6.6
-pkgver=${_major}.21
+pkgver=${_major}.22
_branch=6.x
-_rt=26
+_rt=27
xanmod=1
_revision=
_sf_branch=rt
@@ -83,7 +83,6 @@ pkgrel=${xanmod}
pkgdesc='Linux Xanmod real-time version'
url="http://www.xanmod.org/"
arch=(x86_64)
-
license=(GPL2)
makedepends=(
bc
@@ -119,7 +118,7 @@ done
sha256sums=('d926a06c63dd8ac7df3f86ee1ffc2ce2a3b81a2d168484e76b5b389aba8e56d0'
'SKIP'
- 'cfa6fc66030488187bd292e239f8045949bcb6b7f9a98f009123eb6e330fa829'
+ '21fa004ad4824ed9e80ba5d063be6a62ac3ccf4578575327ae827a8c968343ff'
'a8b38eb482eb685944757182c4886404abc12703e5e56ec39c7d61298d17d71f')
export KBUILD_BUILD_HOST=${KBUILD_BUILD_HOST:-archlinux}
@@ -223,7 +222,9 @@ prepare() {
fi
fi
+ msg2 "make ${_compiler_flags} olddefconfig"
make ${_compiler_flags} olddefconfig
+ #diff -u CONFIGS/xanmod/gcc/${_config} .config || :
make -s kernelrelease > version
msg2 "Prepared %s version %s" "$pkgbase" "$(<version)"
@@ -239,6 +240,7 @@ prepare() {
build() {
cd linux-${_major}
make ${_compiler_flags} all
+ make -C tools/bpf/bpftool vmlinux.h feature-clang-bpf-co-re=1
}
_package() {
@@ -291,7 +293,7 @@ _package-headers() {
msg2 "Installing build files..."
install -Dt "$builddir" -m644 .config Makefile Module.symvers System.map \
- localversion.* version vmlinux
+ localversion.* version vmlinux tools/bpf/bpftool/vmlinux.h
install -Dt "$builddir/kernel" -m644 kernel/Makefile
install -Dt "$builddir/arch/x86" -m644 arch/x86/Makefile
cp -t "$builddir" -a scripts
@@ -300,7 +302,7 @@ _package-headers() {
install -Dt "$builddir/tools/objtool" tools/objtool/objtool
# required when DEBUG_INFO_BTF_MODULES is enabled
- if [ -f "tools/bpf/resolve_btfids/resolve_btfids" ]; then install -Dt "$builddir/tools/bpf/resolve_btfids" tools/bpf/resolve_btfids/resolve_btfids ; fi
+ install -Dt "$builddir/tools/bpf/resolve_btfids" tools/bpf/resolve_btfids/resolve_btfids
msg2 "Installing headers..."
cp -t "$builddir" -a include